Problem K: 零起点学算法107——统计元音

#include<stdio.h>
int main()
{
    int n;
    char a[100];
    while(scanf("%d%*c",&n)!=EOF)
    {
        while(n--)
        {
            int num1=0,num2=0,num3=0,num4=0,num5=0;
            gets(a);
            for(int i=0;a[i]!=‘\0‘;i++)
            {
                switch(a[i])      //在这用switch语句会比较方便
                {
                    case ‘a‘: num1++;break;
                    case ‘e‘: num2++;break;
                    case ‘i‘: num3++;break;
                    case ‘o‘: num4++;break;
                    case ‘u‘: num5++;break;
                }
            }
            printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n\n",num1,num2,num3,num4,num5);
        }

    }
    return 0;
}

原文地址:https://www.cnblogs.com/chenlong991223/p/9977378.html

时间: 2024-11-10 10:56:21

Problem K: 零起点学算法107——统计元音的相关文章

1166: 零起点学算法73——统计元音

1166: 零起点学算法73--统计元音 Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lldSubmitted: 1082  Accepted: 402[Submit][Status][Web Board] Description 统计每个元音字母在字符串中出现的次数. Input 输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串,只由小写字母组成. Output 对于每个测试实例输出5行

武汉科技大学ACM :1003: 零起点学算法67——统计字母数字等个数

Problem Description 输入一串字符,统计这串字符里的字母个数,数字个数,空格字数以及其他字符(最多不超过100个字符) Input 多组测试数据,每行一组 Output 每组输出一行,分别是字母个数,数字个数,空格字数以及其他字符个数 Sample Input I am a student in class 1. I think I can! Sample Output 18 1 6 1 10 0 3 1 HINT char str[100];//定义字符型数组 while(g

Problem F: 零起点学算法85——数组中插入一个数

#include<stdio.h> int main() { int n,a[50],b[50]; while(scanf("%d",&n)!=EOF) { for(int i=0;i<n;i++) { scanf("%d",&a[i]); } int m,k,j=0; scanf("%d%d",&m,&k); for(int i=0;i<n;i++) { if(a[i]<m) { b

Problem J: 零起点学算法89——程序设计竞赛

#include<stdio.h> //选择排序法 int main(){ int n,a[50]; while(scanf("%d",&n)!=EOF){ for(int i=0;i<n;i++){ scanf("%d",&a[i]); } for(int i=0;i<n-1;i++){ int k=i,t; for(int j=i+1;j<n;j++) if(a[k]<a[j]) k=j; if(k!=i){

Problem H: 零起点学算法109——单数变复数

#include <stdio.h> #include<string.h> int main(void) { int n; char word[100]; scanf("%d",&n); getchar(); int i; while(n!=0) { gets(word); int k=strlen(word); if(word[k-1]=='y') strcat(word,"es"); else if(word[k-2]=='s'|

Problem O: 零起点学算法10——求圆柱体的表面积

#include<stdio.h> int main() { float r,h,pi; pi=3.1415926; scanf("%f %f",&r,&h); printf("Area=""%.3f",2*pi*r*r+2*pi*r*h); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720035.html

Problem U: 零起点学算法19——输出特殊值

#include<stdio.h> int main() { printf("%%d"); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720422.html

Problem V: 零起点学算法20——输出特殊值II

#include<stdio.h> int main() { printf("\\n"); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/p/9720428.html

Problem S: 零起点学算法14——三位数反转

#include<stdio.h> #include<stdlib.h> int main() { int a,b,c,s; scanf("%d",&s); a=s/100; b=s%100/10; c=s%100%10; printf("%d%d%d",c,b,a); system("pause"); return 0; } 原文地址:https://www.cnblogs.com/chenlong991223/