POJ - 2524 Ubiquitous Religions(简单并查集)

Ubiquitous Religions

Time Limit: 5000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

Submit Status

Description

当今世界有很多不同的宗教,很难通晓他们。你有兴趣找出在你的大学里有多少种不同的宗教信仰。

你知道在你的大学里有n个学生(0 < n <= 50000) 。你无法询问每个学生的宗教信仰。此外,许多学生不想说出他们的信仰。避免这些问题的一个方法是问m(0 <= m <= n(n - 1)/ 2)对学生, 问他们是否信仰相同的宗教( 例如他们可能知道他们两个是否去了相同的教堂) 。在这个数据中,你可能不知道每个人信仰的宗教,但你可以知道校园里最多可能有多少个不同的宗教。假定每个学生最多信仰一个宗教。

Input

有多组数据。对于每组数据:

第一行:两个整数n和m。

以下m行:每行包含两个整数i和j,表示学生i和j信仰相同的宗教。学生编号从1到n。

输入的最后一行中,n = m = 0。

Output

对于每组测试数据,输出一行,输出数据序号( 从1开始) 和大学里不同宗教的最大数量。(参见样例)

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

输入巨大,推荐使用scanf。

简单并查集,求无向图连通分量。

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int MAXN = 50000 + 50;
int parent[MAXN];

int n, m;

void make_set()
{
	for (int i = 0; i <= n; i++)
		parent[i] = -1;
}

int find_set(int t)
{
	if (parent[t] == -1)
		return t;
	else
		return parent[t] = find_set(parent[t]);
}

void union_set(int a, int b)
{
	int t1 = find_set(a);
	int t2 = find_set(b);
	if (t1 != t2)
		parent[t2] = t1;
}

int main()
{
	int casen;
	casen = 1;
	while (scanf("%d%d", &n, &m) != EOF&&n)
	{
		int a, b;
		make_set();
		for (int i = 0; i < m; i++)
		{
			scanf("%d%d", &a, &b);
			union_set(a, b);
		}
		int sum = 0;
		for (int i = 1; i <= n; i++)
		{
			if (parent[i] == -1)
				sum++;
		}
		printf("Case %d: ", casen);
		casen++;
		printf("%d\n", sum);
	}
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-12-11 04:40:55

POJ - 2524 Ubiquitous Religions(简单并查集)的相关文章

POJ 2524 Ubiquitous Religions (简单并查集,三种方式)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 30791   Accepted: 14928 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

poj 2524:Ubiquitous Religions(并查集,入门题)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23997   Accepted: 11807 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

poj 2524 Ubiquitous Religions(并查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23168   Accepted: 11404 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

POJ 2524 Ubiquitous Religions 【并查集】

解题思路:输入总人数 n,和m组数据:即和杭电畅通工程相类似,对这m组数据做合并操作后,求最后一共有多少块区域. #include<stdio.h> int pre[50001]; int find(int root) { if(root!=pre[root]) pre[root]=find(pre[root]); return pre[root]; } void unionroot(int x,int y) { int root1,root2; root1=find(x); root2=fi

POJ 2524 Ubiquitous Religions (幷查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23090   Accepted: 11378 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

POJ 2524 Ubiquitous Religions Union Find 并查集

本题是标准的并查集了,最后利用这些集求有多少独立集. 所以这里也写个标准程序过了. 最后查找独立集合: 看有多少个节点的父母节点是自己的,那么就是独立集合了.自己做自己的父母当然最独立的了,没有任何依赖,呵呵. #include <stdio.h> const int MAX_N = 50001; //const int MAX_M = MAX_N/2 * (MAX_N-1) + 1; int N, M; struct SubSet { int p, r; }; SubSet sub[MAX_

SDUT Ubiquitous Religions(并查集+哈希)

Ubiquitous Religions Time Limit: 1000MS Memory limit: 65536K 题目描述 There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your

POJ 2524 Ubiquitous Religions(宗教种类:并差集)

链接:http://poj.org/problem?id=2524 Ubiquitous Religions Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 27774 Accepted: 13610 Description There are so many different religions in the world today that it is difficult to keep track of them al

POJ Ubiquitous Religions (并查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 25255   Accepted: 12454 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi