Oil Deposits 搜索 bfs 强联通

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output

0 1 2 2

#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 100
const int inf=0x7fffffff;   //无限大
int dx[8]={1,-1,0,0,1,-1,1,-1};
int dy[8]={0,0,1,-1,1,-1,-1,1};
int vis[120][120];
int n,m;
int ans=0;
struct point
{
    int x;
    int y;
};
void bfs(int x,int y)
{
    if(vis[x][y]!=1)
        return;
    ans++;
    queue<point> q;
    point a;
    a.x=x;
    a.y=y;
    q.push(a);
    point now,next;
    now.x=x;
    now.y=y;
    while(!q.empty())
    {
        now=q.front();
        for(int i=0;i<8;i++)
        {
            next.x=now.x+dx[i];
            next.y=now.y+dy[i];
            if(next.x<0||next.x>=n)
                continue;
            if(next.y<0||next.y>=m)
                continue;
            if(vis[next.x][next.y]!=1)
                continue;
            vis[next.x][next.y]=0;
            q.push(next);
        }
        q.pop();
    }
}
int main()
{
    while(cin>>n>>m)
    {
    memset(vis,0,sizeof(vis));
        if(n==0&&m==0)
            break;
    char a;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            cin>>a;
            if(a==‘*‘)
                vis[i][j]=-1;
            else
                vis[i][j]=1;
        }
    }
    ans=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(vis[i][j]==1)
                bfs(i,j);
        }
    }
    cout<<ans<<endl;
    }
    return 0;
}
时间: 2024-11-05 14:43:06

Oil Deposits 搜索 bfs 强联通的相关文章

(简单) POJ 1562 Oil Deposits,BFS。

Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It

F - Oil Deposits 【BFS】

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyze

UVA Oil Deposits (BFS)

 Oil Deposits  The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.

HDU 1241 &lt;Oil Deposits&gt; &lt;搜索&gt;

Description GeoSurvComp地质调查公司负责探测地下石油储藏. GeoSurvComp现在在一块矩形区域探测石油,并把这个大区域分成了很多小块.他们通过专业设备,来分析每个小块中是否蕴藏石油.如果这些蕴藏石油 的小方格相邻,那么他们被认为是同一油藏的一部分.在这块矩形区域,可能有很多油藏.你的任务是确定有多少不同的油藏. Input 输入可能有多个矩形区域(即可能有多组测试).每个矩形区域的起始行包含m和n,表示行和列的数量,1<=n,m<=100,如果m =0表示输入的结束

A - Oil Deposits(搜索)

搜索都不熟练,所以把以前写的一道搜索复习下,然后下一步整理搜索和图论和不互质的中国剩余定理的题 Description GeoSurvComp地质调查公司负责探测地下石油储藏. GeoSurvComp现在在一块矩形区域探测石油,并把这个大区域分成了很多小块.他们通过专业设备,来分析每个小块中是否蕴藏石油.如果这些蕴藏石油的小方格相邻,那么他们被认为是同一油藏的一部分.在这块矩形区域,可能有很多油藏.你的任务是确定有多少不同的油藏. Input 输入可能有多个矩形区域(即可能有多组测试).每个矩形

UVa 572 - Oil Deposits 【DFS】联通块问题

题目链接 题目大意: 求图中@连通块的个数,只要两个@相邻就算它们是连通的(斜方向的也算相邻) #include <stdio.h> #include <string.h> char map[110][110]; int vis[110][110]; int n, m, ans; int dir[8][2] = { {0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1} }; void dfs(int a,int b) { int

HDU 搜索练习 Oil Deposits

Oil Deposits Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 61 Accepted Submission(s) : 25 Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil

PKU 1562/HDU 1241 Oil Deposits(原油有多少块区域---BFS,DFS)

Oil Deposits Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region o

Oil Deposits(杭电oj1241)(BFS)

Oil Deposits Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13013    Accepted Submission(s): 7540 Problem Description The GeoSurvComp geologic survey company is responsible for detecting under