HDU 2767 Proving Equivalences (强联通)

http://acm.hdu.edu.cn/showproblem.php?pid=2767

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2926    Accepted Submission(s): 1100

Problem Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.

2. Ax = b has exactly one solution for every n × 1 matrix b.

3. Ax = b is consistent for every n × 1 matrix b.

4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the
four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a
lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.

* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

Source

NWERC 2008

题意:

要证明等价性(要求所有命题都是等价的),现已给出部分证明(u->v),问最少还需多少步才能完成目标。

分析:

我们的目标是(没有蛀牙)使得整个图是强联通的,已经有部分有向边u->v。我们先用强联通缩点,得到一个有向无环图,设入度为0的点有a个,出度为0的点有b个,我们只要max(a,b)步就能完成目标(数学归纳法可证)。

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define maxm 50000
#define maxn 20007

using namespace std;

int in[maxn],out[maxn];
int fir[maxn];
int u[maxm],v[maxm],nex[maxm];
int sccno[maxn],pre[maxn],low[maxn];
int st[maxn],top;
int scc_cnt,dfs_clock;
int n,m;

void tarjan_dfs(int _u)
{
    pre[_u]=low[_u]=++dfs_clock;
    st[++top]=_u;
    for (int e=fir[_u];~e;e=nex[e])
    {
        int _v=v[e];
        if (!pre[_v])
        {
            tarjan_dfs(_v);
            low[_u]=min(low[_u],low[_v]);
        }
        else
        {
            if (!sccno[_v])
            {
                low[_u]=min(low[_u],pre[_v]);
            }
        }
    }

    if (pre[_u]==low[_u])
    {
        ++scc_cnt;
        while (true)
        {
            int x=st[top--];
            sccno[x]=scc_cnt;
            if (x==_u) break;
        }
    }
}

void find_scc()
{
    scc_cnt=dfs_clock=0;top=-1;
    memset(pre,0,sizeof pre);
    memset(sccno,0,sizeof sccno);
    for (int i=1;i<=n;i++)
    {
        if (!pre[i])    tarjan_dfs(i);
    }
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("/home/fcbruce/文档/code/t","r",stdin);
    #endif // ONLINE_JUDGE

    int T_T;
    scanf("%d",&T_T);
    while (T_T--)
    {

        scanf("%d %d",&n,&m);
        memset(fir,-1,sizeof fir);
        for (itn i=0;i<m;i++)
        {
            scanf("%d %d",&u[i],&v[i]);
            nex[i]=fir[u[i]];
            fir[u[i]]=i;
        }

        find_scc();

        if (scc_cnt==1)
        {
            printf("%d\n",0);
            continue;
        }

        memset(in,0,sizeof in);
        memset(out,0,sizeof out);
        for (int i=0;i<m;i++)
        {
            if (sccno[u[i]]==sccno[v[i]])   continue;

            in[sccno[v[i]]]++;
            out[sccno[u[i]]]++;
        }

        int a=0,b=0;
        for (itn i=1;i<=scc_cnt;i++)
        {
            if (in[i]==0)   a++;
            if (out[i]==0)  b++;
        }

        printf("%d\n",max(a,b));
    }

    return 0;
}

HDU 2767 Proving Equivalences (强联通),布布扣,bubuko.com

时间: 2024-08-07 19:13:51

HDU 2767 Proving Equivalences (强联通)的相关文章

HDU 2767 Proving Equivalences(强联通缩点)

Proving Equivalences Problem Description Consider the following exercise, found in a generic linear algebra textbook. Let A be an n × n matrix. Prove that the following statements are equivalent: 1. A is invertible.2. Ax = b has exactly one solution

hdu 2767 Proving Equivalences 强连通缩点

给出n个命题,m个推导,问最少增加多少条推导,可以使所有命题都能等价(两两都能互推) 既给出有向图,最少加多少边,使得原图变成强连通. 首先强连通缩点,对于新图,每个点都至少要有一条出去的边和一条进来的边(这样才能保证它能到任意点和任意点都能到它) 所以求出新图中入度为0的个数,和出度为0的个数,添加的边就是从出度为0的指向入度为0的.这样还会有一点剩余,剩余的就乱连就行了. 所以只要求出2者的最大值就OK. #include <iostream> #include<cstring>

HDU 2767 Proving Equivalences(强连通 Tarjan+缩点)

HDU 2767 Proving Equivalences(强连通 Tarjan+缩点) ACM 题目地址:HDU 2767 题意: 给定一张有向图,问最少添加几条边使得有向图成为一个强连通图. 分析: Tarjan入门经典题,用tarjan缩点,然后就变成一个有向无环图(DAG)了. 我们要考虑的问题是让它变成强连通,让DAG变成强连通就是把尾和头连起来,也就是入度和出度为0的点. 统计DAG入度和出度,然后计算头尾,最大的那个就是所求. 代码: /* * Author: illuz <iil

hdu 2767 Proving Equivalences(强连通入门题)

1 /************************************************* 2 Proving Equivalences(hdu 2767) 3 强连通入门题 4 给个有向图,求至少加多少条边使得图是所有点都是强连通的 5 由a->b->c->a易知n个点至少要n条边,每个出度和入度都要大 6 于1.先求所有所有强连通分量,把每个强连通分量看成一个点 7 在找每个点的出度和入度,最后还差的出度和入度的最大值就是 8 答案. 9 10 ************

HDU 2767 Proving Equivalences

 Proving Equivalences Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3676    Accepted Submission(s): 1352 Problem Description Consider the following exercise, found in a generic linear algeb

HDU 2767 Proving Equivalences 图论scc缩点

问一个图,最少需要加多少条边,使得这个图强联通. Tarjan缩点,重建图,令a=入度为0的scc个数,b=出度为0的scc个数,ans=max(a,b): 若图scc=1,本身强联通,ans=0: 1 #include<bits/stdc++.h> 2 using namespace std; 3 const int MAXN = 20010;//点数 4 const int MAXM = 200100;//边数 5 struct Edge { 6 int to,next; 7 }edge[

HDU 2767 Proving Equivalences (Tarjan縮點)

Time limit :2000 ms Memory limit :32768 kB Consider the following exercise, found in a generic linear algebra textbook. Let A be an n × n matrix. Prove that the following statements are equivalent: 1. A is invertible. 2. Ax = b has exactly one soluti

HDU 2767-Proving Equivalences(强联通+缩点)

题目地址:HDU 2767 题意:给一张有向图,求最少加几条边使这个图强连通. 思路:先求这张图的强连通分量,如果为1,则输出0(证明该图不需要加边已经是强连通的了),否则缩点.遍历原图的所有边,如果2个点在不同的强连通分量里面,建边,构成一张新图.统计新图中点的入度和出度,取入度等于0和出度等于0的最大值(因为求强连通缩点后,整张图就变成了一个无回路的有向图,要使之强连通,只需要将入度=0和出度=0的点加边即可,要保证加边后没有入度和出度为0的点,所以取两者最大值) *#include <st

hdoj 2767 Proving Equivalences【求scc&amp;&amp;缩点】【求最少添加多少条边使这个图成为一个scc】

Proving Equivalences Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4263    Accepted Submission(s): 1510 Problem Description Consider the following exercise, found in a generic linear algebra t