1119 Pre- and Post-order Traversals(30 分)

1119 Pre- and Post-order Traversals(30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

给出前序和后序遍历,看是否能确定一棵树,前序遍历是根左右,后序是左右根所以通过对比可以先确定根然后左右子树就是中间夹的那一块,由于每一棵子树都满足这个条件,所以能把左右子树给分开,可以递归去构建左右子树,如果只有一棵子树,左右子树必有一为空,这样这棵树就是不确定的,至于输出,统一当成左子树或右子树。

代码:

#include <stdio.h>
int n,pre[31],post[31],in[31],c,flag = 1;
void getin(int prel,int prer,int postl,int postr) {
    if(prel > prer)return;
    int d = pre[prel ++];///根结点
    postr --;///避开根结点前移
    int t = -1;
    for(int i = postl;i <= postr;i ++) {
        if(post[i] == pre[prel]) {///确定左子树范围
            t = i;
            break;
        }
    }
    ///中序遍历
    if(t != -1)getin(prel,prel + t - postl,postl,t);///左子树
    in[c ++] = d;///根
    if(t != -1 && t != postr)getin(prel + t - postl + 1,prer,t + 1,postr);///右子树
    else if(t != -1)flag = 0;///没有右子树 实际上子树既可以是左子树也可以是右子树
}
int main() {
    scanf("%d",&n);
    for(int i = 0;i < n;i ++) {
        scanf("%d",&pre[i]);
    }
    for(int i = 0;i < n;i ++) {
        scanf("%d",&post[i]);
    }
    getin(0,n - 1,0,n - 1);
    printf("%s\n",flag ? "Yes" : "No");
    for(int i = 0;i < c;i ++) {
        if(i)printf(" %d",in[i]);
        else printf("%d",in[i]);
    }
    putchar(‘\n‘);
}


1119 Pre- and Post-order Traversals(30 分)

原文地址:https://www.cnblogs.com/8023spz/p/9272856.html

时间: 2024-11-01 07:55:52

1119 Pre- and Post-order Traversals(30 分)的相关文章

1119 Pre- and Post-order Traversals (30 分)

1119 Pre- and Post-order Traversals (30 分) Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder travers

[二叉树建树]1119. Pre- and Post-order Traversals (30) (前序和后序遍历建立二叉树)

1119. Pre- and Post-order Traversals (30) Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversa

PAT甲级——1131 Subway Map (30 分)

可以转到我的CSDN查看同样的文章https://blog.csdn.net/weixin_44385565/article/details/89003683 1131 Subway Map (30 分) In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing

PAT Advanced 1020 Tree Traversals (25分)

1020 Tree Traversals (25分) Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Construct a tree from Inorder and Level order traversals

Given inorder and level-order traversals of a Binary Tree, construct the Binary Tree. Following is an example to illustrate the problem. BinaryTree Input: Two arrays that represent Inorder and level order traversals of a Binary Treein[]    = {4, 8, 1

PAT Advanced Level 1064 Complete Binary Search Tree (30)(30 分)

1064 Complete Binary Search Tree (30)(30 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of

04-树6 Complete Binary Search Tree (30 分)

04-树6 Complete Binary Search Tree (30 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a

1127 ZigZagging on a Tree (30 分)树的层次遍历

1127 ZigZagging on a Tree (30 分) Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to pr

1064 Complete Binary Search Tree (30 分)完全二叉树

1064 Complete Binary Search Tree (30 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a n