POJ3684-Physics Experiment 弹性碰撞

Physics Experiment

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3576   Accepted: 1270   Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20

题意:N个半径为R厘米的小球排在距离地面高度H米的管道里,将小球释放,每个球间隔一秒,问T秒后,每个小球距离地面的高度。(球与球,球与地面的碰撞都是弹性碰撞)思路:先考虑单个球的情况,小球需要t=sqrt(2*H/g)秒才能落地,令k=T/t;小球离地面的距离设为y   y=H-0.5*g*(T-kt)^2 ,k是偶数 
     y=H-0.5*g*(kt+t-T)^2 ,k是奇数

    考虑多个小球,因为是弹性碰撞,所以可以认为两个小球没有碰撞,直接穿过
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
#define fio ios::sync_with_stdio(false);cin.tie(0);cout.tie(0)
#define maxn 109
using namespace std;

int c;
int n, T;
int h, r;
double y[maxn];

double calh(int i) {
    int ralT = T - (i - 1);
    if (ralT < 0) return h;
    double t = sqrt(h / 5.0);
    int k = (int)(ralT / t);
    double y;
    if (k % 2 == 0) {
        y = h - 5.0 * (ralT - k * t)*(ralT - k * t);
    }
    else {
        y = h - 5.0 * (k * t + t - ralT)*(k * t + t - ralT);
    }
    return y;
}

int main() {
    cin >> c;
    while (c--)
    {
        cin >> n >> h >> r >> T;
        for (int i = 1; i <= n; i++) {
            y[i] = calh(i);
        }
        sort(y + 1, y + 1 + n);
        for (int i = 1; i<n; i++) {
            printf("%.2f ", y[i] + 2 * r*(i - 1) / 100.0);
        }
        printf("%.2f\n", y[n] + 2 * r*(n - 1) / 100.0);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/the-way-of-cas/p/9464146.html

时间: 2024-08-29 00:39:53

POJ3684-Physics Experiment 弹性碰撞的相关文章

poj 3684 Physics Experiment 弹性碰撞

Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1489   Accepted: 509   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment,

POJ3684 Physics Experiment 【物理】

Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1031   Accepted: 365   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment,

Greedy:Physics Experiment(弹性碰撞模型)(POJ 3848)

物理实验 题目大意:有一个与地面垂直的管子,管口与地面相距H,管子里面有很多弹性球,从t=0时,第一个球从管口求开始下落,然后每1s就会又有球从球当前位置开始下落,球碰到地面原速返回,球与球之间相碰会发生完全弹性碰撞(各自方向改变,速率变为相碰时另一个球的速率)问最后所有球的位置? 这一题又是一道弹性碰撞模型的题目,和Liner World有点像,但是这一题不要求输出球的名字,而是要你求得各个球的高度 这道题我们只用明白一个道理就很方便了: 首先我们来看一个球的情况: 一个球从H的高度下落,碰到

Physics Experiment poj 3684 弹性碰撞

Language: Default Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1107   Accepted: 380   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Befor

Physics Experiment(POJ 3684)

原题如下: Physics Experiment Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3583   Accepted: 1275   Special Judge Description Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the exper

北大ACM3684——Physics Experiment

这题,题目的意思是,有N个球从高度为H的地方落下,每一秒落下一个球,球与球之间和球与地板直接都是弹性碰撞,求T秒后的每个球的位置,也就是高度. 这题,跟Ants那题类似,也就是球与球碰撞可以当作不转换方向,继续按照原来的方向.也就是R = 0的时候,忽略半径,算出每一个球的位置,每一个球与地板碰撞后,会上升到原来的高度.先算出一次掉落需要t = sqrt(2 * H / g):每个球总共的时间T,总共的完整的来回有k = T / t次. k为奇数,最终高度为H - g * (k * t + t

POJ 3684 Physics Experiment

和蚂蚁问题类似. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<queue> #include<algorithm> using namespace std; int c,n; double h,r,t,T; double ans[105]; double cal(double time) { if(time<=0) re

弹性碰撞 poj 3684

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground.

常用技巧精选(一)

尺取法 Subsequence(POJ 3061) 原题如下: Subsequence Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 20969 Accepted: 8948 Description A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integ