[POJ2586]Y2K Accounting Bug

试题描述

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

(题目好难懂,可以去 http://blog.sina.com.cn/s/blog_768e348b0100xc53.html 看翻译。。。)

输入

Input is a sequence of lines, each containing two positive integers s and d.

输出

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

输入示例

59 237
375 743
200000 849694
2500000 8000000

输出示例

116
28
300612
Deficit

数据规模及约定

见“试题描述

题解

直接暴力咯。。。

不过也可以 dp 或是贪心。。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <map>
#include <set>
using namespace std;

int read() {
    int x = 0, f = 1; char c = getchar();
    while(!isdigit(c)){ if(c == ‘-‘) f = -1; c = getchar(); }
    while(isdigit(c)){ x = x * 10 + c - ‘0‘; c = getchar(); }
    return x * f;
}

#define maxn 15
int A[maxn];

int main() {
	int s, d;
	while(scanf("%d%d", &s, &d) == 2) {
		int all = (1 << 12) - 1, ans = -1;
		for(int i = 0; i <= all; i++) {
			int sum = 0;
			for(int j = 0; j < 12; j++) {
				if(i >> j & 1) A[j] = s;
				else A[j] = -d;
				sum += A[j];
			}
			int S = 0;
			for(int j = 0; j < 5; j++) S += A[j];
			if(S >= 0) continue;
			bool ok = 1;
			for(int j = 1; j < 8; j++) {
				S = S - A[j-1] + A[j+4];
				if(S >= 0) { ok = 0; break; }
			}
			if(!ok) continue;
			ans = max(ans, sum);
		}
		if(ans >= 0) printf("%d\n", ans);
		else puts("Deficit");
	}

	return 0;
}
时间: 2024-09-30 11:10:40

[POJ2586]Y2K Accounting Bug的相关文章

poj2586 Y2K Accounting Bug(贪心)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://poj.org/problem?id=2586 Language: Default Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9979   Accepted: 4970 Description Accounting for Computer

POJ2586——Y2K Accounting Bug

Y2K Accounting Bug Description Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. All what they remember is that MS Inc. posted a surplus or a deficit each month of

Y2K Accounting Bug(poj2586)

题意: 有一个公司由于某个病毒使公司赢亏数据丢失,但该公司每月的 赢亏是一个定数,要么一个月赢利s,要么一月亏d.现在ACM只知道该公司每五个月有一个赢亏报表,而且每次报表赢利情况都为亏.在一年中这样的报表总共有8次(1到5,2到6,…,8到12),现在要编一个程序确定当赢s和亏d给出,并满足每张报表为亏的情况下,全年公司最高可赢利多少,若存在,则输出多多额,若不存在,输出"Deficit". 分析: 在保证连续5个月都亏损的前提下,使得每5个月中亏损的月数最少.          

POJ 2586 Y2K Accounting Bug(枚举大水题)

Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10674   Accepted: 5344 Description Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc

poj 2586 Y2K Accounting Bug (贪心)

Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9632   Accepted: 4806 Description Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

poj 2586 Y2K Accounting Bug

Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10150   Accepted: 5061 题目大意:有家公司每个月有盈余s 和亏损d但不知道具体是那个月 只知道一年中每个连续的五个月都是亏损的.要求求出该公司这一年里最大的盈利的可能金额 若不能盈利就输出Deficit 注意如果s>4d也是要输出Deficit的 可以用分类方法去做 注意要保证每连续的五个月中都有n个d保证这五个月是

贪心 --- Y2K Accounting Bug

Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9691   Accepted: 4838 Description Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

** poj Y2K Accounting Bug 2586

Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10117   Accepted: 5043 Description Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc

Y2K Accounting Bug(贪心)

Y2K Accounting Bug Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10945   Accepted: 5499 Description Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc