POJ3150---Cellular Automaton(矩阵)

Description

A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m ? 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i ? j|, n ? |i ? j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers n, m, d, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n?2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m ? 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1

5 3 1 1

1 2 2 1 2

sample input #2

5 3 1 10

1 2 2 1 2

Sample Output

sample output #1

2 2 2 2 1

sample output #2

2 0 0 2 2

Source

Northeastern Europe 2006

容易推出转移矩阵,但是规模太大,还不行

观察发现这个矩阵的每一行都是循环的,下一行的就是上一行向右循环移动一位,所以我们可以把矩阵乘法降到n^2,只用一维数组来保存,这样再结合矩阵快速幂就可以ac了

/*************************************************************************
    > File Name: POJ3150.cpp
    > Author: ALex
    > Mail: [email protected]
    > Created Time: 2015年03月17日 星期二 20时42分20秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

LL mat[505][505];
LL base[505];
LL arr[505];
LL tmp[505];
LL init[505];
int n, m, d, k;

void mul (LL a[])
{
    for (int j = 1; j <= n; ++j)
    {
        tmp[j] = 0;
        for (int i = 1; i <= n; ++i)
        {
            tmp[j] += mat[i][j] * a[i];
            tmp[j] %= m;
        }
    }
    for (int i = 1; i <= n; ++i)
    {
        a[i] = tmp[i];
    }
}

void fastpow()
{
    while (k)
    {
        if (k & 1)
        {
            mul (arr);
        }
        k >>= 1;
        mul (base);
        for (int i = 1; i <= n; ++i)
        {
            for (int j = 1; j <= n; ++j)
            {
                int p = (j + i - 1) % n;
                if (!p)
                {
                    p = n;
                }
                mat[i][p] = base[j];
            }
        }
    }
}

int main ()
{
    while (~scanf("%d%d%d%d", &n, &m, &d, &k))
    {
        for (int i = 1; i <= n; ++i)
        {
            scanf("%lld", &init[i]);
        }
        for (int j = 1; j <= n; ++j)
        {
            for (int i = 1; i <= n; ++i)
            {
                int dis = min (abs(i - j), n - abs(i - j));
                if (dis <= d)
                {
                    mat[i][j] = 1;
                }
            }
        }
        memset (arr, 0, sizeof(arr));
        arr[1] = 1; //单位矩阵
        for (int i = 1; i <= n; ++i)
        {
            base[i] = mat[1][i];
        }
        fastpow();
        for (int i = 1; i <= n; ++i)
        {
            for (int j = 1; j <= n; ++j)
            {
                int p = (j + i - 1) % n;
                if (!p)
                {
                    p = n;
                }
                mat[i][p] = arr[j];
            }
        }
        mul(init);
        for (int i = 1; i <= n; ++i)
        {
            printf("%lld", init[i]);
            if (i < n)
            {
                printf(" ");
            }
        }
        printf("\n");
    }
    return 0;
}
时间: 2024-10-12 03:47:27

POJ3150---Cellular Automaton(矩阵)的相关文章

Uva 1386 - Cellular Automaton ( 矩阵乘法 + 循环矩阵 )

Uva 1386 - Cellular Automaton ( 矩阵乘法 + 循环矩阵 ) #include <cstdio> #include <cstring> #define CLR( a, b ) memset( a, b, sizeof(a) ) int MOD; #define MAX_SIZE 500 struct Mat { int n; LL mat[MAX_SIZE][MAX_SIZE]; Mat( int _n = 0 ) { n = _n; CLR( mat

【poj 3150】Cellular Automaton 矩阵

题目:http://poj.org/problem?id=3150 Cellular Automaton 矩阵乘法+二分 Cellular Automaton Time Limit: 12000MS Memory Limit: 65536K Total Submissions: 3544 Accepted: 1428 Case Time Limit: 2000MS Description A cellular automaton is a collection of cells on a gri

[POJ 3150] Cellular Automaton (矩阵快速幂 + 矩阵乘法优化)

Cellular Automaton Time Limit: 12000MS   Memory Limit: 65536K Total Submissions: 3048   Accepted: 1227 Case Time Limit: 2000MS Description A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of dis

POJ3150—Cellular Automaton(循环矩阵)

题目链接:http://poj.org/problem?id=3150 题目意思:有n个数围成一个环,现在有一种变换,将所有距离第i(1<=i<=n)个数小于等于d的数加起来,对m取余,现在要求将所有的数都变换k次,得到的n个数的值. 思路:构造一个循环矩阵,以下这个矩阵是以样例1为例的循环矩阵. 1 1 0 0 1 1 1 1 0 0 0 1 1 1 0 0 0 1 1 1 1 0 0 1 1 我们发现n尽然达到了500,复杂度是n^3logk,过不了,我们发现这个矩阵长得很奇葩,每一行都是

POJ 3150 Cellular Automaton --矩阵快速幂及优化

题意:给一个环,环上有n块,每块有个值,每一次操作是对每个点,他的值变为原来与他距离不超过d的位置的和,问k(10^7)次操作后每块的值. 解法:一看就要化为矩阵来做,矩阵很好建立,大白书P157页有讲,大概为: [1 1 0 .. 0 1] [1 1 1 .. .. 0] ... [1 1 .. .. .. 1]  的循环矩阵,可以证明,循环矩阵的乘积还是循环矩阵,且循环矩阵的性质: a[i][j] = a[i-1][j-1] (循环的) ,所以,我们每次矩阵相乘只需要算出第一行,余下的不需要

UVA 1386 - Cellular Automaton(循环矩阵)

UVA 1386 - Cellular Automaton 题目链接 题意:给定一个n格的环,现在有个距离d,每次变化把环和他周围距离d以内的格子相加,结果mod m,问经过k次变换之后,环上的各个数字 思路:矩阵很好想,每个位置对应周围几个位置为1,其余位置为0,但是这个矩阵有500,有点大,直接n^3去求矩阵不太合适,然后观察发现这个矩阵是个循环矩阵,循环矩阵相乘的话,只需要保存一行即可,然后用n^2的时间就足够计算了 代码: #include <stdio.h> #include <

POJ 3150 Cellular Automaton(矩阵乘法+二分)

题目链接 题意 : 给出n个数形成环形,一次转化就是将每一个数前后的d个数字的和对m取余,然后作为这个数,问进行k次转化后,数组变成什么. 思路 :下述来自here 首先来看一下Sample里的第一组数据.1 2 2 1 2经过一次变换之后就成了5 5 5 5 4它的原理就是a0 a1 a2 a3 a4->(a4+a0+a1) (a0+a1+a2) (a1+a2+a3) (a2+a3+a4) (a3+a4+a0) 如果用矩阵相乘来描述,那就可以表述为1xN和NxN的矩阵相乘,结果仍为1xN矩阵a

poj 3150 Cellular Automaton(矩阵快速幂)

http://poj.org/problem?id=3150 大致题意:给出n个数,问经过K次变换每个位置上的数变为多少.第i位置上的数经过一次变换定义为所有满足 min( abs(i-j),n-abs(i-j) )<=d的j位置上的数字之和对m求余. 思路: 我们先将上述定义表示为矩阵 B =  1 1 0 0 1 1 1 1 0 0 0 1 1 1 0 0 0 1 1 1 1 0 0 1 1 B[i][j] = 表示i与j满足上述关系,B[i][j] = 0表示i与j不满足上述关系.根据这个

【POJ】3150 Cellular Automaton(矩阵乘法+特殊的技巧)

http://poj.org/problem?id=3150 这题裸的矩阵很容易看出,假设d=1,n=5那么矩阵是这样的 1 1 0 0 1 1 1 1 0 0 0 1 1 1 0 0 0 1 1 1 1 0 0 1 1 这是n^3的,可是n<=500,显然tle 我们观察这个n×n的矩阵,发现没一行都是由上一行向右移得到的. 而根据Cij=Aik×Bkj,我们可以发现,其实Bkj==Akj==Ai(j-k) 那么就可以降二维变一维,每一次只要算第一行即可,即Cj=Ak*Bj-k #includ

POJ - 3150 :Cellular Automaton(特殊的矩阵,降维优化)

A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of t