杭电ACM 三 动能定理 物理

问题及代码

Problem Description

Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the
bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

Unfortunately, he had not had enough time to calculate whether the bungee rope has the right length, so it is not clear at all what is going to happen when he jumps off the bridge. There are three possible scenarios:

The rope is too short (or too strong), and James Bond will never reach the ground.

The rope is too long (or too weak), and James Bond will be going too fast when he touches the ground. Even for a special agent, this can be very dangerous. You may assume that if he collides at a speed of more than 10 m/s, he will not survive the impact.

The rope‘s length and strength are good. James Bond touches the ground at a comfortable speed and can escape.

As his employer, you would like to know whether James Bond survives or whether you should place a job ad for the soon-to-be vacant position in the local newspaper. Your physicists claim that:

The force with which James is pulled towards the earth is

9.81 * w,

where w is his weight in kilograms and 9.81 is the Earth acceleration in meters over squared seconds.

Mr. Bond falls freely until the rope tautens. Then the force with which the bungee rope pulls him back into the sky depends on the current length of the rope and is

k * Δl,

where Δl is the difference between the rope‘s current length and its nominal, unexpanded length, and k is a rope-specific constant.

Given the rope‘s strength k, the nominal length of the rope l in meters, the height of the bridge s in meters, and James Bond‘s body weight w, you have to determine what is going to happen to our hero. For all your calculations, you may assume that James Bond
is a point at the end of the rope and the rope has no mass. You may further assume that k, l, s, and w are non-negative and that s < 200.

The input contains several test cases, one test case per line. Each test case consists of four floating-point numbers (k, l, s, and w) that describe the situation. Depending on what is going to happen, your program must print "Stuck in the air.", "Killed by
the impact.", or "James Bond survives.". Input is terminated by a line containing four 0s, this line should not be processed.

Sample Input

350 20 30 75
375 20 30 75
400 20 30 75
425 20 30 75
450 20 30 75
400 20 30 50
400 20 30 80
400 20 30 85
0 0 0 0

Sample Output

Killed by the impact.
James Bond survives.
James Bond survives.
James Bond survives.
Stuck in the air.
Stuck in the air.
James Bond survives.
Killed by the impact.
/*
*Copyright (c)2014,烟台大学计算机与控制工程学院
*All rights reserved.
*文件名称:mod.cpp
*作    者:冷基栋
*完成日期:2015年2月20日
*版 本 号:v1.0
*/
#include<iostream>
#include<cmath>
using namespace std;
const double G=9.81;
int main()
{
    double k,l,s,w;
    while(cin>>k>>l>>s>>w)
    {
        if(k==0&&l==0&&s==0&&w==0)break;
        double e=w*G*s;
        if(s>l)e-=k*(s-l)*(s-l)/2;
        if(e<0)
        {
            cout<<"Stuck in the air."<<endl;
            continue;
        }
        double v=sqrt(e*2/w);
        if(v>10) cout<<"Killed by the impact."<<endl;
        else cout<<"James Bond survives."<<endl;
    }
    return 0;
}

运行结果:

知识点总结:

势能 continue

学习心得:

好好学习 天天向上



时间: 2024-12-17 08:35:10

杭电ACM 三 动能定理 物理的相关文章

杭电ACM 三 大数取模

题目及代码 Problem Description As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B. To make the problem easier, I promise that B will be smaller than 100000. I

杭电ACM 三 圆桌会议倒序换座

Problem Description HDU ACM集训队的队员在暑假集训时经常要讨论自己在做题中遇到的问题.每当面临自己解决不了的问题时,他们就会围坐在一张圆形的桌子旁进行交流,经过大家的讨论后一般没有解决不了的问题,这也只有HDU ACM集训队特有的圆桌会议,有一天你也可以进来体会一下哦:),在一天在讨论的时候,Eddy想出了一个极为古怪的想法,如果他们在每一分钟内,一对相邻的两个ACM队员交换一下位子,那么要多少时间才能得到与原始状态相反的座位顺序呢?(即对于每个队员,原先在他左面的队员

杭电ACM 三 重力搭牌

问题及代码: Problem Description How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you c

杭电ACM 三 选地盖房防水淹(Math.ceil)

问题及代码: Problem Description Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to

杭电ACM 三 在坐标系中的微积分

问题及代码 Problem Description Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the p

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

杭电ACM水仙花数

水仙花数 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 96473    Accepted Submission(s): 28632 Problem Description 春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的: "水仙花数"是指一个三位数,它的各位数字的立方和等于其本身,比如:1

杭电ACM 2036 改革春风吹满地

已知直角坐标系3点p(a,b),m(c,d),n(e,f) 求三角形pmn面积的表达式! 解: 无论三角形的顶点位置如何,△PMN总可以用一个直角梯形(或矩形)和两个直角三角形面积的和差来表示而在直角坐标系中,已知直角梯形和直角三角形的顶点的坐标,其面积是比较好求的.下面以一种情形来说明这个方法,其它情形方法一样,表达式也一样(表达式最好加上绝对值,确保是正值)如图情形(P在上方,M在左下,N在右下),过P作X轴的平行线L,作MA⊥L,NB⊥L(设P在A.B之间)则A.B的坐标是A(c,b),B

杭电ACM Java实现样例

若使用Java求解杭电ACM,答案提交必须注意两点: 1.类名一定得是Main,否则服务器无法编译: 2.必须用while进行输入判断. 以1000题测试题为例,代码如下: import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner scan=new Scanner(System.in); while(scan.hasNextInt()) { int a=scan.n