hdu 1518 Square (dfs搜索可参考poj1011)

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8589    Accepted Submission(s): 2784

Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

Source

University of Waterloo Local Contest 2002.09.21

#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
#include"algorithm"
using namespace std;
#define N 25
#define max(a,b) (a>b?a:b)
int a[N],n,t,mark[N],sum;
bool cmp(int a,int b)
{
    return a>b;
}
int dfs(int index,int len,int rest)
{
    int i;
    if(rest==t)
        return 1;
    for(i=index;i<n;i++)
    {
        if(!mark[i]&&a[i]<=len)
        {
            mark[i]=1;
            if(len==a[i])
            {
                if(dfs(0,t,rest-a[i]))
                    return 1;
            }
            else if(dfs(i+1,len-a[i],rest-a[i]))
                return 1;
            mark[i]=0;  //若当前值不能满足条件,进行回溯
            if(rest==sum)       //若满足此条件,则该条边不能加入任一条边
                return 0;
            if(len==t)   //同上
                return 0;
            while(a[i]==a[i+1])     //这条边不行,则和它同长的边也不行
                i++;
        }
    }
    return 0;
}
int main()
{
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a,a+n,cmp);
        if(sum%4)
            printf("no\n");
        else
        {
            memset(mark,0,sizeof(mark));
            if(dfs(0,t=sum/4,sum))
                printf("yes\n");
            else
                printf("no\n");
        }
    }
    return 0;
}

hdu 1518 Square (dfs搜索可参考poj1011),布布扣,bubuko.com

时间: 2024-12-25 22:54:12

hdu 1518 Square (dfs搜索可参考poj1011)的相关文章

hdu 1518 Square(深搜dfs)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518 --------------------------------------------------------------------------------------------------------------------------------------------

HDU 1518 Square 搜索

Square Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 11   Accepted Submission(s) : 5 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Given a set of sticks of vario

hdu 1518 Square(深搜+剪枝)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518 题目大意:根据题目所给的几条边,来判断是否能构成正方形,一个很好的深搜应用,注意剪枝,以防超时! 1 #include <iostream> 2 #include <cstdio> 3 #include<algorithm> 4 #include <cstring> 5 using namespace std; 6 int ap[30],visit[30]

HDU 1518 Square (DFS+剪枝)

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square? Input The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M intege

hdu 1518 Square

Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square? Input The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number

hdu 1518 Square 深搜,,,,花样剪枝啊!!!

Square Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9588    Accepted Submission(s): 3127 Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end

hdu 1518(dfs)

参考页面: http://www.yuanjiaocheng.net/CSharp/Csharp-keys.html http://www.yuanjiaocheng.net/CSharp/csharp-interface.html http://www.yuanjiaocheng.net/CSharp/Csharp-operators.html http://www.yuanjiaocheng.net/CSharp/Csharp-if-else.html http://www.yuanjiao

HDU 1312:Red and Black(DFS搜索)

HDU 1312:Red and Black Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From

HJDU 1518—— Square(DFS)

简单深搜~~~~ <strong>#include<iostream> #include<cstring> #include<cstdio> #include<algorithm> #include<functional> #define M 30 using namespace std; int vis[M],a[M],n,flag,sum; void dfs(int s,int cur,int d) { if(cur==3||fl