ACM,大数相加问题

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 316067    Accepted Submission(s): 61349

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110


解读:

四个字节的整型最多能存下10*10大小的整数,长整型也不足以存下,因此考虑用数组来存,相加之和则用整型数组存放

1、先把加数和被加数数输入到字符数组中

2、再用循环将对每位进行处理再相加

分三种情况来讨论(见代码)

切记最高位进位问题

3、最后输出


代码:

#include<iostream>
#include<string.h>
using namespace std;
char a[1000],b[1000];//加数和被加数
int c[1000];//和
int main()
{
    int T;//记录共有几个例子
    while(scanf("%d",&T))
    {
        int i=1;//记录当前是第几个例子
        int m,n;//用来存放每个字符转化成的数字
        while(T--)
        {//处理每个例子
           int j=0;//记录和的位数
           scanf("%s%s",a,b);
           m=strlen(a);//计算出串长
           n=strlen(b);
           int temp=0;//用来存储进位
           for(m--,n--;m>=0||n>=0;)
           {//逐位相加用循环,
                 if(m>=0&&n>=0)
                 {
                     int x,y;
                   x=a[m]-‘0‘;//转换成整型
                   y=b[n]-‘0‘;
                   c[j]=(x+y+temp)%10;
                   temp=(x+y+temp)/10;
                   m--;n--;j++;
              }
                 if(m>=0&&n<0)
                 {
                     int x;
                     x=a[m]-‘0‘;//转换成int
                     c[j]=(x+temp)%10;
                     temp=(x+temp)/10;
                     m--;j++;
              }
              if(m<0&&n>=0)
                 {
                     int y;
                     y=b[n]-‘0‘;
                     c[j]=(y+temp)%10;
                     temp=(y+temp)/10;
                     n--;j++;
              }
           }
           if(temp!=0)
           {//当最高位还有进位时
                c[j]=temp;
                j++;
           }
           cout<<"Case "<<i<<":"<<endl;
           cout<<a<<" + "<<b<<" = ";
           for(;j-1>=0;j--)
             cout<<c[j-1];
           cout<<endl;
           i++;
           if(i<T)
           cout<<endl;
        }
    }
 } 

以下再给出另一种解法(毕竟思路要开阔嘛,所以就收录了接下来的这个代码)

#include<iostream>
#include<string>
using namespace std;
char add(char temps,char tempstr,int &tempaddc)
{
    int temp;
    temp = (temps - ‘0‘) + (tempstr - ‘0‘) + tempaddc;  //实现进位。
    tempaddc = temp / 10;  // 算出进位数
    return temp % 10 + ‘0‘;
}
int main()
{
    string str,s;
    int tempaddc;
    char c;
    int n,lenstr,lens;
    while(cin>>n)
    {
        while(n--)
        {
            cin>>str>>s;
            tempaddc = 0;
            c = ‘0‘;
            if(s.length() > str.length())swap(s,str);
            lenstr = str.length();
            lens = s.length();
            lens--;
            lenstr--;
            while (lenstr >= 0)
            {
                if(lens < 0) str[lenstr] = add(c,str[lenstr],tempaddc);    //字符串长度较长部分的计算
                else
                {
                    str[lenstr] = add(s[lens],str[lenstr],tempaddc);
                    lens--;
                }
                lenstr--;
            }
            cout<<str<<endl;
        }
    }
    return 0;
}  

如有疑问请指出,O(∩_∩)O谢谢

至于乘法和除法之后再补充!!!

时间: 2024-10-21 03:42:08

ACM,大数相加问题的相关文章

ACM——大数相加

大数加法 时间限制(普通/Java):1000MS/3000MS          运行内存限制:65536KByte 总提交:2085            测试通过:543 描述 求两个非负整数(1000位以内)的和. 输入 两个非负整数(1000位以内),以空格分隔. 输出 两个非负整数的和. 样例输入 111111111111 222222222222 样例输出 333333333333 提示 题目来源 GUOJ #include<iostream> #include<strin

ACM 大数相加

大数问题 基本都可以归结到大数相加上来 做大数问题  要返璞归真 回到小学里做加法 把数字读入到字符串数组中  每个位数一 一相加  主要考虑进位问题 如果整数的话 左边用零补齐 小数的话要左右分开补齐零  小数的零要补右边 HDOJ题目在1002 1753 下面给代码  整数相加 #include <stdio.h> #include <string.h> #define SIZE 1000 void convert(char a[],char newa[]) { memset(

HDU 1250 Hat&#39;s Fibonacci(Java大数相加)+讲解

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250 Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n -

HDU 1316 (斐波那契数列,大数相加,大数比较大小)

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1316 Recall the definition of the Fibonacci numbers: f1 := 1 f2 := 2 fn := fn-1 + fn-2 (n >= 3) Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. Input The input c

HDU 1250 Hat&#39;s Fibonacci(大数相加)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1250 Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12952    Accepted Submission(s): 4331 Problem Description A Fibonacci sequence

java-两个大数相加

题目要求:用字符串模拟两个大数相加. 一.使用BigInteger类.BigDecimal类 public static void main(String[] args) { String a="8888899999999888";  String b="88888888888888";  String str=new BigInteger(a).add(new BigInteger(b)).toString();  System.out.println(str);

高精度问题之大数相加(原来就是用字符串相加,模拟手算这么简单!)

解题心的: 就是基本的一对一模拟手算..借助c++的string 不用逆序运算了.很方便的补0.  最后处理下前导0的问题. #include <iostream> #include <string> using namespace std; // 实现大数相加 结果存放在num中 void bigIntergerAdd(string &num, string add) { int goBit = 0; // 存放进位 // 先交换下顺序 加数的位数要比较少 if (num

ACM大数模板(支持正负整数)

之前就保留过简陋的几个用外部数组变量实现的简单大数模板,也没有怎么用过,今天就想着整合封装一下,封装成C++的类,以后需要调用的时候也方便得多. 实现了基本的加减乘除和取模运算的操作符重载,大数除以大数难度太大就没实现,另外还实现了比较运算符,方便实际使用贴近内置类型的体验. 话不多说,贴代码. 1 #include <stdio.h> 2 #include <string.h> 3 #include <ctype.h> 4 5 #define MAXBIT 1007

HDU 1047 Integer Inquiry 大数相加 string解法

本题就是大数相加,题目都不用看了. 不过注意的就是HDU的肯爹输出,好几次presentation error了. 还有个特殊情况,就是会有空数据的输入case. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <limits.h

模板,大数相加

char a[Max],b[Max],c[Max],sum[Max]; void jia(char str1[],char str2[]) { int i,j,k,z; k=0;z=0; for(i=strlen(str1)-1,j=strlen(str2)-1;i>=0||j>=0;i--,j--) //核心,加法以及进位 { if(i>=0) z+=str1[i]-'0'; if(j>=0) z+=str2[j]-'0'; c[k++]=z%10+'0'; z=z/10; }