UVa 1025 A Spy in the Metro(动态规划)

传送门

Description

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated. Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria. The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

Input

The input file contains several test cases. Each test case consists of seven lines with information as follows. Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations. Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment. Line 3. N − 1 integers: t1, t2, . . . , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on. Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first station. Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the first station. Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station. Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station. The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input

4 55 5 10 15 4 0 5 10 20 4 0 5 10 15 4 18 1 2 3 5 0 3 6 10 12 6 0 3 5 7 12 15 2 30 20 1 20 7 1 3 5 7 11 13 17 0

Sample Output

Case Number 1: 5

Case Number 2: 0

Case Number 3: impossible

思路

  题意:

  某城市的地铁是线性的,有n(2≤n≤50)个车站,从左到右的编号为1~N.有M1辆列车从第一站开始往右开,还有M2辆列车从第n站开始往左开。在时刻0,Mario从第1站出发,目的是在时刻T(0≤T≤200)会见车站n的一个间谍。在车站等车容易被抓,所以她决定尽量躲在开动的火车上,让在车站等待的总时间尽量短。列车靠站停车时间忽略不计,且Mario身手敏捷,即使两辆方向不同的列车在同一时间靠站,Mario也能完成换乘。求最少等待时间。

  思路:

  Mario在某个状态都有三种决策:

    • 等一分钟。
    • 搭乘往右开的车(如果有)
    • 搭乘往左开的车(如果有)

  影响到当前决策的只有当前时间和所处的车站,所以可以用d(i,j)表示时刻i,你在车站j,最少还需要等待多长时间。边界条件d(T,n) = 0,其他d(T,j)为正无穷。

 

/*
 *dp[i][j]表示时刻i,在车站j,最少还需要等待多长时间
 *has_train[t][i][0]表示时刻t,在车站i是否有向右开的火车
 *has_train[t][i][1]表示时刻t,在车站i是否有向左开的火车
 */
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 55;
const int maxt = 205;
const int INF = 0x3f3f3f3f;
int t[maxn],has_train[maxt][maxn][2],dp[maxt][maxn];
int main()
{
	int n,Case = 0;
	while (~scanf("%d",&n) && n)
	{
		int T,M1,M2,d;
		memset(has_train,0,sizeof(has_train));
		memset(dp,0,sizeof(dp));
		scanf("%d",&T);
		for (int i = 1;i < n;i++)	scanf("%d",&t[i]);
		scanf("%d",&M1);
		while (M1--)
		{
			scanf("%d",&d);
			for (int j = 1;j < n;j++)
			{
				if (d <= T)	has_train[d][j][0] = 1;
				d += t[j];
			}
		}
		scanf("%d",&M2);
		while (M2--)
		{
			scanf("%d",&d);
			for (int j = n - 1;j > 0;j--)
			{
				if (d <= T)	has_train[d][j+1][1] = 1;
				d += t[j];
			}
		}
		for (int i = 1;i < n;i++)	dp[T][i] = INF;
		dp[T][n] = 0;
		for (int i = T - 1;i >= 0;i--)
		{
			for (int j =1;j <= n;j++)
			{
				dp[i][j] = dp[i+1][j] + 1;
				if (j < n && has_train[i][j][0] && i + t[j] <= T)	dp[i][j] = min(dp[i][j],dp[i+t[j]][j+1]);
				if (j > 1 && has_train[i][j][1] && i + t[j-1] <= T)	dp[i][j] = min(dp[i][j],dp[i+t[j-1]][j-1]);
			}
		}
		printf("Case Number %d: ",++Case);
		dp[0][1]>=INF ? printf("impossible\n"):printf("%d\n",dp[0][1]);
	}
	return 0;
}

  

时间: 2024-12-23 01:59:46

UVa 1025 A Spy in the Metro(动态规划)的相关文章

UVA 1025 - A Spy in the Metro (DAG的动态规划)

第一遍,刘汝佳提示+题解:回头再看!!! POINT: dp[time][sta]; 在time时刻在车站sta还需要最少等待多长时间: 终点的状态很确定必然是的 dp[T][N] = 0 ---即在T时刻的时候正好达到N站点 我们可以 从终点的状态往起始的状态转化, 一步步走就可以了. has_train[t][i][0]; t时刻在i车站是否有往右开的火车 has_train[t][i][1]; t时刻在i车站是否有往左开的火车 #include <iostream>#include &l

UVA 1025 A Spy in the Metro(DP)

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a s

UVA 1025 A Spy in the Metro

A Spy in the Metro #include <iostream> #include <cstdio> #include <cstring> using namespace std; int INF=0x3f3f3f3f; int kase=0; int main() { int n; while(scanf("%d",&n)&&n!=0) { int T,M1,M2,time[n+1]; scanf("%

UVA 1025 A Spy in the Metro DP

DP[ i ][ j ] 在 i 时刻 j 号车站的等待最小时间..... 有3种可能: 在原地等,坐开往左边的车,做开往右边的车 A Spy in the Metro Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Submit Status Description Secret agent Maria was sent to Algorithms City to carry out an es

UVA 1025 A Spy in the Metro(DAG dp)

UVA 1025 1 #include<cstdio> 2 #include<iostream> 3 #include<queue> 4 #include<vector> 5 #include<stack> 6 #include<set> 7 #include<string> 8 #include<cstring> 9 #include<math.h> 10 #include<algorith

UVa 1025 A Spy in the Metro (DP动态规划)

题意:一个间谍要从第一个车站到第n个车站去会见另一个,在是期间有n个车站,有来回的车站,让你在时间T内时到达n,并且等车时间最短, 也就是尽量多坐车,最后输出最少等待时间. 析:这个挺复杂,首先时间是一个顺序,设d(i,j)表示时刻 i 在第 j 个车站,最少还要等待多长时间,那么边界是d(T, n) = 0. 并且有三种决策: 决策一:等着 d[i][j] = d[i + 1][j] + 1; 为什么从i + 1 过来呢? 你想一下,DP表示等待的时间,那么是不是应该倒着来呢? 决策二:有往右

World Finals 2003 UVA - 1025 A Spy in the Metro(动态规划)

分析:时间是一个天然的序,这个题目中应该决策的只有时间和车站,使用dp[i][j]表示到达i时间,j车站在地上已经等待的最小时间,决策方式有三种,第一种:等待一秒钟转移到dp[i+1][j]的状态,代价为1.第二种:如果可以则向右上车,转移到dp[i+t][j+1],无代价,t为列车行驶时间.第三种与第二种相同.初始状态为dp[0][1] = 0,其他为INF.答案为dp[T][n]. 代码如下: #include<iostream> #include<cstdio> #inclu

UVA 1025 A Spy in the Metro 【DAG上DP/逆推/三维标记数组+二维状态数组】

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a s

uva 1025 A Spy int the Metro

https://vjudge.net/problem/UVA-1025 看见spy忍俊不禁的想起省赛时不知道spy啥意思 ( >_< f[i][j]表示i时刻处于j站所需的最少等待时间,有三种可能,一是i-1时刻就在这里然后等待了1时刻  f[i][j]=f[i-1][j]+1  ; 二是正好由由左边相邻的一个车站开过来(如果可以的话)  f[i][j]=f[i-t[j-1]][j-1];  三是正好由右边的车站开过来(if can) f[i][j]=f[i-t[j]][j+1]; 取三者的最