HDU 1042.N!【高精度乘法】【8月24】

N!

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6

高精度乘法。数组存,每一位存5位数,不然会严重超时。另外,这道题的限制时间为5s(java10s)。

代码例如以下:

#include<cstdio>
int main(){
    int n,m,t;
    while(scanf("%d",&n)==1){
        int f[8005]={0};
        f[0]=1;t=0;
        for(int i=2;i<=n;i++)
        for(int j=0;j<8005;j++){
            f[j]=f[j]*i+t;
            t=f[j]/100000;
            f[j]%=100000;
        }
        for(int i=8004;i>=0;i--)
        if(f[i]){//前面的0不用输出
            m=i;
            printf("%d",f[i]);
            break;
        }
        for(int i=m-1;i>=0;i--)
            printf("%05d",f[i]);//把0也要补起来
        printf("\n");
    }
    return 0;
}

时间: 2024-10-12 02:50:23

HDU 1042.N!【高精度乘法】【8月24】的相关文章

HDU 1042 N! 高精度乘法

Problem Description Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! Input One N in one line, process to the end of file. Output For each N, output N! in one line. Sample Input 1 2 3 Sample Output 1 2 6 题目意思很简单,就是让你求N的阶乘,但是N的范围有10000,所

Hdu 1042 N! (高精度数)

Problem Description Givenan integer N(0 ≤ N ≤ 10000), your task is to calculate N! Input OneN in one line, process to the end of file. Output Foreach N, output N! in one line. Sample Input 1 2 3 Sample Output 1 2 6 Author JGShining(极光炫影) /********* 高

HDU1402 FFT高精度乘法模板题

#include<bits/stdc++.h> using namespace std; //HDU 1402 求高精度乘法 const double PI = acos(-1.0); //复数结构体 struct Complex { double x,y;//实部和虚部x+yi Complex(double _x = 0.0,double _y = 0.0) { x = _x; y = _y; } Complex operator -(const Complex &b)const {

hdu 1063 Exponentiation (高精度小数乘法)

//大数继续,额,要吐了. Problem Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem re

高精度乘法程序

对于超过20位的数的乘法问题,我们无法使用普通的方法!!!即使是longlong也会超出范围的!像这样的数,我们只能使用高精度的知识利用数组的方法解决问题!对于高精度乘法的问题,其实思路和高精度加法的思路差不多,都需要使用字符数组来存放每次算完的结果!        1  2  3        *4  5  6    ________________      12  15  18   8  10  124  5   6  _____________________4 13   28   27

poj1001(高精度乘法)

1.题目表述 Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 135893   Accepted: 33256 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation o

真真真&#183;?高精度乘法!!!!!

RX-0奉上哈哈哈哈哈哈哈哈哈哈哈哈哈™™™ 先奉上真真真·高精度乘法源代码: 高精度乘法 RX-0制作最后修改:2016年7月6日#include<stdio.h>#include<string.h>#include<math.h>char s[10000],b;int a[10000];int c[10000];int main(){ int x,l=0,y=1,i,j,m,l1=0; long long s1=0; //freopen("hp.in&qu

[vijos P1040] 高精度乘法

如果这次noip没考好,完全是因为从7月29日之后就没有再写过程序了.说起来,真是一个泪流满面的事实… 那这样一个弱智题练手恢复代码能力,竟然还花了我两个晚上(当然不是两整个晚上…) 第一天TLE了,好在我机智,一看到解题里说要压位就自动脑补出压位了. 代码风格非常诡异,弱智题竟然写到2KB我也是醉了. program vijos_p1040; const maxn=10020; var a,b,aa,bb:array[1..maxn] of integer; c:array[1..2*maxn

高进度加法与高精度乘法

正整数的高精度加法和高精度乘法(C++) 加法运算如下: // 高精度加法 string add(string a, string b) { // 确保 a >= b if (a.size() < b.size()) { string temp = a; a = b; b = temp; } int len1 = a.size(), len2 = b.size(); // a, b前缀补零 ,比如 a = 12345, b = 678时,补零之后 a = 012345,b = 0000678.