POJ 1860 & ZOJ 1544 Currency Exchange(最短路SPFA)

题目链接:

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1544

PKU:http://poj.org/problem?id=1860

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define pi acos(-1.0)
#define INF 0xffffff
#define N 3005
#define M 2005
int Edgehead[N];
int cont[N];
double dis[N];
struct
{
    int v,next;
    double rate, comm, w;
} Edge[2*M];
bool vis[N];
int k;
int n, m, s;
double val;
void Addedge(int u,int v,double r, double c)
{
    Edge[k].next = Edgehead[u];
    Edge[k].rate = r;
    Edge[k].v = v;
    Edge[k].comm = c;
    Edge[k].w = 0;
    Edgehead[u] = k++;
}
void init()
{
    for(int i = 1 ; i <=n ; i++ )//求最长路径开始设为-1
        dis[i] = 0;
    memset(Edgehead,-1,sizeof(Edgehead));
    memset(vis,false,sizeof(vis));
    memset(cont,0,sizeof(cont));
}

int SPFA( int start)
{
    queue<int>Q;
    dis[start] = val;
    vis[start] = true;
    ++cont[start];
    Q.push(start);
    while(!Q.empty())//直到队列为空
    {
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for(int i = Edgehead[u] ; i!=-1 ; i = Edge[i].next)//注意
        {
            int v = Edge[i].v;
            Edge[i].w = (dis[u] - Edge[i].comm)*Edge[i].rate-dis[u];
            if(dis[v] < dis[u] + Edge[i].w)
            {
                dis[v] = dis[u]+Edge[i].w;
                if( !vis[v] )//防止出现环,也就是进队列重复了
                {
                    Q.push(v);
                    vis[v] = true;
                }
                if(++cont[v] > n)//有负环
                    return -1;
            }
        }
    }
    return 1;
}
int main()
{
    int a, b;
    double r, c;
    while(~scanf("%d%d%d%lf",&n,&m,&s,&val))//n为目的地
    {
        k = 0;
        init();
        for(int i = 1 ; i <= m ; i++ )
        {
            scanf("%d%d",&a,&b);
            scanf("%lf%lf",&r,&c);
            Addedge(a, b, r, c);//双向链表
            scanf("%lf%lf",&r,&c);
            Addedge(b, a, r, c);//双向链表
        }
        if(SPFA(s) == -1)
        {
            printf("YES\n");
        }
        else
            printf("NO\n");
    }
    return 0;
}
时间: 2024-10-01 04:27:56

POJ 1860 & ZOJ 1544 Currency Exchange(最短路SPFA)的相关文章

【最短路】 ZOJ 1544 Currency Exchange 判断负圈

给出 N 种货币 M 条兑换关系 开始时所有的货币S 和有X 块钱 接下来M条关系 A B W1 W2 W3 W4 表示 A->B 所需的手续费为W2块钱  汇率为W1 B->A 所需的手续费为W4块钱  汇率为W3 所以对于输入的一行建两条边 要求到最后可以赚到钱 所以当出现了负圈即可赚到无限多的钱 #include <cstdio> #include <cstdlib> #include <cstring> #include <climits>

【最短路】 ZOJ 1544 Currency Exchange 推断负圈

给出 N 种货币 M 条兑换关系 開始时全部的货币S 和有X 块钱 接下来M条关系 A B W1 W2 W3 W4 表示 A->B 所需的手续费为W2块钱  汇率为W1 B->A 所需的手续费为W4块钱  汇率为W3 所以对于输入的一行建两条边 要求到最后能够赚到钱 所以当出现了负圈就可以赚到无限多的钱 #include <cstdio> #include <cstdlib> #include <cstring> #include <climits&g

POJ 1860 Currency Exchange(最短路)

Currency Exchange Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 20482   Accepted: 7352 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and pe

Currency Exchange(最短路_Beelman_Ford)

Currency Exchange Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 20482   Accepted: 7352 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and pe

poj 3767 I Wanna Go Home 最短路spfa

题意: 给一个无向图,每个点有属性支持A或B(点1的属性恒为A,点2恒为B),求点1到点2的最短路,所求的最短路径要满足要求:路径上的边两边的点的属性至多有一次不一样. 分析: 最短路问题就用spfa水吧~~d[v][0]表示从起点开始到v点的属性没有变化过,d[v][1]表示从起点到v属性已经变化过了,最后答案min(d[2][0].d[2][1]); 代码: //poj 3767 //sep9 #include <iostream> #include <queue> using

POJ 3268 Silver Cow Party (来回最短路 SPFA)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14384   Accepted: 6490 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤X ≤

POJ 1860——Currency Exchange——————【最短路、SPFA判正环】

Currency Exchange Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1860 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two par

POJ 1860 Currency Exchange [bellman_ford]

传送门:http://poj.org/problem?id=1860 题目: Currency Exchange Time Limit:1000MS   Memory Limit:30000KB   64bit IO Format:%I64d & %I64u SubmitStatus Description Several currency exchange points are working in our city. Let us suppose that each point specia

poj 1860 Currency Exchange(SPFA)

题目链接:http://poj.org/problem?id=1860 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can b