HDU 1724 Ellipse [辛普森积分]

Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1868    Accepted Submission(s): 792

Problem Description

Math is important!! Many students failed in 2+2’s mathematical test, so let‘s AC this problem to mourn for our lost youth..
Look this sample picture:

A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )

Input

Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).

Output

For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.

Sample Input

2
2 1 -2 2
2 1 0 2

Sample Output

6.283 3.142


可以计算椭圆面积了哈哈

注意eps小一点

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const double eps=1e-10;

double a,b,l,r;
inline double F(double x){
    return sqrt((a*a-x*x)/(a*a))*b;
}
inline double cal(double l,double r){
    return (F(l)+F(r)+4*F((l+r)/2))*(r-l)/6;
}
double Simpson(double l,double r,double now){
    double mid=(l+r)/2,p=cal(l,mid),q=cal(mid,r);
    if(abs(now-p-q)<eps) return now;
    else return Simpson(l,mid,p)+Simpson(mid,r,q);
}

int main(int argc, const char * argv[]) {
    int T;scanf("%d",&T);
    while(T--){
        scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
        l=max(l,-a);r=min(r,a);
        printf("%.3f\n",2*Simpson(l,r,cal(l,r)));
    }

    return 0;
}
时间: 2024-10-27 09:37:44

HDU 1724 Ellipse [辛普森积分]的相关文章

HDU 1724 Ellipse 【自适应Simpson积分】

Ellipse Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1977    Accepted Submission(s): 832 Problem Description Math is important!! Many students failed in 2+2's mathematical test, so let's AC t

HDU - 1724 Ellipse(simpson积分)(入门模板题)

原题链接 题意: 给定 a,b,l,r,求 与x = l,x = r 围成的封闭图形的面积. 思路: 大佬可以直接算一下原函数就出来了,当没法计算或者很难计算的时候就可以用 自适应simpson 积分来逼近真实值. 1 /* 2 * @Author: windystreet 3 * @Date: 2018-08-04 16:24:01 4 * @Last Modified by: windystreet 5 * @Last Modified time: 2018-08-04 16:24:33 6

hdu 1071 The area 高斯消元求二次函数+辛普森积分

构造系数矩阵,高斯消元求解二次函数,然后两点式求直线函数,带入辛普森积分法无脑AC... #include<cstdio> #include<queue> #include<algorithm> #include<cstring> #include<vector> #include<cmath> using namespace std; struct node { double x,y; }p[4]; double g[10][10]

【自适应辛普森积分】hdu1724 Ellipse

Ellipse Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2502    Accepted Submission(s): 1126 Problem Description Math is important!! Many students failed in 2+2's mathematical test, so let's AC

辛普森积分

引例 计算积分:\[\int_{L}^{R} \frac{cx+d}{ax+b} dx\] 题解 其实可以直接求导然后做,然而太弱根本推不出来. 于是就可以使用自适应辛普森积分. 辛普森(Simpson)公式是牛顿-科特斯公式当n=2时的情形. \[\int_{L}^{R} f(x) dx\approx\frac{(R-L)[f(L)+f(R)+4f(mid)]}{6}\],其中\(mid = \frac{L+R}{2}\) 这样每次求一个区间的积分,先求左右两段积分,如果不满足精度就递归下去,

BZOJ 2178: 圆的面积并 [辛普森积分 区间并]

2178: 圆的面积并 Time Limit: 20 Sec  Memory Limit: 259 MBSubmit: 1740  Solved: 450[Submit][Status][Discuss] Description 给出N个圆,求其面积并 Input 先给一个数字N ,N< = 1000 接下来是N行是圆的圆心,半径,其绝对值均为小于1000的整数 Output 面积并,保留三位小数 太可怕了!!!!!! 直接上辛普森积分 函数值就是x=..线上的区间并 区间并直接排序扫描就可以了

HDU 2876 Ellipse, again and again

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2876   HDU集训队选拔赛地点:3教3楼机房,时间:5月10日(周六)12:00開始,请相互转告,谢谢~百度之星编程大赛--您报名了吗?  Ellipse, again and again Time Limit: 2000/1000 MS (Java/Others)    Memor

BZOJ 1502 NOI 2005 月下柠檬树 计算几何 自适应辛普森积分

题目大意:有一个由圆锥和圆台组成的柠檬树,在月亮发出的平行光下,可以形成一个影子,求这个影子的面积. 思路:理解投影的性质:只要是平行光线,投影在水平面上,所得的图形都与原图形全等. 知道了这一点我们就可以画画图,分析就知道,其实柠檬树的影子,就是一些园和等腰梯形的面积的并.(如下图,样例) 运用计算几何的知识就可以得到圆的方程和圆的公切线的方程,然后得到一个连续的函数.最后这个题就成为一直函数的解析式,求这个函数与X轴之间的面积. 套用辛普森积分:Simpson(l,r) = (F(l) +

[BZOJ1502]月下柠檬树(自适应辛普森积分)

1502: [NOI2005]月下柠檬树 Time Limit: 5 Sec  Memory Limit: 64 MBSubmit: 1387  Solved: 739[Submit][Status][Discuss] Description 李哲非常非常喜欢柠檬树,特别是在静静的夜晚,当天空中有一弯明月温柔地照亮地面上的景物时,他必会悠闲地 坐在他亲手植下的那棵柠檬树旁,独自思索着人生的哲理.李哲是一个喜爱思考的孩子,当他看到在月光的照射下 柠檬树投在地面上的影子是如此的清晰,马上想到了一个问