Mayor's posters(线段树 + 离散化)

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters
and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates
started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.

Your task is to find the number of visible posters when all the posters are placed given the information about posters‘ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among
the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After
the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

解题思路:

难点在于离散化,数据过大,必须进行离散化,而且不能是普通的离散化。如果两个相邻海报没有紧挨着,则在离散化的时候必须给两个海报之间留有间隔。

打个比方:(1,10)(1,4)(5,10)这组数据,普通离散化后应该为(1,4)(1,2)(3,4),那么答案应该为2。

(1,10)(1,3)(6,10)这组数据普通离散化后应该也为(1,4)(1,2)(3,4),答案也为2,可显然这题答案应该为3。问题就出在未留有间隔。

解决方案就是判断是否紧挨,若没有紧挨,就在离散化的时候往数组里面加一个数。在这里我采用的是用结构体来进行离散化。

剩下的就是求海报出现的个数问题,对线段进行着色,后贴的海报着色会覆盖之前的海报,最后统计颜色的种数即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
const int maxn = 11111;
int x[maxn << 2], col[maxn << 4], ans, c[maxn << 2];
bool flag[maxn << 2];
struct san
{
    int a, pos;
}f[maxn << 2];
bool cmp(san v, san t)
{
    return v.a < t.a;
}
void PushDown(int rt)
{
    if(col[rt] != 0)
    {
        col[rt << 1] = col[rt << 1 | 1] = col[rt];
        col[rt] = 0;
    }
}
void update(int L, int R, int c, int l, int r, int rt)
{
    if(L <= l && R >= r)
    {
        col[rt] = c;
        return;
    }
    PushDown(rt);
    int m = (l + r) >> 1;
    if (L <= m) update(L , R , c , lson);
    if (m < R) update(L , R , c , rson);
}
void query(int l, int r, int rt)
{
    if(col[rt] != 0)
    {
        if(!flag[col[rt]])  // 用flag检测该颜色是否之前出现过
        {
            ans++;
            flag[col[rt]] = true;
        }
        return;
    }
    if(l == r)
        return;
    int m = (l + r) >> 1;
    query(lson);
    query(rson);
}
int main()
{
    int t, n, ll, rr;
    scanf("%d", &t);
    while(t--)
    {
       ans = 0;
       memset(col , 0, sizeof(col));
       memset(flag, false, sizeof(flag));
       scanf("%d", &n);
       int k = 0;
       for(int i = 1; i <= n; i++)
       {
           scanf("%d%d", &ll, &rr); // 用f存储左右范围的值,因此有2*n个
           f[++k].a = ll;
           f[k].pos = k;
           f[++k].a = rr;
           f[k].pos = k;
       }
        sort(f + 1, f + k + 1, cmp); //进行第一次排序
        int t = 2 * n;
        for(int i = 2; i <= 2 * n; i++)
        {
            if(f[i].a > f[i - 1].a + 1)  //判断是否紧挨,无需考虑两者是否属于同一个海报
            {
                f[++t].a = f[i - 1].a + 1; // 未紧挨就加上一个紧挨的数
                f[t].pos = 0;  // 使其pos为0,就不会在离散化时进入有效值中
            }
        }
        int m = 1;
        c[1] = 1;
        sort(f + 1, f + t + 1, cmp); // 二次排序,产生间隔
        for(int i = 2; i <= t; i++)  // 去重处理
        {
            if(f[i].a == f[i - 1]. a)
                c[i] = m;
            else
                c[i] = ++m;
        }
        for(int i = 1; i <= t; i++)  // 得到有效值
            x[f[i].pos] = c[i];
        for(int i = 1; i <= 2 * n - 1; i += 2)  //进行着色
            update(x[i], x[i + 1], i, 1, 4 * n, 1);
        query(1, 4 * n, 1);  // 求颜色种类
        printf("%d\n", ans);
    }
    return 0;
}

Mayor's posters(线段树 + 离散化)

时间: 2024-09-26 22:08:00

Mayor's posters(线段树 + 离散化)的相关文章

Poj 2528 Mayor&#39;s posters (线段树+离散化)

题目连接: http://poj.org/problem?id=2528 题目大意: 有10000000块瓷砖,n张海报需要贴在墙上,每张海报所占的宽度和瓷砖宽度一样,长度是瓷砖长度的整数倍,问按照所给海报顺序向瓷砖上贴海报,最后有几张海报是可见的? 解题思路: 因为瓷砖块数和海报张数多,首选线段树,如果按照常规的建树方式,把瓷砖当做数的节点,肯定会MTL......... 所以我们可以用海报的起点和终点当做树的节点,这样树的节点才有20000个,但是这样建树的话,求海报覆盖了那些节点会很复杂,

POJ 2528 Mayor&#39;s posters (线段树区间更新+离散化)

题目链接:http://poj.org/problem?id=2528 给你n块木板,每块木板有起始和终点,按顺序放置,问最终能看到几块木板. 很明显的线段树区间更新问题,每次放置木板就更新区间里的值.由于l和r范围比较大,内存就不够了,所以就用离散化的技巧 比如将1 4化为1 2,范围缩小,但是不影响答案. 写了这题之后对区间更新的理解有点加深了,重点在覆盖的理解(更新左右两个孩子节点,然后值清空),还是要多做做题目. 1 #include <iostream> 2 #include <

Mayor&#39;s posters(线段树之点的成段更新加离散化)

bin神的萌萌哒专题 这道题目也是简单区间更新的线段树题目,不过题目的数据范围很大,直接搞,时间空间的花费都会异常的高,所以就要用到离散化来优化时间空间复杂度. 何为离散化?........................ 简单地说就是对于给出的庞大数据进行一种数据上的缩小. 比如给你一段(1,10000)的区间,由于我们要的不是其区间长度,我们只需要知道这段区间的状态 如何,于是我们可以忽视其长度,把其表示成(1,2)这个区间长度极小的区间,这相当于物理上的质点. 当我们处理的问题上与其区间长

POJ 2528 Mayor&#39;s posters 线段树成段更新+离散化

题目来源:POJ 2528 Mayor's posters 题意:很多张海报贴在墙上 求可以看到几张海报 看那两张图就行了 第一张俯视图 思路:最多2W个不同的数 离散化一下 然后成段更新 a[rt] = i代表这个区间是第i张报纸 更新玩之后一次query cover[i]=1代表可以看到第i张报纸 #include <cstdio> #include <algorithm> #include <cstring> using namespace std; const

poj-----(2528)Mayor&#39;s posters(线段树区间更新及区间统计+离散化)

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 43507   Accepted: 12693 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post

poj 2528 Mayor&#39;s posters(线段树)

题目链接:http://poj.org/problem?id=2528 思路分析:线段树处理区间覆盖问题,也可以看做每次给一段区间染不同的颜色,最后求在整段区间上含有的所有颜色种类数: 注意由于区间太大,所以需要离散化: 区间更新:对于线段树的每个结点,标记颜色,初始时没有颜色,标记为0:当更新时,使用延迟标记,需要标记传递到子节点: 区间查询:使用深度优先查询线段树,当某个子节点的颜色不为0时,即停止深度优先搜索,并在map中查询是否已经记录该段区间的颜色: 代码如下: #include <i

poj2528--Mayor&#39;s posters(线段树+离散化)

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 41785   Accepted: 12164 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post

POJ2528Mayor&#39;s posters[线段树 离散化]

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 59683   Accepted: 17296 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post

Mayor&#39;s posters 线段树区间覆盖

题目链接 http://poj.org/problem?id=2528 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally dec

POJ_2528 Mayor&#39;s poster(线段树+离散化)

题目请点我 题解: 这道题与之前的题目相比重点在于一个映射的预处理,题目所给的区间达到10000000,而最多只有10000个点,如果直接建树的话太过于空旷.把这些区间的左右节点一一对应,最多有4×10000个点,远小于之前的10000000,而且区间之间的对应关系也不会改变. 举个例子: 区间:[2,6],[4,8],[6,10] 我们进行下面对应: 2 4 6 8 10 1 2 3 4 5 则原区间变为[1,3],[2,4],[3,5].可以发现它们之间的覆盖关系并没有改变,但是却紧凑了很多