题目链接:
这题和hdu1429是姊妹题 请参见传送门
题目:
Key Task
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1187 Accepted Submission(s): 470
Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange
long corridors that fork and join at absolutely unexpected places.
The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way
out of a labyrinth. Your task is to write a verification software that solves this game.
The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors
of the same color.
You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square
with an appropriate key before.
Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following:
Note that it is allowed to have
You may assume that the marker of your position (“*”) will appear exactly once in every map.
There is one blank line after each map. The input is terminated by two zeros in place of the map size.
Output
For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead.
One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.
Sample Input
1 10 *........X 1 3 *#X 3 20 #################### #XY.gBr.*.Rb.G.GG.y# #################### 0 0
Sample Output
Escape possible in 9 steps. The poor student is trapped! Escape possible in 45 steps.
Source
2008
“Shun Yu Cup” Zhejiang Collegiate Programming Contest - Warm Up(2)
Recommend
linle | We have carefully selected several similar problems for you: 1882 1887 1889 1883 1888
代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=20+10;
char map[maxn][maxn];
int n,m,t;
bool vis[maxn][maxn][(1<<10)+10];
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
struct Point
{
int x,y,step;
int key;
};
queue<Point>Q;
Point st;
bool check(int x,int y)
{
if(x>=1&&x<=n&&y>=1&&y<=m&&map[x][y]!='*')
return true;
return false;
}
int bfs()
{
while(!Q.empty()) Q.pop();
memset(vis,false,sizeof(vis));
vis[st.x][st.y][st.key]=true;
st.key=st.step=0;
Q.push(st);
Point cur,nex;
while(!Q.empty())
{
cur=Q.front();
Q.pop();
if(map[cur.x][cur.y]=='^')
return cur.step;
for(int i=0;i<4;i++)
{
nex.x=cur.x+dx[i];
nex.y=cur.y+dy[i];
nex.key=cur.key;
if(check(nex.x,nex.y))
{
nex.step=cur.step+1;
if(nex.step>=t)
continue;
else if(map[nex.x][nex.y]>='A'&&map[nex.x][nex.y]<='Z')
{
int temp=map[nex.x][nex.y]-'A';
int nk=cur.key&1<<temp;
if(nk&&!vis[nex.x][nex.y][nex.key])
{
vis[nex.x][nex.y][nex.key]=true;
Q.push(nex);
}
}
else if(map[nex.x][nex.y]>='a'&&map[nex.x][nex.y]<='z')
{
int temp=map[nex.x][nex.y]-'a';
nex.key=cur.key|1<<temp;
if(!vis[nex.x][nex.y][nex.key])
{
vis[nex.x][nex.y][nex.key]=true;
Q.push(nex);
}
}
else
{
if(!vis[nex.x][nex.y][nex.key])
{
vis[nex.x][nex.y][nex.key]=true;
Q.push(nex);
}
}
}
}
}
return -1;
}
inline void read_graph()
{
char str[maxn];
for(int i=1;i<=n;i++)
{
scanf("%s",str+1);
for(int j=1;j<=m;j++)
{
if(str[j]=='@')
{
st.x=i;
st.y=j;
map[i][j]=str[j];
}
else map[i][j]=str[j];
}
}
}
int main()
{
while(~scanf("%d%d%d",&n,&m,&t))
{
read_graph();
int ans=bfs();
printf("%d\n",ans);
}
return 0;
}
hdu1885Key Task(状态压缩+bfs)