POJ 3481 & HDU 1908 Double Queue (map运用)

题目链接:

PKU:http://poj.org/problem?id=3481

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1908

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by
a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed
to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
K P Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same
client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

Source

Southeastern Europe 2007

题意:

三个操作:

1、插入两个数,第一个数是客户的名字,第二个数是优先级!

2、输出当前客户中优先级最高的名字,并删除!

3、输出当前客户中优先级最低的名字,并删除!

代码如下:

#include <cstdio>
#include <map>
#include <cstring>
#include <algorithm>
using namespace std;
#include <string>
map<int,int> m;
int main()
{
    int op;
    int name, p;
    while(~scanf("%d",&op))
    {
        if(op == 0)
            break;
        if(op == 2 && m.size() == 0)
        {
            printf("0\n");
            continue;
        }
        if(op == 3 && m.size() == 0)
        {
            printf("0\n");
            continue;
        }
        if(op == 1)
        {
            scanf("%d%d",&name,&p);
            m[p] = name;
            continue;
        }
        if(op == 2)
        {
            printf("%d\n",(*m.rbegin()).second);
            m.erase(m.find((*m.rbegin()).first));
            //printf("%d\n",(*m.end()).second);
            //m.erase(m.end());
            //注意此处不能用*m.end(),因为*m.end()返回的是数组的最后一个单元+1的指针
        }
        else
        {
            //printf("%d\n",(*m.rend()).second);//同样
            //m.erase(m.find((*m.rend()).first));
            printf("%d\n",(*m.begin()).second);
            m.erase(m.begin());
        }
    }
    return 0;
}
时间: 2024-10-11 11:43:28

POJ 3481 & HDU 1908 Double Queue (map运用)的相关文章

hdu 1908 Double Queue (map)

# include <stdio.h> # include <algorithm> # include <iostream> # include <string.h> # include <string> # include <map> using namespace std; int main() { map<int,int>q; map<int,int>::iterator p; int n,name,nu

HDU 1908 Double Queue&lt;Set&gt;

Problem Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of th

hdu 1908 Double Queue

题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=1908 Double Queue Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using mod

HDU 1908 Double Queue(set)

Problem Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of th

hdu 1908 double queues

http://acm.hdu.edu.cn/showproblem.php?pid=1908 看到有两个优先级,然后题目中又有queue...就想到了优先队列... 但是优先队列的cmp函数没搞懂,因为比较的是结构体,好像要重载< 什么的. 然而并不会. 其实用map就可以做... map在插入的时候可以自动按关键字排序,简直好评如潮! #include <algorithm> #include <cstdio> #include <iostream> #incl

poj 3481 Double Queue STL中map的运用

题意: 维护一个集合,操作有1:加入一个元素,2:删除最大元素,3:删除最小元素. 分析: map本质是个容器,且具有第一个关键字有序的性质,所以用它来水水就好啦~ 代码: //poj 3481 //sep9 #include <iostream> #include <map> using namespace std; map<int,int> mymap; map<int,int>::iterator iter; int main() { int x,su

POJ 题目3481 Double Queue(SBT ro map)

Double Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11824   Accepted: 5385 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provid

POJ 3481 Double Queue(Treap模板题)

Double Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 15786   Accepted: 6998 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provid

AVL树(模板题)—— POJ 3481 Double Queue

对应POJ题目:点击打开链接 Double Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11741   Accepted: 5335 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing env