【bzoj1531】[POI2005]Bank notes 多重背包dp

题目描述

Byteotian Bit Bank (BBB) 拥有一套先进的货币系统,这个系统一共有n种面值的硬币,面值分别为b1, b2,..., bn. 但是每种硬币有数量限制,现在我们想要凑出面值k求最少要用多少个硬币.

输入

第一行一个数 n, 1 <= n <= 200. 接下来一行 n 个整数b1, b2,..., bn, 1 <= b1 < b2 < ... < b n <= 20 000, 第三行 n 个整数c1, c2,..., cn, 1 <= ci <= 20 000, 表示每种硬币的个数.最后一行一个数k – 表示要凑的面值数量, 1 <= k <= 20 000.

输出

第一行一个数表示最少需要付的硬币数

样例输入

3
2 3 5
2 2 1
10

样例输出

3



题解

裸的多重背包+二进制拆分

把一种物品拆成 1个一组+2个一组+4个一组+8个一组+...,剩余的分组。然后作01背包dp即可。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int b[210] , c[210] , f[20010] , m;
void dp(int w , int c)
{
	int i;
	for(i = m ; i >= w ; i -- ) f[i] = min(f[i] , f[i - w] + c);
}
int main()
{
	int n , i , j;
	scanf("%d" , &n);
	for(i = 1 ; i <= n ; i ++ ) scanf("%d" , &b[i]);
	for(i = 1 ; i <= n ; i ++ ) scanf("%d" , &c[i]);
	scanf("%d" , &m);
	memset(f , 0x3f , sizeof(f)) , f[0] = 0;
	for(i = 1 ; i <= n ; i ++ )
	{
		for(j = 1 ; j <= c[i] ; j <<= 1)  dp(b[i] * j , j) , c[i] -= j;
		if(c[i]) dp(b[i] * c[i] , c[i]);
	}
	printf("%d\n" , f[m]);
	return 0;
}
时间: 2024-10-13 15:47:59

【bzoj1531】[POI2005]Bank notes 多重背包dp的相关文章

BZOJ 1531 POI2005 Bank notes 多重背包

题目大意:多重背包 一大早就水了个题233 #include <cstdio> #include <cstring> #include <iostream> #include <algorithm> #define M 20200 using namespace std; int n,k,b[220],c[220]; int f[M]; int main() { int i,j,k; cin>>n; for(i=1;i<=n;i++) sc

BZOJ1531: [POI2005]Bank notes

1531: [POI2005]Bank notes Time Limit: 5 Sec  Memory Limit: 64 MBSubmit: 229  Solved: 119[Submit][Status] Description Byteotian Bit Bank (BBB) 拥有一套先进的货币系统,这个系统一共有n种面值的硬币,面值分别为b1, b2,..., bn. 但是每种硬币有数量限制,现在我们想要凑出面值k求最少要用多少个硬币. Input 第一行一个数 n, 1 <= n <

BZOJ 1531: [POI2005]Bank notes( 背包 )

多重背包... ---------------------------------------------------------------------------- #include<bits/stdc++.h> #define rep(i, n) for(int i = 0; i < n; i++) #define clr(x, c) memset(x, c, sizeof(x)) using namespace std; const int maxn = 209, maxk =

【BZOJ 1531】 [POI2005]Bank notes

1531: [POI2005]Bank notes Time Limit: 5 Sec Memory Limit: 64 MB Submit: 271 Solved: 139 [Submit][Status][Discuss] Description Byteotian Bit Bank (BBB) 拥有一套先进的货币系统,这个系统一共有n种面值的硬币,面值分别为b1, b2,-, bn. 但是每种硬币有数量限制,现在我们想要凑出面值k求最少要用多少个硬币. Input 第一行一个数 n, 1

1531: [POI2005]Bank notes二进制优化(c++)

Description Byteotian Bit Bank (BBB) 拥有一套先进的货币系统,这个系统一共有n种面值的硬币,面值分别为b1, b2,..., bn. 但是每种硬币有数量限制,现在我们想要凑出面值k求最少要用多少个硬币. Input 第一行一个数 n, 1 <= n <= 200. 接下来一行 n 个整数b1, b2,..., bn, 1 <= b1 < b2 < ... < b n <= 20 000, 第三行 n 个整数c1, c2,...,

POJ 1742 Coins 【多重背包DP】

题意:有n种面额的硬币.面额.个数分别为A_i.C_i,求最多能搭配出几种不超过m的金额? 思路:dp[j]就是总数为j的价值是否已经有了这种方法,如果现在没有,那么我们就一个个硬币去尝试直到有,这种价值方法有了的话,那么就是总方法数加1.多重背包可行性问题 传统多重背包三重循环会超时,因为只考虑是否可行,没有考虑剩余面额数量的因素. o(n*v)方法 #include <iostream> #include <cstdio> #include <string.h> #

DZY Loves Math II:多重背包dp+组合数

Description Input 第一行,两个正整数 S 和 q,q 表示询问数量.接下来 q 行,每行一个正整数 n. Output 输出共 q 行,分别为每个询问的答案. Sample Input 30 3 9 29 1000000000000000000 Sample Output 0 9 450000036 Hint 感谢the Loser协助更正数据对于100%的数据,2<=S<=2e6??,1<=n<=101810^{18}10?18??,1<=q<=10

BZOJ 1531 POI2005 Bank notes

多重背包问题,二进制拆分后做~ #include <cstdio> #include <algorithm> #include <cstring> #define up(a,b,c) for(register int c=a;c<=b;++c) #define down(a,b,c) for(register int c=a;c>=b;--c) typedef long long ll; ll n,x; ll num[205],value[205],Aim,

多重背包(dp专题)

题目大意:输入n,代表有n种数,接下来n个数代表n种数,再接下来n个数代表每种数有多少个,在输入K,代表用这些数要加成的和 问你是否能加为K,能输出yes,不能输出no 这是一个典型的多重背包问题,可以用dp来求解,.但是如何定义递推关系会影响到最终的复杂度,首先我们先看一下如下定义: dp[i+1][j]:=用前i种数能否加成和为j 为了用前i种数加成j,也就需要能用前i-1种数字加成j,j-a[i],···,j-mi*a[i],中的某一种,由此我们可以定义如下递推关系 dp[i+1][j]=