两台路由器的BGP实战策略路由分发需求实战方案设计

R1和R2有两根线路相连,使用BGP,R1有两组路由,192.168.1.0/24和192.168.2.0/24,当两根线都通的状态下,两组路由流量分散平衡在两个线路上,当其中任意一根断的情况下,只通192.168.1.0/24流量。

方法1

【R1配置】
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.2.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 timers 1 3
neighbor 10.1.12.2 remote-as 2
neighbor 10.1.12.2 timers 1 3
neighbor 10.2.12.2 remote-as 2
neighbor 10.2.12.2 timers 1 3
maximum-paths 2
!
address-family ipv4
  neighbor 2.2.2.2 activate
  neighbor 10.1.12.2 activate
  neighbor 10.2.12.2 activate
  maximum-paths 2
  no auto-summary
  no synchronization
  network 192.168.1.0
  network 192.168.2.0
exit-address-family
!
no ip http server
no ip http secure-server
ip route 2.2.2.2 255.255.255.255 FastEthernet0/0 10.2.12.2
ip route 2.2.2.2 255.255.255.255 FastEthernet1/0 10.1.12.2
!

【R2配置】
!
ip sla monitor 1
type echo protocol ipIcmpEcho 10.2.12.1 source-interface FastEthernet0/0
ip sla monitor schedule 1 start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 10.1.12.1 source-interface FastEthernet1/0
ip sla monitor schedule 2 start-time now
!
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
track 3 list boolean and
object 1
object 2
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
router bgp 2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 timers 1 3
neighbor 10.1.12.1 remote-as 1
neighbor 10.1.12.1 timers 1 3
neighbor 10.2.12.1 remote-as 1
neighbor 10.2.12.1 timers 1 3
maximum-paths 2
!
address-family ipv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 distribute-list 1 in
  neighbor 10.1.12.1 activate
  neighbor 10.1.12.1 distribute-list 2 in
  neighbor 10.2.12.1 activate
  neighbor 10.2.12.1 distribute-list 2 in
  maximum-paths 2
  no auto-summary
  no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
ip route 1.1.1.1 255.255.255.255 10.2.12.1 track 3
ip route 1.1.1.1 255.255.255.255 10.1.12.1 track 3
!
!
!
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 2 permit 192.168.1.0 0.0.0.255

方法2

R2修改方案,为企业方

ip sla monitor 1
type echo protocol ipIcmpEcho 10.2.12.1 source-interface FastEthernet0/0
ip sla monitor schedule 1 start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 10.1.12.1 source-interface FastEthernet1/0
ip sla monitor schedule 2 start-time now
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
track 3 list boolean and
object 1
object 2
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.2.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
router bgp 2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 timers 1 3
neighbor 10.1.12.1 remote-as 1
neighbor 10.1.12.1 timers 1 3
neighbor 10.2.12.1 remote-as 1
neighbor 10.2.12.1 timers 1 3
maximum-paths 2
!
address-family ipv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 distribute-list 1 out
  neighbor 10.1.12.1 activate
  neighbor 10.1.12.1 distribute-list 2 out
  neighbor 10.2.12.1 activate
  neighbor 10.2.12.1 distribute-list 2 out
  maximum-paths 2
  no auto-summary
  no synchronization
  network 192.168.1.0
  network 192.168.2.0
exit-address-family
!
no ip http server
no ip http secure-server
ip route 1.1.1.1 255.255.255.255 10.2.12.1 track 3
ip route 1.1.1.1 255.255.255.255 10.1.12.1 track 3
!
!
!
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 2 permit 192.168.1.0 0.0.0.255

R1上down其中一个接口
R2提示
R2#
*Mar  1 02:34:50.951: %BGP-5-ADJCHANGE: neighbor 10.1.12.1 Down BGP Notification sent
R2#
*Mar  1 02:34:50.955: %BGP-3-NOTIFICATION: sent to neighbor 10.1.12.1 4/0 (hold time expired) 0 bytes
R2#
R2#
R2#
R2#
R2#
*Mar  1 02:35:00.387: %TRACKING-5-STATE: 2 rtr 2 reachability Up->Down
*Mar  1 02:35:00.555: %TRACKING-5-STATE: 3 list boolean and Up->Down
R2#
*Mar  1 02:35:02.939: %BGP-3-NOTIFICATION: received from neighbor 1.1.1.1 4/0 (hold time expired) 0 bytes
R2#
*Mar  1 02:35:02.947: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Down BGP Notification received
R1的路由表
R1#sh ip ro b
B    192.168.1.0/24 [20/0] via 10.2.12.2, 00:03:24

方法3

使用advertise-map来解决,但有些IOS不支持。

(R1)  Config:
router bgp 1
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
network 192.168.2.0
redistribute connected route-map redis_conn (目的是想将两条外线路由弄进bgp 路由表,方便后面的advertise-map检测这两条路由的存在性来决定是否要发布次要网段)
neighbor 12.1.1.2 remote-as 2
neighbor 12.1.1.2 update-source Serial1/0
neighbor 12.1.1.2 advertise-map dist_out2 exist-map line2(如果外线2正常,外线2的路由就会重分发进bgpl路由表,就通告出次要路由,此时如果2正常,且能从s1/0【一线端口】通告给邻居路由,说明1先也正常,即都正常。如果2线断线,端口就会down,route-map  redis_conn,也就不会将line2这条路有分布进bgp路由表,就不会宣告次要路由,也是有点类似交叉建邻居的方法,下面同理)
neighbor 12.1.2.2 remote-as 2
neighbor 12.1.2.2 update-source Serial1/1
neighbor 12.1.2.2 advertise-map dist_out2 exist-map line1
no auto-summary
!

ip prefix-list dist_out2 seq 5 permit 192.168.2.0/24
!
ip prefix-list line1 seq 5 permit 12.1.1.0/30(外线一路由)
!         
ip prefix-list line2 seq 5 permit 12.1.2.0/30(外线二路由)
!

route-map redis_conn permit 10
match interface Serial1/0 Serial1/1

route-map dist_out2 permit 10
match ip address prefix-list dist_out2
!

route-map line2 permit 10
match ip address prefix-list line2
!
route-map line1 permit 10
match ip address prefix-list line1
!

ISP(R2)  Config:     (ISP的配置很简单,基本什么都不做,实际来说,用户有什么需求,最好做在CE上面,PE上在能满足的要求的情况下,尽量精简配置,节约资源)
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 12.1.1.1 remote-as 1
neighbor 12.1.1.1 update-source Serial1/0
neighbor 12.1.2.1 remote-as 1
neighbor 12.1.2.1 update-source Serial1/1
no auto-summar

时间: 2024-09-30 05:57:01

两台路由器的BGP实战策略路由分发需求实战方案设计的相关文章

思科两台路由器telnet

实验一:两台路由器 实验拓扑 实验要求 两台路由器都开启telnet功能,用访问控制列表使RT1能够通过telnet远程登陆RT2,而RT2不能登陆RT1 实验步骤 1.给两台路由器的接口配置IP地址 2.开启telnet功能,并设置登录密码 3.测试一下两台路由器是否能互相登陆 4.配置访问控制列表实现实验要求,并将列表应用在RT1的接口入方向 5.测试实验结果 实验总结

利用静态路由将两台路由器拼通三台pc

静态路由 要求:利用静态路由配置两台路由器并拼通三台pc 首先,在思科模拟器中,将路由器和pc用合适的线缆连接好,如图:1.第一步,我们首先设置好pc0.pc1.pc2的IP,子网掩码,网关:2.接下来设置路由器端口信息:进入特权模式(enable),在进入配置模式(config).依照此步骤将剩下端口信息设置完成3.设置完成后端口的红点将变成绿色 原文地址:http://blog.51cto.com/14118608/2335714

家里用两台路由器(转)

买EeePC的时候,我还顺便买了一台无线路由器. 买回来以后,就遇到一个问题:我家已经有一台路由器了,怎样才能再加一台进去呢? 网上查到的资料,都写得太专业,对像我这样的业余人士用处不大.我反复设置各种参数,整整花了一个晚上,才算安装成功.下面就是一些设置要点,我记录下来备忘,希望对其他朋友有用. ================== 先说一下我家的网络情况. 如上图所示,我家使用ADSL上网.ADSL Modem直接连电话线,后面跟了一台路由器.然后,拉了两根线,一根供大房间里的PC上网,另一

终端通过两台路由器相互通信(静态路由设置)

一.示意图 二.IP规划 1) 配置终端IP.子网掩码.网关 PC0:192.168.10.100  255.255.255.0  192.168.10.1 PC1:10.185.10.100  255.255.255.0 10.185.10.1 2) 配置路由端口的IP地址. Router0 f0/0:ip add  192.168.10.1  255.255.255.0 Router0 f0/1:ip add  192.168.20.100  255.255.255.0 Router1 f0

使用两个路由器扩展家庭无线网络

当我们在家里使用无线路由器时,往往会因为墙导致在有的房间里面没有无线信号.这时就需要用扩展无线网络,本文这里介绍一种廉价且高效的使用两个路由器方式. 用网线连接A路由器LAN口(1到4随便一个口)和B路由器LAN口.(两台路由器设置好后再用网线连接)这种方法通过网线连接即稳定速度又快,但后期配置维护不方便. 这种方式下,是相当于把B路由器当作集线器使用的. PS: 这里的连接是不需要直接的物理连接,只要在一个子网内即可,像家庭布线的时候往往会将网口牵到每一个房间,使用该网口连接到B路由器即可.

Winpcap网络编程十之Winpcap实战,两台主机通过中间主机通信

注:本篇博客同样不针对于伸手党,源代码等等的我不会完全公开的,此篇文章写出来为大家的网络编程或者课程设计提供一定的思路.. 好,本次我们需要完成的任务是: 完成两台主机通过中间主机的数据通信(网络层) 增加基于IP地址的转发功能 增加网络层封装 其实最主要的就是基于IP地址的转发功能,网络层的封装其实我们在初级功能中就已经做好了. 首先,实验的思路是A通过中间主机B向C发送数据.那么B则作为一个路由器,B要监听两个网卡,一个网卡发来的数据通过另一个网卡发出去. 示意图如下: A---------

实战栈溢出:三个漏洞搞定一台路由器(转自长亭科技)

转:https://zhuanlan.zhihu.com/p/26271959 背景知识: 1.snprintf(),为函数原型int snprintf(char *str, size_t size, const char *format, ...),将可变个参数(...)按照format格式化成字符串,然后将其复制到str中. 函数返回值:若成功则返回欲写入的字符串长度,若出错则返回负值.与snprintf的返回值不同,sprintf的返回值是成功写入的字符串长度,此处需要谨慎处理! 2.st

让两台主机通过四个路由器互通

让两台主机通过四个路由器互通 网络拓扑图如下: 环境准备:需要在vmware虚拟机中克隆6台虚拟机,每台系统环境为centos6.9 ,每台分配的最小内存为256M. R1,R2,R3,R4 这四台主机需要开启路由转发功能:vim /etc/sysctl.confnet.ipv4.ip_forward = 1sysctl -piptables -F克隆机需要重新更改网卡的名字.1.cat /etc/udev/rules.d/70-persistent-net.rules 2.将上述文件中的mac

实现两台电脑通过多条路由器也能通信(全网通与静态路由的设置)

思科测试中,还有一个项目让我很纠结.有两点: 第一:全网通的设置在边际路由器上的时候,中间的路由器怎么设置. 第二:路由器之间的吓一跳怎么设置,特别是边际路由器的吓一跳设置. 首次做的时候以为只需要给两台边际路由器设置成全网通就行,中间路由器并没有设置吓一跳,所以一直行不通.后来又被边际路由器的吓一跳设置给困住了,以为是跳到终端的ip段.在此我记下两点笔记:首先:默认路由在静态路由里设置(子网掩码格式为0.0.0.0).一般设置在边际路由(连接终端)上,不属于边际的路由正常设置静态路由.其次:边