杭电 HDU ACM 1405 The Last Practice

The Last Practice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8374    Accepted Submission(s): 1724

Problem Description

Tomorrow is contest day, Are you all ready?

We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.

what does this problem describe?

Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it  should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

Hint

60=2^2*3^1*5^1


 

Author

lcy

这个题目气的我头疼,以前做过类似的题目 ,思路先是 素数打表,然后依次检索并记录素数因子,重复此过程直到,n==1;不过不幸的是超时。参考了网上的方法。

不好理解,可以这样想。一个数既然可以表示某些素数的乘积,那么对于一个数n,从2开始检索n的所有因子,那么既然是n的因子,必然为质数,反证:如果某个i为合数,

那么必然又能写成两小一点儿得数乘积,早就应该被从2开始的因子分解掉了,不可能发生,那么只能是质数了。

这个是超时的:

#include<iostream>
#include<cmath>
#include<string.h>
using namespace std;
int ls[65539];
int cnt[1000];
int u=0;
void prime()
{
	for(int i=1;i<=65537;i++)
	ls[i]=1;
	for(int j=2;j<sqrt(65537);j++)
	{
		if(ls[j])
		{
			for(int k=j+j;k<=65537;k+=j)
				ls[k]=0;
		}
	}

	for(int r=2;r<=65537;r++)
	{
		if(ls[r])
			cnt[u++]=r;
	}

}

int main()
{
	int n;int gq[65540];int h=1;
    prime();
	while(cin>>n&&n>0)
	{
		memset(gq,0,sizeof(gq));
		for(int x=0;x<u;x++)
		{
			if(n%cnt[x]==0)
			{
				gq[cnt[x]]++;
			n/=cnt[x];
			}
			if(n==1)
				break;
			else if(n<=cnt[x])
				x=-1;

		}

		cout<<"Case "<<h++<<"."<<endl;
		for(int p=0;p<=65534;p++)
		{
			if(gq[p])
				cout<<p<<" "<<gq[p]<<" ";
		}
		cout<<endl<<endl;
	}
	return 0;
}

AC Code:

#include<iostream>
using namespace std;
int main()
{
	int n,ls[100],gq[50],flag=0,t=1;
	while(cin>>n&&n>0)
	{
		if(flag)
			cout<<endl;
		memset(ls,0,sizeof(ls));
		memset(gq,0,sizeof(gq));
		int k=0;
		for(int i=2;n!=1;i++)
		{
			if(n%i==0)
			{
				ls[k]=i;
				while(n%i==0)
				{
					gq[k]++;
					n/=i;
				}
				k++;
			}

		}

		cout<<"Case "<<t++<<"."<<endl;
		for(int m=0;m<k;m++)
			cout<<ls[m]<<" "<<gq[m]<<" ";
		cout<<endl;
		flag=1;
	}
	return 0;
}

时间: 2024-10-14 15:20:45

杭电 HDU ACM 1405 The Last Practice的相关文章

杭电HDU ACM Uncle Tom&#39;s Inherited Land*(二分图匹配 建模)

Uncle Tom's Inherited Land* Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2496    Accepted Submission(s): 1028 Special Judge Problem Description Your old uncle Tom inherited a piece of land f

杭电 HDU ACM 1397 Goldbach&#39;s Conjecture

Goldbach's Conjecture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4976    Accepted Submission(s): 1901 Problem Description Goldbach's Conjecture: For any even number n greater than or equal

杭电 HDU ACM 5186 zhx&#39;s submissions

zhx's submissions Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1892    Accepted Submission(s): 507 Problem Description As one of the most powerful brushes, zhx submits a lot of code on many

杭电 HDU ACM 1025 Constructing Roads In JGShining&#39;s Kingdom

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17732    Accepted Submission(s): 5023 Problem Description JGShining's kingdom consists of 2n(n is no mo

杭电 HDU ACM 圆桌会议

圆桌会议 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3356    Accepted Submission(s): 2351 Problem Description HDU ACM集训队的队员在暑假集训时经常要讨论自己在做题中遇到的问题.每当面临自己解决不了的问题时,他们就会围坐在一张圆形的桌子旁进行交流,经过大家的讨论后一般没有

杭电 HDU ACM 1046 Tempter of the Bone

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 83458    Accepted Submission(s): 22740 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

杭电 HDU ACM 1496 Equations

Equations Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 6065    Accepted Submission(s): 2455 Problem Description Consider equations having the following form: a*x1^2+b*x2^2+c*x3^2+d*x4^2=0 a,

杭电 HDU ACM 1283 最简单的计算机

最简单的计算机 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5238    Accepted Submission(s): 2967 Problem Description 一个名叫是PigHeadThree的研究组织设计了一台实验用的计算机,命名为PpMm.PpMm只能执行简单的六种命令A,B,C,D,E,F:只有二个内存M1,M

杭电 HDU ACM 1213 How Many Tables

How Many Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17049    Accepted Submission(s): 8349 Problem Description Today is Ignatius' birthday. He invites a lot of friends. Now it's dinn