Stockbroker Grapevine

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1‘ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001

大意:有T个人是传播源,接下来的每一行第一行都是这个人能转播的人数下面分别是被传播的人编号和传播所需要的时间数,要求所有人都被转播到得条件下问你应该选择那个人开始传播以及传播所需要的最短的时间。明显的邻接矩阵,用floyed(三个循环求出最小)算法求出最小的邻接矩阵。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f,MAX = 300;
int d[MAX],map[MAX][MAX];
int main()
{
    int y,t,T,n;
 while(~scanf("%d",&T)&&T){
        memset(d,0,sizeof(d));

        for(int i = 1; i <=T;i++)
            for(int j = 1; j <= T;j++)
              map[i][j] = inf;
int i;
        for( i = 1; i <= T; i++){
                scanf("%d",&n);
          while(n--){
                scanf("%d%d",&y,&t);
                map[i][y] = t;
          }
        }
        for(int k = 1; k <= T; k++){
            for(int i = 1; i <=T; i++){
                for(int j = 1; j <= T ;j++){
                            if(i!=k&&i!=j&&k!=j)
                        map[i][j] = min(map[i][j],map[i][k]+map[k][j]);
                    }
                }
        }//每一种都要满足
        int min1 = inf, k;
        for(int i = 1; i <= T ; i++){
            for(int j = 1; j <= T; j++)
                    if(map[i][j] > d[i]&&i!=j)
                      d[i] = map[i][j];

                  if(d[i] < min1){
                    min1 = d[i];
                    k = i;
              }
        }
        if(min1 == inf) printf("disjoint\n");
        else
        printf("%d %d\n",k,min1);
 }
 return 0;
}

时间: 2024-10-06 04:08:33

Stockbroker Grapevine的相关文章

POJ1125 Stockbroker Grapevine【Floyd】

Stockbroker Grapevine Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 27977 Accepted: 15527 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the st

POJ1125——Stockbroker Grapevine

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 27547   Accepted: 15264 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

POJ 1125 Stockbroker Grapevine

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 33141   Accepted: 18246 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

POJ 1125:Stockbroker Grapevine

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000KB   64bit IO Format: %I64d & %I64u Submit Status Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation among

【POJ 1125】Stockbroker Grapevine

[POJ 1125]Stockbroker Grapevine 最短路 不过这题数据很水..主要想大牛们试试南阳OJ同题 链接如下: http://acm.nyist.net/JudgeOnline/talking.php?pid=426&page=2 数据增大很多 用到很多东西才能过 (弱没过,,, 这题就是求最短路寻找所有通路中最大权的最小值外加考验英语水平-- Floyd 208K 0MS 1162B #include using namespace std; int dis[111][1

POJ 1125 Stockbroker Grapevine (Floyd算法)

Floyd算法计算每对顶点之间的最短路径的问题 题目中隐含了一个条件是一个人可以同时将谣言传递给多个人 题目最终的要求是时间最短,那么就要遍历一遍求出每个点作为源点时,最长的最短路径长是多少,再求这些值当中最小的是多少,就是题目所求 #include<bits/stdc++.h> using namespace std; int n,x,p,t; int m[120][120],dist[120][120],Max[120]; void floyd(int n,int m[][120],int

POJ1125 Stockbroker Grapevine 【Floyd】

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 27431   Accepted: 15201 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

pij——1125 Stockbroker Grapevine

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 37154   Accepted: 20676 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

Stockbroker Grapevine POJ 1125 Floyd

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 37069   Accepted: 20612 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

POJ 1125 Stockbroker Grapevine (动规)

Stockbroker Grapevine Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 26392 Accepted: 14555 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the st