HDU 4791 & ZOJ 3726 Alice's Print Service (数学 打表)

题目链接:

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=4791

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5072

Problem Description

Alice is providing print service, while the pricing doesn‘t seem to be reasonable, so people using her print service found some tricks to save money.

For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It‘s easy to figure out that if you want to print 99 pages, the best choice is to print an
extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.

Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input

The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.

Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 <
... < sn ≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price
when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.

Output

For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input

1
2 3
0 20 100 10
0 99 100

Sample Output

0
1000
1000

Source

2013 Asia Changsha Regional Contest

题意:

打印纸张,随着张数的添加,每张的价格非递增,给出
m 个询问打印的张数,求出最小的花费。

PS:

保留打印a[i]份分别须要的钱,从后往前扫一遍,保证取得最优解。

然后再找到所打印的张数的区间,与没有多打印,仅仅打印m张所需的花费比較!

HDU代码例如以下:

#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <iostream>
#define INF 1e18
using namespace std;

const int maxn=100017;
typedef __int64 LL;

LL s[maxn],p[maxn],c[maxn];

int main()
{
    int T;
    int n, m;
    LL tt;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
        {
            scanf("%I64d%I64d",&s[i],&p[i]);
        }

        LL minn = INF;
        for(int i = n-1; i >= 0; i--)
        {
            minn = min(s[i]*p[i],minn);
            c[i] = minn;
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%I64d",&tt);
            if(tt>=s[n-1])//最后
                printf("%I64d\n",tt*p[n-1]);
            else
            {
                int pos = upper_bound(s,s+n,tt)-s;
                LL ans = tt*p[pos-1];
                ans = min(ans,c[pos]);
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}

ZJU代码例如以下:

#include <cstdio>
#include <algorithm>
#include <iostream>
#define INF 1e18
using namespace std;

const int maxn = 100017;
typedef long long LL;

LL s[maxn], p[maxn], c[maxn];

int main()
{
    int T;
    int n, m;
    LL tt;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
        {
            scanf("%lld%lld",&s[i],&p[i]);
        }

        LL minn = INF;
        for(int i = n-1; i >= 0; i--)
        {
            minn = min(s[i]*p[i],minn);
            c[i] = minn;
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%lld",&tt);
            if(tt>=s[n-1])//最后
                printf("%lld\n",tt*p[n-1]);
            else
            {
                int pos = upper_bound(s,s+n,tt)-s;
                LL ans = tt*p[pos-1];
                ans = min(ans,c[pos]);
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}

HDU 4791 &amp; ZOJ 3726 Alice's Print Service (数学 打表)

时间: 2024-10-10 23:10:06

HDU 4791 &amp; ZOJ 3726 Alice&#39;s Print Service (数学 打表)的相关文章

HDU 4791 &amp; ZOJ 3726 Alice&#39;s Print Service (数学 打表)

题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=4791 ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5072 Problem Description Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her pr

HDU 4791 Alice&#39;s Print Service (2013长沙现场赛,二分)

Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1855    Accepted Submission(s): 454 Problem Description Alice is providing print service, while the pricing doesn't seem to

2013 ACM/ICPC 长沙现场赛 A题 - Alice&#39;s Print Service (ZOJ 3726)

Alice's Print Service Time Limit: 2 Seconds      Memory Limit: 65536 KB Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money. For example, the price when

HDU 4791 Alice&#39;s Print Service

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4791 题面: Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1596    Accepted Submission(s): 380 Problem Description Alice is pr

HDU 4791 Alice&#39;s Print Service 水二分

点击打开链接 Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1084    Accepted Submission(s): 240 Problem Description Alice is providing print service, while the pricing doesn't

hdu 4791 Alice&#39;s Print Service (DP+离线处理)

Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1163    Accepted Submission(s): 270 Problem Description Alice is providing print service, while the pricing doesn't seem to

zoj 3726 水题+二分

Alice's Print Service Time Limit: 2 Seconds      Memory Limit: 65536 KB Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money. For example, the price when

UVAlive 6611 Alice&#39;s Print Service 二分

Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.For example, the price when printing less than 100 pages is 20 cents per page, but when printing not

HDU 4791 Alice&#39;s Print Service(2013长沙区域赛现场赛A题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4791 解题报告:打印店提供打印纸张服务,需要收取费用,输入格式是s1 p1 s2 p2 s3 p3...表示打印区间s1到s2张纸的单价是p1,打印区间s2 到s3的单价是p2....最后是sn到无穷大的单价是pn,让你求打印k张纸的总费用最少是多少?有m次查询. 因为s1*p1 > s2 * p2 > s3*p3......,很显然,加入k所在的那个区间是第x个区间,那么最低费用要么是k * p