实验名称:配置静态NAT实现内外网通信
实验拓扑:
如图所示,现有一台PC机,想要访问到ISP的服务,该如何操做呢?
实验目的:使内网PC机可以访问到ISP服务
实验步骤:
- 配置内外网设备的IP地址
PC机:
Gw:
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname gw
gw(config)#interface fastEthernet 0/0
gw(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
ip ad
gw(config-if)#ip address 192.168.10.254 255.255.255.0
gw(config-if)#exit
gw(config)#interface fastEthernet 0/1
gw(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
gw(config-if)#ip address 100.1.1.1 255.255.255.0
gw(config-if)#exit
gw(config)#
SLP-1:
Router>EN
Router#CONFigure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router SLP-1 (config)#hostname SLP-1
SLP-1 (config)#interface fastEthernet 0/0
SLP-1 (config-if)#no shutdown
SLP-1 (config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
SLP-1 (config-if)#ip address 100.1.1.2 255.255.255.0
SLP-1 (config-if)#exit
SLP-1 (config)#interface fastEthernet 0/1
SLP-1 (config-if)#no shutdown
SLP-1 (config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
SLP-1 (config-if)#ip address 200.1.1.1 255.255.255.0
SLP-1 (config)#exit
SLP-1#
SLP-2:
Router>EN
Router#CONFigure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router SLP-1 (config)#hostname SLP-2
SLP-2 (config)#interface fastEthernet 0/0
SLP-2 (config-if)#no shutdown
SLP-2 (config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
SLP-2 (config-if)#ip address 200.1.1.2 255.255.255.0
SLP-2 (config-if)#exit
- 配置网关设备上的默认路由
gw(config)#ip route 0.0.0.0 0.0.0.0 100.1.1.2
gw(config)#exit
gw#
%SYS-5-CONFIG_I: Configured from console by console - 配置ISP边的网络(启用IGP-RIP)
SLP-1:
SLP-1(config)#router rip \开启rip
SLP-1(config-router)#version 2\选择rip版本2
SLP-1(config-router)#no auto-summary \关闭自动汇总
SLP-1(config-router)#passive-interface fastEthernet 0/0
SLP-1(config-router)#network 100.1.1.0
SLP-1(config-router)#network 200.1.1.0
SLP-1(config-router)#exit
SLP-1(config)#
SLP-2:
SLP-2(config)#router rip \开启rip
SLP-2(config-router)#version 2\选择rip版本2
SLP-2(config-router)#no auto-summary \关闭自动汇总
SLP-2(config-router)#network 200.1.1.0
SLP-2(config-router)#exit
SLP-2(config)#
- 在网关设备上配置NAT边界
Gw:
gw(config)#interface fastEthernet 0/0
gw(config-if)#ip nat inside \标记此为NAT的内部端口
gw(config-if)#exit
gw(config)#interface fastEthernet 0/1
gw(config-if)#ip nat outside \标记此为NAT的外部端口
gw(config-if)#exit
gw(config)# - 配置NAT转换条目
Gw:
gw(config)#ip nat inside source static 192.168.10.1 100.1.1.1
gw(config)#exit
gw# - 验证、测试、保存
Gw:show ip nat translation:
debug ip nat :
PC-1:
ping 200.1.1.2
Gw:
根据此图可以看出,NAT将一个私有地址转换为公有地址,从而实现了访问的服务。
今天就暂时先简单说这些,关于NAT的其他类型会在后面为大家呈现,请大家多多关注!!!!!
配置静态NAT实现内外网通信
原文地址:http://blog.51cto.com/13557013/2060468