HDU 4751 Divide Groups(二分图的判断)

Problem Description

This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos.

After carefully planning, Tom200 announced his activity plan, one that contains two characters:

1. Whether the effect of the event are good or bad has nothing to do with the number of people join in.

2. The more people joining in one activity know each other, the more interesting the activity will be. Therefore, the best state is that, everyone knows each other.

The event appeals to a great number of alumnus, and Tom200 finds that they may not know each other or may just unilaterally recognize others. To improve the activities effects, Tom200 has to divide all those who signed up into groups to take part in the activity
at different time. As we know, one‘s energy is limited, and Tom200 can hold activity twice. Tom200 already knows the relationship of each two person, but he cannot divide them because the number is too large.

Now Tom200 turns to you for help. Given the information, can you tell if it is possible to complete the dividing mission to make the two activity in best state.

Input

The input contains several test cases, terminated by EOF.

Each case starts with a positive integer n (2<=n<=100), which means the number of people joining in the event.

N lines follow. The i-th line contains some integers which are the id

of students that the i-th student knows, terminated by 0. And the id starts from 1.

Output

If divided successfully, please output "YES" in a line, else output "NO".

Sample Input

3
3 0
1 0
1 2 0

Sample Output

YES

题意:n个人分成两个集合,要每一个图的认识关系都是完全图,是否可以分成

思路:先把不是相互认识的放在一个连接表联系起来,这些人必须不是一个集合的,然后染色法判断

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i < b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 105

vector<int>g[N];
int n,vis[N];
int a[N][N];

bool dfs(int x,int color)
{
     int i;
     vis[x]=color;
     fre(i,0,g[x].size())
	{
        int to=g[x][i];

        if(vis[to]!=-1)
		{
			if(vis[to]==color) return false;  //不认识但是在一个集合
			continue;
		}

        if(!dfs(to,!color))  //不认识就得在不同的集合
		  return false;
	}
   return true;
}

bool solve()
{
	int i,j;
	mem(vis,-1);

	fre(i,1,n+1)
	{
		if(vis[i]==-1&&dfs(i,0)==false)
			return false;
	}
   return true;

}

int main()
{
	int i,j;
	while(~sf(n))
	{
		fre(i,1,n+1)
		  g[i].clear();

		int x;
		mem(a,0);
		fre(i,1,n+1)
		{
			while(sf(x),x)
				{
				  a[i][x]=1;
				}
		}

		fre(i,1,n+1)
		  fre(j,i+1,n+1)
		   if(a[i][j]==0||a[j][i]==0)
		   {
		   	  g[i].push_back(j);
		   	  g[j].push_back(i);
		   }

	   if(solve())
		pf("YES\n");
	   else
		pf("NO\n");
	}
     return 0;
}
时间: 2024-10-14 20:57:58

HDU 4751 Divide Groups(二分图的判断)的相关文章

hdu 4751 Divide Groups 二分图

题意给出所有人之间的关系,单向的,问能不能将这群人分成两组,使得每组内部的任意两人都互相认识. 先把单向边都换成无向边,即如果a,b互相认识那么不变,如果只是单向边的话那么则认为他们两个不认识,然后假设能分成满足题意的两个集合,那么新图的补图中这两个集合内部是没有边的,所以只要判断补图是不是二分图即可. #include <cstdio> #include <cstring> #include <queue> using namespace std; int G[210

HDU 4751 Divide Groups

Divide Groups Time Limit: 1000ms Memory Limit: 32768KB This problem will be judged on HDU. Original ID: 475164-bit integer IO format: %I64d      Java class name: Main   This year is the 60th anniversary of NJUST, and to make the celebration more colo

hdu 4751 Divide Groups 2—sat问题 还是未理解

Divide Groups Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1443    Accepted Submission(s): 512 Problem Description This year is the 60th anniversary of NJUST, and to make the celebration mor

HDU 4751 Divide Groups(判断是否为二分图)

#include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <algorithm> #include <vector> #include <queue> #include <set> #define LL long long #define FOR(i, x, y) for(int i=x;i<=

hdu 4751 Divide Groups(dfs染色 或 2-sat)

Problem Description   This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos.   After carefully planning, Tom200 announced his activity plan

hdu 4751 Divide Groups bfs (2013 ACM/ICPC Asia Regional Nanjing Online 1004)

SDUST的训练赛 当时死磕这个水题3个小时,也无心去搞其他的 按照题意,转换成无向图,预处理去掉单向的边,然后判断剩下的图能否构成两个无向完全图(ps一个完全图也行或是一个完全图+一个孤点) 代码是赛后看的网上大神,所以转载过来了,dfs染色的时候很巧妙,巧妙的用到了就两个无向完全图 #include <cstdio> #include <cstring> #include <cmath> #include <vector> #include <qu

Divide Groups 二分图的判定

Divide Groups Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1835    Accepted Submission(s): 657 Problem Description   This year is the 60th anniversary of NJUST, and to make the celebration mo

hdu4751 二分图的判断

http://acm.hdu.edu.cn/showproblem.php?pid=4751 Problem Description This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos. After carefully p

(0染色判定二分图) hdu 4751

J - Divide Groups Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 4751 Appoint description:  System Crawler  (2015-04-14) Description   This year is the 60th anniversary of NJUST, and to make th