POJ-1986 Distance Queries(LCA、离线)


Distance Queries

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 14378   Accepted: 5062
Case Time Limit: 1000MS

Description

Farmer John‘s cows refused to run in his marathon since he chose a path much too long for their leisurely lifestyle. He therefore wants to find a path of a more reasonable length. The input to this problem consists of the same input as in "Navigation Nightmare",followed by a line containing a single integer K, followed by K "distance queries". Each distance query is a line of input containing two integers, giving the numbers of two farms between which FJ is interested in computing distance (measured in the length of the roads along the path between the two farms). Please answer FJ‘s distance queries as quickly as possible!

Input

* Lines 1..1+M: Same format as "Navigation Nightmare"

* Line 2+M: A single integer, K. 1 <= K <= 10,000

* Lines 3+M..2+M+K: Each line corresponds to a distance query and contains the indices of two farms.

Output

* Lines 1..K: For each distance query, output on a single line an integer giving the appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6
1 4
2 6

Sample Output

13
3
36

Hint

Farms 2 and 6 are 20+3+13=36 apart.

Source

USACO 2004 February

题目大意:第一行告诉你田的数量和田之间的路数量,然后告诉你两块田的距离和方向(可以忽略方向),然后k次询问,两块田间的最短距离。

解题思路:直接套模板,对于lca离线算法的理解学习,参考(http://www.cnblogs.com/JVxie/p/4854719.html),觉得很详细,就通过这个了解了离线,在线的方法至今不懂。。

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;

struct node
{
    int v,c;
};

vector<node>tree[maxn],que[maxn];
int dis[maxn],num[maxn],f[maxn];
bool vis[maxn];

void Init(int n)
{
    for(int i=0;i<=n;i++)
    {
        tree[i].clear();
        que[i].clear();
        f[i] = i;
        dis[i] = 0;
        num[i] = 0;
        vis[i] = 0;
    }
}

int Find(int x)
{
    int r=x;
    while(r!=f[r])
    {
        r = f[r];
    }
    while(x!=f[x])
    {
        int j=f[x];
        f[x] = r;
        x = j;
    }
    return x;
}

void lca(int u)
{
    vis[u] = true;
    f[u] = u;
    for(int i=0;i<que[u].size();i++)
    {
        int v = que[u][i].v;
        if(vis[v])
        {
            num[que[u][i].c]=dis[v]+dis[u]-2*dis[Find(v)];
        }
    }
    for(int i=0;i<tree[u].size();i++)
    {
        int v=tree[u][i].v;
        if(!vis[v])
        {
            dis[v] = dis[u]+tree[u][i].c;
            lca(v);
            f[v] = u;
        }
    }
}

int main()
{
    int x,y,c,n,m,q;
    char s[5];
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        Init(n);
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d %s",&x,&y,&c,s);
            node temp;
            temp.v = y;
            temp.c = c;
            tree[x].push_back(temp);
            temp.v = x;
            tree[y].push_back(temp);
        }
        scanf("%d",&q);
        for(int i=0;i<q;i++)
        {
            scanf("%d %d",&x,&y);
            node temp;
            temp.v = y;
            temp.c = i;
            que[x].push_back(temp);
            temp.v = x;
            que[y].push_back(temp);
        }
        lca(1);
        for(int i=0;i<q;i++)
            printf("%d\n",num[i]);
    }

}
时间: 2024-10-24 20:54:29

POJ-1986 Distance Queries(LCA、离线)的相关文章

POJ 1986 Distance Queries LCA树上两点的距离

题目来源:POJ 1986 Distance Queries 题意:给你一颗树 q次询问 每次询问你两点之间的距离 思路:对于2点 u v dis(u,v) = dis(root,u) + dis(root,v) - 2*dis(roor,LCA(u,v)) 求最近公共祖先和dis数组 #include <cstdio> #include <cstring> #include <vector> using namespace std; const int maxn =

POJ 1986 Distance Queries LCA两点距离树

标题来源:POJ 1986 Distance Queries 意甲冠军:给你一棵树 q第二次查询 每次你问两个点之间的距离 思路:对于2点 u v dis(u,v) = dis(root,u) + dis(root,v) - 2*dis(roor,LCA(u,v)) 求近期公共祖先和dis数组 #include <cstdio> #include <cstring> #include <vector> using namespace std; const int max

poj 1986 Distance Queries LCA

题目链接:http://poj.org/problem?id=1986 Farmer John's cows refused to run in his marathon since he chose a path much too long for their leisurely lifestyle. He therefore wants to find a path of a more reasonable length. The input to this problem consists

POJ - 1986 Distance Queries(离线Tarjan算法)

1.一颗树中,给出a,b,求最近的距离.(我没考虑不联通的情况,即不是一颗树的情况) 2.用最近公共祖先来求, 记下根结点到任意一点的距离dis[],这样ans = dis[u] + dis[v] - 2 * dis[lca(u, v)] 3. /* 离线算法,LCATarjan 复杂度O(n+Q); */ #include<iostream> #include<stdio.h> #include<string.h> using namespace std; const

POJ 1986 Distance Queries 【输入YY &amp;&amp; LCA(Tarjan离线)】

任意门:http://poj.org/problem?id=1986 Distance Queries Time Limit: 2000MS   Memory Limit: 30000K Total Submissions: 16648   Accepted: 5817 Case Time Limit: 1000MS Description Farmer John's cows refused to run in his marathon since he chose a path much t

poj 1986 Distance Queries 带权lca 模版题

Distance Queries Description Farmer John's cows refused to run in his marathon since he chose a path much too long for their leisurely lifestyle. He therefore wants to find a path of a more reasonable length. The input to this problem consists of the

POJ 1986 Distance Queries (在线LCA转RMQ)

题目地址:POJ 1986 纯模板题.输入的最后一个字母是多余的,完全不用管.还有注意询问的时候有相同点的情况. 代码如下: #include <iostream> #include <string.h> #include <math.h> #include <queue> #include <algorithm> #include <stdlib.h> #include <map> #include <set>

POJ 1986 Distance Queries(LCA)

[题目链接] http://poj.org/problem?id=1986 [题目大意] 给出一棵树,问任意两点间距离. [题解] u,v之间距离为dis[u]+dis[v]-2*dis[LCA(u,v)] [代码] #include <cstdio> #include <algorithm> #include <cstring> using namespace std; const int N=300010; int d[N],num[N],dis[N],ed=0,x

POJ 1986 Distance Queries

http://poj.org/problem?id=1986 题意:一棵树里找到两个点的距离.(不用考虑不联通的情况) 题解:LCA模板题. 1 #include <iostream> 2 #include <algorithm> 3 #include <cstring> 4 #include <string> 5 #include <cstdio> 6 #include <cmath> 7 #include <queue>

POJ 1986 DIstance Query LCA水题

给出一棵树,对于每一个询问,给出2个节点,输出2个节点的距离. 输入中有字母,那个是没有用的,不用管. 思路: 0.选择编号为1的节点作为树的root (注意:有些题的边是单向的,这时候我们要根据节点的入度来确定root, 双向的话一般可以随意选择一个节点作为root) 1.dfs1,求出dep和pa[i][0] 2.初始化数组pa 3.节点(u,v)的权值为w 把本来是边的权值w赋给u,v中dep较大的节点, cost[i]表示节点i的权值为cost[i] 先初始化:cost[root]=0