233 Matrix(hdu5015 矩阵)

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1190    Accepted Submission(s): 700

Problem Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a0,1 = 233,a0,2 = 2333,a0,3 = 23333...) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,...,an,0, could you tell me an,m in the 233 matrix?

Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,...,an,0(0 ≤ ai,0 < 231).

Output

For each case, output an,m mod 10000007.

Sample Input

1 1

1

2 2

0 0

3 7

23 47 16

Sample Output

234

2799

72937

Hint

我们这样看:已知a11 ,a21 ,a31 ,a41  。。。求后面的

a12 = a11 +233;

a22 = a11 + a21 +233;

a32 = a11 + a21 +a31 +233;

a42 = a11 + a21 +a31 +a41 +233;

.........

同理:后面的列也一样:

a13 = a12 +233;

a23 = a12 + a22 +233;

a33 = a12 + a22 +a32 +233;

a43 = a12 + a22 +a32 +a42 +233;

...........

ss所以有矩阵:

233 a11 
a21  a31  a41  ... 3

*

10 1 1 1 1 ... 0
0 1 1 1 1 ... 0
0 0 1 1 1 ... 0
0 0 0 1 1 ... 0
0 0 0 0 1 ... 0
... ... ... ... ... ... ...
1 0 0 0 0 ... 1

=

......................................................................................................................................................

z转载请注明出处:寻找&星空の孩子

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5015

#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL __int64
#define mod 10000007

LL N,M;

struct matrix
{
    LL m[15][15];
};
LL a[15];

matrix multiply(matrix x,matrix y)
{
    matrix temp;
    memset(temp.m,0,sizeof(temp.m));
    for(int i=0; i<N+2; i++)
    {
        for(int j=0; j<N+2; j++)
        {
            if(x.m[i][j]==0) continue;
            for(int k=0; k<N+2; k++)
            {
                if(y.m[j][k]==0) continue;
                temp.m[i][k]+=x.m[i][j]*y.m[j][k]%mod;
                temp.m[i][k]%=mod;
            }
        }
    }
    return temp;
}

matrix quickmod(matrix a,LL n)
{
    matrix res;
    memset(res.m,0,sizeof(res.m));
    for(int i=0;i<N+2;i++) res.m[i][i]=1;
    while(n)
    {
        if(n&1)
            res=multiply(res,a);
        n>>=1;
        a=multiply(a,a);
    }
    return res;
}
int main()
{
    int n,k;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        a[0]=233;
        a[N+1]=3;
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&a[i]);
        }

        matrix ans;
        memset(ans.m,0,sizeof(ans.m));
        ans.m[0][0]=10;
        ans.m[N+1][0]=1;
        ans.m[N+1][N+1]=1;
        for(int j=1;j<=N;j++)
        {
            for(int i=0;i<=j;i++)
            {
                ans.m[i][j]=1;
            }
        }

        ans=quickmod(ans,M);//M次幂定位到纵坐标。

        LL ant=0;
        for(int i=0;i<N+2;i++)//横坐标是N,即,乘以矩阵的N列。
        {
            ant=(ant+a[i]*ans.m[i][N])%mod;
        }
        printf("%I64d\n",ant);
    }
    return 0;
}

本来要做新题的,可是遇到不会的了。。。hdu4767 Bell 现在卡在  中国剩余定理,还要好好梳理梳理!

加油!少年!!!

时间: 2024-10-07 06:33:08

233 Matrix(hdu5015 矩阵)的相关文章

ACM学习历程——HDU5015 233 Matrix(矩阵快速幂)(2014陕西网赛)

Description In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 233

hdu 5015 233 Matrix (矩阵高速幂)

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 749    Accepted Submission(s): 453 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may s

hdu 5015 233 Matrix (矩阵快速幂)

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 749    Accepted Submission(s): 453 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may s

hdu 5015 233 Matrix(构造矩阵)

http://acm.hdu.edu.cn/showproblem.php?pid=5015 因为是个二维的递推式,当时没有想到可以这样构造矩阵.从列上看,当前这一列都是由前一列递推得到.根据这一点来构造矩阵.令b[i]代表第i列,是一个(n+2)*1的矩阵,即b[1] = [1,233......],之所以在加了两行,是要从前一个矩阵b[i-1]得到b[i]中的第二个数2333...,再构造一个转换矩阵a,它是一个(n+2)*(n+2)的矩阵,那么a^(m-1) * b就是第m列. /* a矩

233 Matrix 矩阵快速幂

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333...

HDU - 5015 233 Matrix (矩阵构造)

Problem Description In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be

HDOJ 233 Matrix 5015【矩阵快速幂】

233 Matrix Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1355    Accepted Submission(s): 806 Problem Description In our daily life we often use 233 to express our feelings. Actually, we may

HDU 5015 233 Matrix(矩阵快速幂)

Problem Description In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be

Spring-1-I 233 Matrix(HDU 5015)解题报告及测试数据

233 Matrix Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the quest