HDU 1035--Robot Motion--模拟

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6422    Accepted Submission(s): 3015

Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

模拟题,给定一个操作矩阵,N S W E 分别代表向上,下,左,右移动 给定一个机器人,机器人总是从最顶层开始,列坐标题目会给出,你的任务是判断几步之后机器人会走出这个矩阵(有可能永远也走不出,因为可能会形成一个环)我们虚拟一个墙,就是存字符的时候让它从下标1开始,而在矩阵外层套上一层别的字符,与题目中那4个字符不相同就可以,用来判断机器人是否走出矩阵,然后模拟操作就可以了,注意判断是否形成环,可以设一个数组vis[][],初始化为0,代表所有的子符都没访问过,然后访问过就置为1,当判断到一个字符访问过2次时,说明有环,退出来继续操作就可以了(应该不难想)
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cctype>
#include <algorithm>
#include <vector>
using namespace std;
bool vis[110][110];
char map[110][110];
int i,j;
char bfs(char x)
{
	if(x=='N')
		i--;
	else if(x=='S')
	    i++;
	else if(x=='E')
	    j++;
	else if(x=='W')
		j--;
	return map[i][j];
}
int main()
{
    int m,n,start;char next;
	while(cin>>m>>n>>start)
	{
		if(!m&&!n&&!start)break;
		memset(map,'a',sizeof(map));
		memset(vis,0,sizeof(vis));
		for(i=1;i<=m;i++)
			for(j=1;j<=n;j++)
			cin>>map[i][j];
		i=1;j=start;
		int cnt=1;vis[i][j]=1;
		next=map[i][j];
		while((next=bfs(next))!='a')
		{
			if(!vis[i][j])
			{cnt++;vis[i][j]=1;}
			else
			break;

		}
		vis[i][j]=0;int num=1;
		next=map[i][j];
		while((next=bfs(next))!='a')
		{
			if(vis[i][j])
		    num++;
			else
		    break;

		}
		if(num>1)
			cout<<cnt-num<<" step(s) before a loop of "<<num<<" step(s)"<<endl;
		else
			cout<<cnt<<" step(s) to exit"<<endl;
	}
	return 0;
}

HDU 1035--Robot Motion--模拟,布布扣,bubuko.com

时间: 2024-10-11 13:20:56

HDU 1035--Robot Motion--模拟的相关文章

[ACM] hdu 1035 Robot Motion (模拟或DFS)

Robot Motion Problem Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down t

HDU 1035 [Robot Motion] 模拟 记忆

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1035 题目大意:给出一个地图,每个点都指定下一步的方向.问移动情况(何时走出地图或几步后进入多长的循环) 关键思想:模拟+记忆化.我的做法是访问过的点vis置1,往后每走一步,走过的所有点vis++,因为每个点都可能是循环的节点.后面回到一个vis>1的点,vis-1就是循环长度了.(也可以记录到每个点的步数,最后点的步数差值就是循环长度) 代码如下 //模拟 记忆.可优化 #include <i

HDU 1035 Robot Motion Union Find 并查集题解

本题的类型我一看就想到使用并查集解了,因为要查找是否有环,这是并查集的典型用法. 但是由于本题数据实在是太水了,故此有人使用直接模拟都过了.这让本题降了个档次. 这里使用并查集解.而且可以根据需要简化并查集函数,代码还是很好打的. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include &l

杭电 HDU 1035 Robot Motion

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7488    Accepted Submission(s): 3431 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

HDU 1035 Robot Motion

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3466    Accepted Submission(s): 1608 Problem Description A robot has been programmed to follow the instructions in its path. Instruct

HDOJ 题目1035 Robot Motion(模拟)

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7372    Accepted Submission(s): 3389 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

hdoj 1035 Robot Motion

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7974    Accepted Submission(s): 3685 Problem Description A robot has been programmed to follow the instructions in its path. Instruct

HDU ACM 1035 Robot Motion 简单模拟题

分析:一步步的走,走出矩阵则说明没有环,若走到已经走过的地方,说明有环,按格式输出结果,OK. #include<iostream> using namespace std; #define N 15 int dir[4][2]={-1,0,1,0,0,-1,0,1}; char map[N][N]; int vis[N][N]; char ch[]="NSWE"; int n,m; int id(char c) { int i; for(i=0;i<4;i++) i

HDU 1036 Robot Motion 深搜

 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down the page) E east (t

69棋牌游戏源码,POJ 1573 Robot Motion模拟

主题:http://pj.org/Debug ID=1573    主要思想:棋盘上充满了N,E,S,W指令.人们按照棋盘的指示从北方的初始列开始移动,直到你下完棋或四处走动.    N意味着向北(向上)移动.    E意味着向东移动(右).    S意味着向南移动(下).    W意味着向西移动(左).    分析:因为棋盘只有10*10,也就是说最多只有100步,所以您可以使用模拟算法.我们声明一个用于记录指令的字符卡映射,以及一个初始值为零的象棋卡,用于记录所走过的路径.国际象棋棋局或发现