lightoj 1079 Just another Robbery 解题心得

原题:

Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability Pof getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

分析:状态题,01背包,用二维转态表示三个量。

dp[i][j] = min(dp[i-1][j] , dp[i-1][j-v[i]]) ,dp[i][j]表示前 i 个银行抢劫到 j 这么多钱被抓的概率。

代码:

#include<stdio.h>
#define maxn 110
#define min(a,b) (a)>(b)?(b):(a)

double a[maxn];
int v[maxn];
double f[maxn][maxn*maxn];
int main()
{
    int T, cas = 1;
    int n;
    double p;
    int sum;
    scanf("%d", &T);
    while (T--)
    {
        sum = 0;
        scanf("%lf%d", &p, &n);
        for (int i = 1; i <= n; i++)
            scanf("%d%lf", &v[i], &a[i]), sum += v[i];
        for (int i = 1; i <= sum; i++)
            f[0][i] = -1;
        f[0][0] = 0;
        for (int i = 1; i <= n; i++)
            for (int j = 0; j <= sum; j++)
            {
                if (j - v[i]<0 || f[i - 1][j - v[i]]<-0.5)
                    f[i][j] = f[i - 1][j];
                else
                    if(f[i - 1][j]<0)
                        f[i][j] = f[i - 1][j - v[i]] + (1 - f[i - 1][j - v[i]])*a[i];
                    else
                        f[i][j] = min(f[i - 1][j], f[i - 1][j - v[i]] + (1 - f[i - 1][j - v[i]])*a[i]);
            }
        int ans = 0;
        for (int i = 0; i <= sum; i++)
            if (f[n][i]>-0.5 && f[n][i]<p)
                ans = i;
        printf("Case %d: %d\n", cas++, ans);
    }
    return 0;
}
时间: 2024-10-13 07:52:35

lightoj 1079 Just another Robbery 解题心得的相关文章

[LightOJ 1079] Just another Robbery

Just another Robbery As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friend

LightOJ - 1079 Just another Robbery 概率 + dp

题目大意:harry要去抢劫银行,他手上有每个银行布局,所以他很清楚的了解到每个银行有多少钱,和去抢劫该银行被捕的概率 现在他要拟定一个计划,要求在被捕概率低于p的情况下,抢劫到最多的钱 解题思路:银行1个1个的抢过去,抢到的钱随着抢劫银行的数量增加或者不变(不变的情况就是不抢劫该银行),被捕的概率随着银行数量的增加而增大或者不变(不变的情况就是不抢劫该银行) 所以这个题有三个量在改变,一个是银行的数量,一个是抢到的钱,还有一个是被捕的概率 所以用二维dp来表示三个变量,设dp[i][j]表示抢

LightOJ 1079 Just another Robbery (01背包)

题意:给定一个人抢劫每个银行的被抓的概率和该银行的钱数,问你在他在不被抓的情况下,能抢劫的最多数量. 析:01背包,用钱数作背包容量,dp[j] = max(dp[j], dp[j-a[i] * (1.0 - pp[i])),dp[i] 表示不被抓的最大概率,在能抢劫到 i 个钱. 代码如下: #pragma comment(linker, "/STACK:1024000000,1024000000") #include <cstdio> #include <stri

lightoj 1079 Just another Robbery 概率 背包

题目中给的都是被逮捕的概率p,并不方便计算,所以统统通过1-p,变成q,表示安全的概率. 然后这么多银行可以选择,有些类似背包问题.开始下意识认为应该是安全概率算体积,金钱算价值,更符合直观想法.但安全概率不是整数,这样子没法dp. 但是背包有个技巧,有时候体积可能是直观上的价值,我们不妨把金钱作为体积试试. dp[i][j]表示,考虑前i个银行,拿了j的金钱,的最大安全概率. dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - v[i]] * q[i]),我们再

(概率 01背包) Just another Robbery -- LightOJ -- 1079

http://lightoj.com/volume_showproblem.php?problem=1079 Just another Robbery As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated r

第四章学习小结 串的模式匹配 解题心得体会

串的模式匹配 解题心得体会 关于串,模式匹配是其一个很重要的问题.针对这个问题,书上讲了两种模式匹配的算法,即BF算法和KMP算法,下面针对这两种算法的实现谈谈我的心得. 一.BF算法的探索 [错误代码1] #include<iostream> #include<string.h> using namespace std; typedef struct{ char ch[1000002]; int length; }SString; void Index_BF(SString S,

括号配对问题——解题心得

Description You are given a string consisting of parentheses () and []. A string of this type is said to be correct: (a)if it is the empty string (b)if A and B are correct, AB is correct, (c)if A is correct, (A ) and [A ] is correct. Write a program

wechall.net/stegano 解题心得

最近迷上了 www.wechall.net 网站,里面都是些与计算机相关的题目挑战.题目又分很多类型,例如:加密与解密.隐写术.网络攻防.趣味编程.数学逻辑等.题目有的简单,有的很难,需要一些知识和技巧.与其他题目挑战的网站不同的是,在其他类似性质的网站注册的用户可以绑定到 WeChall 网站,然后 WeChall 提供排名信息,而且也分得很细,什么按总分全球排名.什么在自己国家的排名.什么解答某种语言网站题目的排名等.可以从解题的人数判断题目的难易程度,有兴趣的朋友可以去注册,解题中也能学到

Ducci Sequence 解题心得

原题贴上 A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, ... , an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers: ( a1, a2, ... , an)  (| a1 - a2|,| a2