数据结构实验之图论四:迷宫探索
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
有一个地下迷宫,它的通道都是直的,而通道所有交叉点(包括通道的端点)上都有一盏灯和一个开关;请问如何从某个起点开始在迷宫中点亮所有的灯并回到起点?
Input
连续T组数据输入,每组数据第一行给出三个正整数,分别表示地下迷宫的结点数N(1 < N <= 1000)、边数M(M <= 3000)和起始结点编号S,随后M行对应M条边,每行给出一对正整数,表示一条边相关联的两个顶点的编号。
Output
若可以点亮所有结点的灯,则输出从S开始并以S结束的序列,序列中相邻的顶点一定有边,否则只输出部分点亮的灯的结点序列,最后输出0,表示此迷宫不是连通图。
访问顶点时约定以编号小的结点优先的次序访问,点亮所有可以点亮的灯后,以原路返回的方式回到起点。
Sample Input
1
6 8 1
1 2
2 3
3 4
4 5
5 6
6 4
3 6
1 5
Sample Output
1 2 3 4 5 6 5 4 3 2 1
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int s[1050][1050];/*利用邻接矩阵来记录图*/
int n;/*n节点数量*/
int f[1050];/*记录点是否被遍历过*/
int S;/*起点*/
int pre[3050],num;/*记录路径*/
void DFS(int x)
{
int i;
f[x] = 1;
pre[num++] = x;
for(i=1;i<=n;i++)
{
if(!f[i]&&s[x][i])
{
DFS(i);
pre[num++] = x;
}
}
}
int main()
{
int t,m,i,j;
scanf("%d",&t);
while(t--)
{
memset(f,0,sizeof(f));
scanf("%d%d%d",&n,&m,&S);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
s[i][j] = i==j?1:0;
for(i=0;i<m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
s[a][b] = s[b][a] = 1;
}
num = 0;
DFS(S);
printf("%d",pre[0]);
for(i=1;i<num;i++)
printf(" %d",pre[i]);
if(num==2*n-1)
printf("\n");
else
printf(" 0\n");
}
return 0;
}
原文地址:https://www.cnblogs.com/luoxiaoyi/p/10024793.html
时间: 2024-10-08 20:23:17