POJ 2259 Team Queue(STL队列)

转自:https://www.cnblogs.com/yjlblog/p/7056746.html

题目背景

队列和优先级队列是大多数计算机科学家都知道的数据结构。但是团队队列却不被人熟知,尽管在生活中经常出现。比如,午餐时间的食堂门口的队列就是一个团队队列。在一个团队队列中,每个元素属于一个团队。如果一个元素进入一个队列,它首先从头到尾地搜寻这个队列——检查是否它的队友(在同一个团队称之为队友)也在这个队列里。如果有,它就排在它队友的后面(:-D就是插队咯~~)。如果没有,它就排在整个队列的最后,成为新的最后一名(/(ㄒoㄒ)/~真是不幸)。在普通队列中出队是这样的:元素从头到尾的被处理,按他们出现在团队队列里的顺序。你的任务是写一个程序模拟这样一个团队队列。

输入

输入文件会包含一个或多个测试样例。每一个测试样例由代表团队数量的t(1<=t<=1000)开始。然后t只团队描述如下,每一个团队由一个表示元素个数的数字,以及每个元素组成。元素属于整型,并且范围在0到999999(一百万减一)之间。一个团队可能有多达1000个元素。最后,指令列表如下。有三种不同的指令:ENQUEUE x——x进入团队队列。DEQUEUE x——处理第一个元素并将其移除STOP——结束一个测试样例。当t是0时,输入终止。警告:一个测试样例可能多达200000(/(ㄒoㄒ)/~~二十万)条指令,所以团队队列的实现应该是有效率的:入队和出队都应该花费常数时间。

输出

对应每个测试样例,首先输出一行“Scenario #k”,其中k表示第几次测试。然后,每一个“DEQUEUE”指令打印包含出队的元素(单独占一行)。打印一空行在每一个测试样例之后,即使是最后一个测试样例。

例如:

Sample Input

2

3 101 102 103

3 201 202 203

ENQUEUE 101

ENQUEUE 201

ENQUEUE

102

ENQUEUE 202

ENQUEUE 103

ENQUEUE

203

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

2

5

259001 259002 259003 259004 259005

6 260001 260002 260003 260004 260005

260006

ENQUEUE 259001

ENQUEUE 260001

ENQUEUE 259002

ENQUEUE

259003

ENQUEUE 259004

ENQUEUE 259005

DEQUEUE

DEQUEUE

ENQUEUE

260002

ENQUEUE

260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

0

Sample Output

Scenario

#1

101

102

103

201

202

203

Scenario

#2

259001

259002

259003

259004

259005

260001

分析

题目明确告诉了我们使用队列。使用一个队列排列团队;再使用一个队列排列元素。题目中说了出队入队只能花费常数时间,所以要在元素和团队之间建立映射关系而不能简单地使用数组存下元素。

代码

#include<cstdio>
#include<queue>
#include<map>
using namespace std;
const int maxt = 1000 + 10;
int main()
{
    int t, kase = 0;
    while(scanf("%d", &t) == 1 && t) {
        printf("Scenario #%d\n", ++kase);  

        map<int , int> team;//映射作用是编号x对应它的队伍i
        for(int i = 0; i < t; i++) {
            int n,x;
            scanf("%d", &n);
            while(n--) { scanf("%d", &x); team[x] = i;}
        }  

        queue<int> q, q2[maxt];
        //两个队列是本题的核心
        //q存放的是队伍,q2存放的是按增序排列的所有的队伍以及队伍下的编号
        //即q存放团队整体队列,例{3,1,2}
        //q2存放团队队列,例{103,101,102},{201},{301,303}
        for(;;) {
        int x;
        char cmd[10];
        scanf("%s", cmd);
        if(cmd[0] == ‘S‘) break;//遇到STOP停止
        else if(cmd[0] == ‘D‘){
            int t = q.front();//用变量t表示团队整体队列的队首
            printf("%d\n",q2[t].front()); q2[t].pop();//输出这个队首队伍的第一个人,然后把该人出队
            if(q2[t].empty()) q.pop();//如果该队伍在整个队列中只有一个人,则q的队首出队,即该队伍出队
        }else if(cmd[0] == ‘E‘){
            scanf("%d", &x);
            int t = team[x];//通过map找出x的队列序号
            if(q2[t].empty()) q.push(t);//如果该队还没有人排在队中,则该队列插入队尾
            q2[t].push(x);//把该队伍的人插入到q2的该队中
            }
        }
        printf("\n");
    }
    return 0;
}

原文地址:https://www.cnblogs.com/Fy1999/p/9351510.html

时间: 2024-10-12 11:12:34

POJ 2259 Team Queue(STL队列)的相关文章

POJ 2259 Team Queue 数据结构 队列

Team Queue Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 3282   Accepted: 1188 Description Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, thoug

queue POJ 2259 Team Queue

题目传送门 题意:先给出一些小组成员,然后开始排队.若前面的人中有相同小组的人的话,直接插队排在同小组的最后一个,否则只能排在最后面.现在有排队和出队的操作. 分析:这题关键是将队列按照组数分组,用另外一个队列保存组的序号,当该组里没有人了才换下一组.很好的一道题. 收获:队列的灵活运用 代码: /************************************************ * Author :Running_Time * Created Time :2015/9/9 星期三

poj 3125 Printer Queue (队列)

 Printer Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3679   Accepted: 1975 Description The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs i

ACM学习历程——UVA540 Team Queue(队列,map:Hash)

Description Team Queue   Team Queue  Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front

Team Queue(STL练习题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1387 Team Queue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1518    Accepted Submission(s): 511 Problem Description Queues and Priority Queues

POJ 3481 Double Queue(STL)

题意  模拟银行的排队系统  有三种操作  1-加入优先级为p 编号为k的人到队列  2-服务当前优先级最大的   3-服务当前优先级最小的  0-退出系统 能够用stl中的map   由于map本身就依据key的值排了序   相应2.3  我们仅仅须要输出最大或最小即可了并从map中删除该键值 #include<cstdio> #include<map> using namespace std; map<int, int> a; int main() { map<

poj 3481 Double Queue STL中map的运用

题意: 维护一个集合,操作有1:加入一个元素,2:删除最大元素,3:删除最小元素. 分析: map本质是个容器,且具有第一个关键字有序的性质,所以用它来水水就好啦~ 代码: //poj 3481 //sep9 #include <iostream> #include <map> using namespace std; map<int,int> mymap; map<int,int>::iterator iter; int main() { int x,su

POJ 3125 Printer Queue 数据结构 队列

Printer Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4329   Accepted: 2269 Description The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in t

Team Queue POJ - 2259 (队列)

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for exa