Hdu Information Disturbing

Hdu Information Disturbing

Description

  • In the battlefield , an effective way to defeat enemies is to break their
    communication system.
    The information department told you that there are n
    enemy soldiers and their network which have n-1 communication routes can cover
    all of their soldiers. Information can exchange between any two soldiers by the
    communication routes. The number 1 soldier is the total commander and other
    soldiers who have only one neighbour is the frontline soldier.
    Your boss zzn
    ordered you to cut off some routes to make any frontline soldiers in the network
    cannot reflect the information they collect from the battlefield to the total
    commander( number 1 soldier).
    There is a kind of device who can choose some
    routes to cut off . But the cost (w) of any route you choose to cut off can’t be
    more than the device’s upper limit power. And the sum of the cost can’t be more
    than the device’s life m.
    Now please minimize the upper limit power of your
    device to finish your task.

Input

  • The input consists of several test cases.
    The first line of each test case
    contains 2 integers: n(n<=1000)m(m<=1000000).
    Each of the following N-1
    lines is of the form:
    ai bi wi
    It means there’s one route from ai to
    bi(undirected) and it takes wi cost to cut off the route with the
    device.
    (1<=ai,bi<=n,1<=wi<=1000)
    The input ends with n=m=0.

Output

  • Each case should output one integer, the minimal possible upper limit power of
    your device to finish your task.
    If there is no way to finish the task,
    output -1.

Sample Input

5 5
1 3 2
1 4 3
3 5 5
4 2 6
0 0

Sample Output

3

题解:

  • 首先二分上限。每次得到一个总价钱sum。如果sum<=m,下调上限。否则上调上限
  • check函数里是一个树形dp。
  • 设dp(i)表示以i为根节点时,其通讯爆炸时的最小花费。
  • 那么对于一个点,它与叶子的通讯不是它儿子断掉了,就是它自己手动断掉了。
  • 所以转移:dp(i) = \(\sum{min(dp(son), e[i].dis)}\)
//顶尖了:inf太大会WA!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define maxn 1005
#define inf 1100000
using namespace std;

struct E {int next, to, dis;} e[maxn * 2];
int n, m, num;
int h[maxn], dp[maxn];

int read()
{
    int x = 0, f = 1; char c = getchar();
    while(c < '0' || c > '9') {if(c == '-') f = -1; c = getchar();}
    while(c >= '0' && c <= '9') {x = x * 10 + c - '0'; c = getchar();}
    return x *= f;
}

void add(int u, int v, int w)
{
    e[++num].next = h[u];
    e[num].to = v;
    e[num].dis = w;
    h[u] = num;
}

void dfs(int x, int fat, int val)
{
    for(int i = h[x]; i != 0; i = e[i].next)
        if(e[i].to != fat)
            dfs(e[i].to, x, val);
    for(int i = h[x]; i != 0; i = e[i].next)
        if(e[i].dis > val) dp[x] += dp[e[i].to];
        else dp[x] += min(dp[e[i].to], e[i].dis);
} 

int check(int val)
{
    memset(dp, 0, sizeof(dp));
    for(int i = 1; i <= n; i++)
        if(!e[h[i]].next && i != 1) dp[i] = inf;
    dfs(1, 0, val);
    return dp[1] <= m;
}

int main()
{
    while(scanf("%d%d", &n, &m) == 2)
    {
        if(!n && !m) break;
        num = 0;
        memset(h, 0, sizeof(h));
        for(int i = 1; i < n; i++)
        {
            int u = read(), v = read(), w = read();
            add(u, v, w), add(v, u, w);
        }
        int l = 0, r = 0x3f3f3f3f, ans = -1;
        while(l <= r)
        {
            int mid = (l + r) >> 1;
            if(check(mid)) r = mid - 1, ans = mid;
            else l = mid + 1;
        }
        printf("%d\n", ans);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/BigYellowDog/p/11217099.html

时间: 2024-10-11 12:54:40

Hdu Information Disturbing的相关文章

HDU 3586.Information Disturbing 树形dp

Information Disturbing Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 3205    Accepted Submission(s): 1137 Problem Description In the battlefield , an effective way to defeat enemies is to bre

HDU 3586 Information Disturbing 树形DP+二分

Information Disturbing Problem Description In the battlefield , an effective way to defeat enemies is to break their communication system.The information department told you that there are n enemy soldiers and their network which have n-1 communicati

hdu 3586 Information Disturbing (树形dp)

Information Disturbing Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others) Total Submission(s): 1722    Accepted Submission(s): 641 Problem Description In the battlefield , an effective way to defeat enemies is to bre

BNUOJ 7697 Information Disturbing

Information Disturbing Time Limit: 3000ms Memory Limit: 65536KB This problem will be judged on HDU. Original ID: 358664-bit integer IO format: %I64d      Java class name: Main In the battlefield , an effective way to defeat enemies is to break their

HDU 3586 Information Disturbing (二分+树形dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3586 给定n个敌方据点,1为司令部,其他点各有一条边相连构成一棵树,每条边都有一个权值cost表示破坏这条边的费用,叶子节点为前线.现要切断前线和司令部的联系,每次切断边的费用不能超过上限limit,问切断所有前线与司令部联系所花费的总费用少于m时的最小limit.1<=n<=1000,1<=m<=10^6 dp[i]表示i节点为root的这个子树所破坏的最少费用,if(cost[i]

HDU 3586 Information Disturbing(二分+树形dp)

http://acm.split.hdu.edu.cn/showproblem.php?pid=3586 题意: 给定一个带权无向树,要切断所有叶子节点和1号节点(总根)的联系,每次切断边的费用不能超过上限limit,问在保证总费用<=m下的最小的limit. 思路: 对于上限limit我们可以二分查找.然后就是树形dp,看代码就可以理解的. 1 #include<iostream> 2 #include<algorithm> 3 #include<cstring>

HDU 3586 Information Disturbing

二分+树形DP验证. 答案是通过二分查找得到的,对于每一次二分到的值,进行验证,是否可行. 可以用树形DP来求解所有叶子节点不能向根节点传送消息的最小费用,dp[i] 表示 节点i 的子树的叶子结点都不能向i传送消息的最小费用,这样很容易递推. #include<cstdio> #include<cstring> #include<cmath> #include<ctime> #include<map> #include<vector>

HDU 3586 Information Disturbing (树形DP,二分)

题意: 给定一个敌人的通信系统,是一棵树形,每个节点是一个敌人士兵,根节点是commander,叶子是前线,我们的目的是使得敌人的前线无法将消息传到commander,需要切断一些边,切断每条边需要一定的power,而我们有一台具有m点power的机器,问在使用此机器切断敌人通信系统的情况下,使得所切断边的最大边权达到最小是多少?(m<=100w,n<=1000) 思路: 其实就是要求所切断的边的最小瓶颈边.由于m比较大,不好枚举或者DP.但是他们具有线性的关系,就是瓶颈边越大,肯定越容易有解

Information Disturbing hdu-3586

Problem Description In the battlefield , an effective way to defeat enemies is to break their communication system.The information department told you that there are n enemy soldiers and their network which have n-1 communication routes can cover all