poj 3744 Scout YYF I(矩阵优化概率DP)

Scout YYF I

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5153   Accepted: 1404

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy‘s base. After overcoming a series difficulties, YYF is now at the start of enemy‘s famous "mine road". This is a very long road, on which there are numbers of mines.
At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1-p. Here is the task, given the place of each mine, please calculate the probality that YYF can
go through the "mine road" safely.

Input

The input contains many test cases ended with EOF.

Each test case contains two lines.

The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.

The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000

给n个有地雷的位置,给出走1步的概率和2步的概率,求能顺利通过这条路的概率。

首先对这n个点相邻两点排序分段[1,a[0]],[a[0]+1,a[1]] .......,假设k点有地雷,那么这个人肯定走k+1点,那么把n个点分成n段,每段起点的概率都相同,最后把每段不走地雷点的概率相乘就是结果。

由于区间长度特别大,不能O(n)递推,要用矩阵快速幂优化,很容易推出递推公式f(n)=f(n-1)*p+f(n-2)*(1-p),n点只能从n-1点和n-2点到。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct matrix
{
    double ma[4][4];
};
matrix multi(matrix x,matrix y)
{
    matrix ans;
    memset(ans.ma,0,sizeof(ans.ma));
    for(int i=1; i<=2; i++)
    {
        for(int j=1; j<=2; j++)
        {
            if(x.ma[i][j])
            {
                for(int k=1; k<=2; k++)
                    ans.ma[i][k]=ans.ma[i][k]+x.ma[i][j]*y.ma[j][k];
            }
        }
    }
    return ans;
}
matrix pow(matrix a,int m)
{
    matrix ans;
    for(int i=1; i<=2; i++)
    {
        for(int j=1; j<=2; j++)
        {
            if(i==j)
                ans.ma[i][j]=1;
            else
                ans.ma[i][j]=0;
        }
    }
    while(m)
    {
        if(m&1)
            ans=multi(ans,a);
        a=multi(a,a);
        m=m>>1;
    }
    return ans;
}
int main()
{
    int a[15];
    int n;
    double p;
    while(~scanf("%d%lf",&n,&p))
    {
        double ans=1;
        matrix b,d;
        matrix c;
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        b.ma[1][1]=p;
        b.ma[1][2]=1-p;
        b.ma[2][1]=1;
        b.ma[2][2]=0;
        memset(c.ma,0,sizeof(c.ma));
        c.ma[1][1]=p;
        c.ma[2][1]=1;
        if(a[0]==1||a[0]==2)
        {
            if(a[0]==1)
                ans=0;
            else
                ans=ans*(1-p);
        }
        else
        {
            d=pow(b,a[0]-2);
            d=multi(d,c);
            ans=ans*(1-d.ma[1][1]);
        }
        for(int i=1; i<n; i++)
        {
            int temp=a[i]-a[i-1];
            if(temp==1||temp==2)
            {
                if(temp==1)
                    ans=0;
                else
                    ans=ans*(1-p);
            }
            else
            {
                d=pow(b,temp-2);
                d=multi(d,c);
                ans=ans*(1-d.ma[1][1]);
            }
        }
        printf("%.7f\n",ans);
    }
    return 0;
}
时间: 2024-11-16 21:33:17

poj 3744 Scout YYF I(矩阵优化概率DP)的相关文章

POJ 3744 Scout YYF I(矩阵优化的概率DP)

解题思路: dp[i] = p * dp[i-1] + (1 - p) * dp[i-2]; 由于N比较大,dp[i]需要用矩阵快速幂求解. 安全通过整段路的概率等于安全通过每一个两个炸弹区间的概率乘积. #include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <algorithm> #include <vector> #

POJ 3744 Scout YYF I 矩阵快速幂

Scout YYF I Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4452   Accepted: 1159 Description YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties,

POJ 3744 Scout YYF I 矩阵快速幂优化--概率dp

点击打开链接 Scout YYF I Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5416   Accepted: 1491 Description YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series diffic

poj 3744 Scout YYF I (矩阵)

Description YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which

poj 3744 Scout YYF I(概率dp,矩阵优化)

Scout YYF I Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5020   Accepted: 1355 Description YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties,

POJ 3744 Scout YYF I(矩阵快速幂 概率dp)

题目链接:http://poj.org/problem?id=3744 Description YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road"

poj 3744 Scout YYF I 概率dp+矩阵乘法

分析: dis(k,v1,v2)函数求到当前位置概率为v1,到当前位置之前一步的概率为v2,前进k步到达位置的概率,然后矩阵加速. 代码: //poj 3744 //sep9 #include <iostream> #include <algorithm> using namespace std; int pos[12]; double p,mat[4][4]; double ans[4][4]; void mul1() { double c[4][4]; c[0][1]=c[1]

POJ 3744 Scout YYF I (概率DP+矩阵快速幂)

题意:小明要从1走过一段直线雷区,给定n个地雷的坐标,他走一步的概率是p,两步的概率为1-p,问你他能安全通过雷区的概率. 析:很明显这是一个概率DP,用d(i)表示到达 i 时他安全的概率,那么d[i] = p * d[i-1] + (1-p) * d[i-2];这个状态转移方程很好理解, 就是说要想到达 i 要么从第 i-1 走一步,要么从 i-2 走两步,最后加起来,然后问题来了,这个数可能达到 1E8,那么时间空间复杂度都受不了, 观察这个状态转移方程,是不是很像Fibnacci数列,所

【概率DP】POJ 3744 Scout YYF I

通道 题意:每次走一步的概率是p,走两步的概率是1-p,然后有n个点上有地雷.问YYF走过雷区的概率是多少 思路: dp[i]=p*dp[i-1]+(1-p)dp[i-2] 转移矩阵:   ans[i]    | p ,1-p   |    ans[i-1]            =|             | * ans[i-1]   | 1 , 0     |   ans[i-2] 代码: