hdoj 2795 Billboard 【线段树 单点更新 + 维护区间最大值】

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15719    Accepted Submission(s): 6629

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that‘s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can‘t
be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

题意:有一个高h宽w的公告栏,现在要在上边贴N个1*W的公告。要求1,要在能够完全放下的区域贴公告。2,贴公告时遵循最上最左的原则。问你每张公告分别贴在第几行,若公告无法插入输出-1。

思路:以min(h, N)为区间右边界建立线段树,初始化每个区间最大值Max为w。

之后每次贴公告就是——找一个Max值最大的区间插入 + 维护区间最大值。若Max[1] < W说明不能插入。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 200000+10
using namespace std;
int Max[MAXN<<2];
void PushUp(int o)
{
    Max[o] = max(Max[o<<1], Max[o<<1|1]);
}
void build(int o, int l, int r, int val)
{
    Max[o] = val;
    if(l == r)
        return ;
    int mid = (l+r) >> 1;
    build(o<<1, l, mid, val);
    build(o<<1|1, mid+1, r, val);
    PushUp(o);
}
int query(int o, int l, int r, int v)
{
    if(l == r)
    {
        Max[o] -= v;
        return l;
    }
    int mid = (l + r) >> 1;
    int ans;
    if(Max[o<<1] >= v)//左子树
        ans = query(o<<1, l, mid, v);
    else//右子树
        ans = query(o<<1|1, mid+1, r, v);
    PushUp(o);//维护区间最值  不能少!
    return ans;
}
int main()
{
    int h, w, N;
    while(scanf("%d%d%d", &h, &w, &N) != EOF)
    {
        h = min(N, h);//逗比了 用N来更新 结果样例都过不了
        build(1, 1, h, w);
        int W;
        while(N--)
        {
            scanf("%d", &W);
            if(Max[1] < W)
                printf("-1\n");
            else
                printf("%d\n", query(1, 1, h, W));
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-13 06:57:47

hdoj 2795 Billboard 【线段树 单点更新 + 维护区间最大值】的相关文章

HDU 2795 Billboard (线段树单点更新 &amp;&amp; 求区间最值位置)

题意 : 有一块 h * w 的公告板,现在往上面贴 n 张长恒为 1 宽为 wi 的公告,每次贴的地方都是尽量靠左靠上,问你每一张公告将被贴在1~h的哪一行?按照输入顺序给出. 分析 : 这道题说明了每一次贴都尽量选择靠上靠左的位置,那既然这样,我们以1~h建立线段树,给每一个叶子节点赋值初值 w 表示当前行最大能够容纳宽度为 w 的公告纸,那么对于某一输入 wi 只要在线段树的尽量靠左的区间找出能够容纳这张公告的位置(即叶子节点)然后减去 wi 即可,需要对query()函数进行一点改造,将

HDU 2795 Billboard(线段树,单点更新)

D - Billboard Crawling in process... Crawling failed Time Limit:8000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 2795 Appoint description: bupt_admin_13 (2015-07-28) System Crawler (2015-08-18) Description

HDU 2795 &lt;Billboard&gt; &lt;线段树单点更新&gt;

Description At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in th

HDU 2795 Billboard (线段树 单点更新 区间求最大值)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=2795 题意:有一块h*w 的广告版,有n块1*w[i]的广告,就着放广告尽量在顶上,尽量先放左边的原则,问在第几行能把广告放下,如果放不下,就打印-1: 思路:我们可以根据每一行建树,每一个子叶表示每一行的容量,而节点存放子节点的最大值,然后从最顶到底,快速查找能存放下广告的一行. 总之还是简单的线段树问题,难点在于抽象模型. #include <iostream> #include <cs

线段树 单点更新查询 区间最大值 hdu 2795 Billboard

题意: 有一块h*w(1<=h,w<=10^9)的公告牌,需要在上面放n(n<=200000)个1*w[i]的公告,每个公告优先选可以放置的地方中最上的那行,同一行选最左的地方,依次输出每个公告放置在哪行,如果不能放置,输出-1. 可以把公告牌看作长为h的线段,构建一个线段树,每个节点存储区间的最大值,初始最大值为公告牌的宽度w.如果某区间的最大值大于当前公告的宽度,就可以放在该区间,由于公告优先放在上面,所以选区间的时候也应该先判断左边的区间可不可以,当在某个点放上公告后,该点的最大值

hdu 1754 线段树 单点更新 动态区间最大值

I Hate It Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 52417    Accepted Submission(s): 20598 Problem Description 很多学校流行一种比较的习惯.老师们很喜欢询问,从某某到某某当中,分数最高的是多少. 这让很多学生很反感.不管你喜不喜欢,现在需要你做的是,就是按照老师的

hdu 1754 I Hate It 线段树单点更新和区间求和

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1754 参照HH大牛写的额! Problem Description 很多学校流行一种比较的习惯.老师们很喜欢询问,从某某到某某当中,分数最高的是多少. 这让很多学生很反感. 不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问.当然,老师有时候需要更新某位同学的成绩. Input 本题目包含多

HDU - 3074 - Multiply game (线段树-单点更新,区间求积)

题目传送:Multiply game 思路:简单线段树,单点更新,区间求积,这是上次选拔赛选的题,一看题就是线段树,不过当时线段树不太熟,没敢敲,现在看来居然如此轻松,不过注意这里有大量输出,用printf,居然在这里TLE了一次... AC代码: #include <cstdio> #include <cstring> #include <iostream> #include <algorithm> #include <cmath> #incl

线段树单点更新,区间求和、求最值 模板(区间更新的模板待续)

单点更新分为两种,①把某个值改成另一个值   ②把某个值加上一个值  具体视情况而定,,代码里有说明. #include <cstdio> #include <cstdlib> #include <algorithm> using namespace std; const int maxn = 2e5; //点的个数 struct Point_Segtree //单点更新,区间求和,求最值 { int seg[maxn<<2],sum[maxn<<