poj2983--Is the Information Reliable?(差分约束)

Is the Information Reliable?

Time Limit: 3000MS   Memory Limit: 131072K
Total Submissions: 11125   Accepted: 3492

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with
N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task
is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station
A
is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station
B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers
N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next
M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange
N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliabl

给出了 P a  b  w 表示 b在a以北w公里, V a  b 表示 b在a北边,最少1公里,问所有 的条件可不可以全部满足。

由P 可以得到 b - a = w 也就是b - a <= w  &&  a - b <= w ,由 V a  b 得到 b - a >= 1 也就是 a - b <= -1 ;建图,使用最短路,判断是否会有负环。初始dis要全部为0.

#include <cstdio>
#include <cstring>
#include <algorithm>
struct node
{
    int u , v , w ;
} p[300000];
int dis[2000] , cnt ;
void add(int u,int v,int w)
{
    p[cnt].u = u ;
    p[cnt].v = v ;
    p[cnt++].w = w ;
}
int main()
{
    int i , j , n , m , u , v , w ;
    char str[10] ;
    while(scanf("%d %d", &n, &m)!=EOF)
    {
        cnt = 0 ;
        while(m--)
        {
            scanf("%s", str);
            if(str[0] == 'P')
            {
                scanf("%d %d %d", &u, &v, &w);
                add(u,v,-w);
                add(v,u,w);
            }
            else
            {
                scanf("%d %d", &u, &v);
                add(u,v,-1);
            }
        }
        memset(dis,0,sizeof(dis));
        for(i = 1 ; i <= n ; i++)
            for(j = 0 ; j < cnt ; j++)
                if( dis[ p[j].v ] >dis[ p[j].u ] + p[j].w )
                    dis[ p[j].v ] = dis[ p[j].u ] + p[j].w ;
        for(j = 0 ; j < cnt ; j++)
            if( dis[ p[j].v ] > dis[ p[j].u ] + p[j].w )
                break;
        if(j < cnt)
            printf("Unreliable\n");
        else
            printf("Reliable\n");
    }
}
时间: 2024-08-09 09:48:59

poj2983--Is the Information Reliable?(差分约束)的相关文章

POJ 2983 Is the Information Reliable? 差分约束

裸差分约束. //#pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cstdlib> #include<algorithm> #include<iostream> #include<sstream> #include<cmath> #include<

【POJ2983】Is the Information Reliable? ——差分约束

题目大意:一天南北线上有n个防御站,给出他们之间的位置关系,问有没有可能存在这样一种位置布置符合所给的位置关系.关系有两种,一种是 P A B X,表示A在B北边X光年的位置,V A B表示A在B北边至少1光年位置. 分析:仍然考虑差分约束,容易想到,若关系为P,则 s[a]-a[b]=c; 变换一下则变成: s[b]-s[a]<=-c; s[a]-a[b]<=c; 若关系为V,则 s[b]-s[a]<=-1; 这样转换之后就变成了求最短路了,注意这道题可能无解,无解即表现为存在负环,判

【poj 2983】Is the Information Reliable? 差分约束

题目:http://poj.org/problem?id=2983 Is the Information Reliable? Time Limit: 3000MS Memory Limit: 131072K Total Submissions: 12535 Accepted: 3943 Description The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Dr

POJ训练计划2983_Is the Information Reliable?(差分约束)

解题报告 思路: 求解: p:a-b=x v:a-b>=1 的方程 #include <iostream> #include <cstring> #include <cstdio> #include <queue> #define inf 0x3f3f3f3f using namespace std; struct node { int v,w,next; } edge[220000]; int head[1111],dis[1111],vis[111

POJ 2983-Is the Information Reliable?(差分约束系统)

题目地址:POJ 2983 题意:有N个车站.给出一些点的精确信息和模糊信息.精确信息给出两点的位置和距离.模糊信息给出两点的位置.但距离大于等于一.试确定是否全部的信息满足条件. 思路:事实上就是让你推断是否存在负环.好久才看明确.对于精确消息.能够得出两个差分公式:dis[v] <= dist[u] - w  &&  dist[u] <= dist[v] + w.对于模糊信息.能够得出dis[v] <= dis[u] -1. PS:做差分约束感觉还是Bellman_f

【转载】夜深人静写算法(四)——差分约束

[转载]夜深人静写算法(四) - 差分约束  目录     一.引例       1.一类不等式组的解   二.最短路       1.Dijkstra       2.图的存储       3.链式前向星       4.Dijkstra + 优先队列       5.Bellman-Ford       6.SPFA       7.Floyd-Warshall   三.差分约束        1.数形结合        2.三角不等式        3.解的存在性        4.最大值

POJ 2983 Is the Information Reliable?

/* *POJ 2983 Is the Information Reliable? *差分约束系统 *(1)对于确定信息 P A B X, 有 A - B >= X && A - B <= X 即 B <= A + (-X) && A <= B + X * 即构成边<A, B, -X> 和 <B, A, X> *(2)对于不确定信息 V A B, 有 A - B >= 1, 即 B <= A + (-1) * 即构

POJ 2983:Is the Information Reliable?(差分约束)

题目大意:有n个点在一条直线上,有两类关系:P(x,y,v)表示x在y北边v距离处,V(x,y)表示x在y北边至少1距离出,给出一些这样的关系,判断是否有矛盾. 分析: 差分约束模板题,约束条件P:a-b>=v a-b<=v即a-b>=v b-a<=-v,V:a-b>=1即b-a<=-1,构图spfa判负权回路即可. 需要注意 的是存图时不能用一个二维数组存边权,因为两点间会有多条边.. spfa判断负权回路的方法,记录每个点进队次数,超过点的数目即存在负权回路. 代码

Is the Information Reliable?(差分约束)

Is the Information Reliable?Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u Submit Status Description The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out

POJ 2983 Is the Information Reliable? 信息可靠吗 (差分约束,spfa)

题意:有n个站排成一列,针对每个站的位置与距离关系,现有多个约束条件,约束条件分两种:(1)确定的.明确说明站a距离站b多少个单位距离.(2)不确定的.只知道a在b的左边至少1个单位距离.  根据已知条件,问有没有冲突?不冲突则输出reliable. 思路: 第2种条件比较好确定,如果知道如何用最短路解差分约束的话. 问题在第1种,明确地说明了距离,怎么办?拆成两条式子,比如 dis(a,b)=c,那么可以写成 b-a>=c ,b-a<=c 这样,只要满足这两个条件,原来明确说明的距离也会成立