二分lower_bound()与upper_bound()的运用

<span style="color:#6633ff;">/*
G - 二分
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit

Status
Description
Given n points (1 dimensional) and q segments, you have to find the number of points that lie in each of the segments. A point pi will lie in a segment A B if A ≤ pi ≤ B.

For example if the points are 1, 4, 6, 8, 10. And the segment is 0 to 5. Then there are 2 points that lie in the segment.

Input
Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers n (1 ≤ n ≤ 105) and q (1 ≤ q ≤ 50000). The next line contains n space separated integers denoting the points in ascending order. All the integers are distinct and each of them range in [0, 108].

Each of the next q lines contains two integers Ak Bk (0 ≤ Ak ≤ Bk ≤ 108) denoting a segment.

Output
For each case, print the case number in a single line. Then for each segment, print the number of points that lie in that segment.

Sample Input
1

5 3

1 4 6 8 10

0 5

6 10

7 100000

Sample Output
Case 1:

2

3

2

Hint
Dataset is huge, use faster I/O methods.
By Grant Yuan
2014.7.16
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
int t;
long long low,high,mid,ans;
int n,m;
int a[100005];
long long x,y;
int ct=1;
int main()
{int l,r;
    scanf("%d",&t);
    while(t--){
    scanf("%d%d",&n,&m);

    for(int i=0;i<n;i++)
      {
      scanf("%d",&a[i]);
        }
         printf("Case %d:\n",ct++);
    while(m--){
         scanf("%d%d",&x,&y);
         if(x<a[0]) l=0;
         else {l=lower_bound(a,a+n,x)-a;
         }
         if(y>a[n-1]) r=n;
         else {r=upper_bound(a,a+n,y)-a;
         }
         printf("%d\n",r-l);}}
         return 0;
}
</span>

二分lower_bound()与upper_bound()的运用,布布扣,bubuko.com

时间: 2024-10-08 10:28:24

二分lower_bound()与upper_bound()的运用的相关文章

二分检索函数lower_bound()和upper_bound()

二分检索函数lower_bound()和upper_bound() 一.说明 头文件:<algorithm> 二分检索函数lower_bound()和upper_bound() lower_bound():找到大于等于某值的第一次出现upper_bound():找到大于某值的第一次出现必须从小到大排序后才能用 内部查找方式为二分查找,二分查找必定需要排序 返回值为地址 二.代码及结果 1 /* 2 二分检索函数lower_bound()和upper_bound() 3 lower_bound(

C++STL中lower_bound() 和 upper_bound()二分查找

lower_bound( )和upper_bound( )都是利用二分查找的方法在一个排好序的数组中进行查找的. 通常用sort函数从小到大排序. 在从小到大的排序数组中, lower_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,找到返回该数字的地址,不存在则返回end.通过返回的地址减去起始地址begin,得到找到数字在数组中的下标. upper_bound( begin,end,num):从数组的begin位置到en

hdu 5178(二分-lower_bound,upper_bound)

pairs Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2037    Accepted Submission(s): 732 Problem Description John has n points on the X axis, and their coordinates are (x[i],0),(i=0,1,2,…,n−1).

[STL] lower_bound和upper_bound

STL中的每个算法都非常精妙, ForwardIter lower_bound(ForwardIter first, ForwardIter last,const _Tp& val)算法返回一个非递减序列[first, last)中的第一个大于等于值val的位置. ForwardIter upper_bound(ForwardIter first, ForwardIter last, const _Tp& val)算法返回一个非递减序列[first, last)中第一个大于val的位置.

[转] STL源码学习----lower_bound和upper_bound算法

http://www.cnblogs.com/cobbliu/archive/2012/05/21/2512249.html PS: lower_bound of value 就是最后一个 < value 或者第一个 = value的位置 upper_bound of value 就是第一个 > value的位置 lower_bound的意思是一段相等的序列的头(闭)和尾(开)的位置 STL中关于二分查找的函数有三个lower_bound .upper_bound .binary_search

lower_bound和upper_bound算法

STL中的每个算法都非常精妙,接下来的几天我想集中学习一下STL中的算法. ForwardIter lower_bound(ForwardIter first, ForwardIter last,const _Tp& val)算法返回一个非递减序列[first, last)中的第一个大于等于值val的位置. ForwardIter upper_bound(ForwardIter first, ForwardIter last, const _Tp& val)算法返回一个非递减序列[firs

STL源码学习----lower_bound和upper_bound算法

STL中的每个算法都非常精妙,接下来的几天我想集中学习一下STL中的算法. ForwardIter lower_bound(ForwardIter first, ForwardIter last,const _Tp& val)算法返回一个非递减序列[first, last)中的第一个大于等于值val的位置. ForwardIter upper_bound(ForwardIter first, ForwardIter last, const _Tp& val)算法返回一个非递减序列[firs

关于lower_bound( )和upper_bound( )的常见用法

lower_bound( )和upper_bound( )都是利用二分查找的方法在一个排好序的数组中进行查找的. 在从小到大的排序数组中, lower_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,找到返回该数字的地址,不存在则返回end.通过返回的地址减去起始地址begin,得到找到数字在数组中的下标. upper_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于num

关于lower_bound()和upper_bound()

关于lower_bound()和upper_bound(): 参考:关于lower_bound( )和upper_bound( )的常见用法 注意:查找的数组必须要是排好序的.因为,它们查找的方式也是二分查找,所以,复杂度为log(n) ①从小到大排序 lower_bound(begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,找到并返回该数字的地址,不存在则返回end.通过返回的地址减去起始地址begin,得到找到数字在数组中的下标. up