ztr loves lucky numbers(STL)

ztr喜欢幸运数字,他对于幸运数字有两个要求
1:十进制表示法下只包含4、7
2:十进制表示法下4和7的数量相等
比如47,474477就是
而4,744,467则不是

现在ztr想知道最小的但不小于n的幸运数字是多少

输入描述

有T(1≤n≤105)组数据,每组数据一个正整数n(1≤n≤1018)

输出描述

有T行,每行即答案

输入样例

2
4500
47

输出样例

4747
47

Hint

请尽可能地优化算法,考虑全面
LuckNum.h
#include <iostream>

class LuckNum
{
public:
	int minnum(int n)
	{
		if (n < 47)
			n = 47;
		int tmp = n;
		for (int i = tmp;; i++){
			int array[2] = { 0 };
			tmp = i;
			while (tmp != 0){
				if (tmp % 10 == 4 ){
					array[0]++;
				}
				else if (tmp % 10 == 7){
					array[1]++;
				}
				else
					break;
				tmp /= 10;
			}
			if (tmp == 0){
				if ( array[0] == array[1] )
					return i;
			}
		}
	}
};
Test.cpp
#define _CRT_SECURE_NO_WARNINGS

#include "LuckNum.h"
using namespace std;

int main()
{
	int l = 0;
	scanf("%d", &l);
	while (l<1 || l>100000){
		return -1;
	}
	int *a = new int [l];
	for (int i = 0; i < l; ++i){
		int n = 0;
		scanf("%d", &n);
		a[i] = n;
	}
	LuckNum l1;
	for (int i = 0; i < l; ++i){
		cout << l1.minnum(a[i]) << endl;
	}

	system("pause");
	return 0;
}

运行结果:

可看出运行结果正确,但是for循环中i++似乎不太合理(如下:)

47 74

4477 4747 4774 7447 7474 7744

444777 447477 447747 447774 474774 。。。

所以把i每次加一是不合理的,我们可以进行优化

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

class LuckNum
{
public:
	int minnum(int n)
	{
		if (n < 47)
			n = 47;
		vector<int> a;
		a.push_back(4);
		a.push_back(7);
		while(1){
			sort(a.begin(),a.end());
			while (1){
				int ret = a[0];
				for (int i = 1; i < a.size(); ++i){
					ret =ret * 10 + a[i];
				}
				if (ret >= n){
					return ret;
				}
				if (false == next_permutation(a.begin(), a.end()))
					break;
			}
			a.push_back(4);
			a.push_back(7);
		}
	}
};

运行结果:

我们用到了STL中的next_permutation(),与之对应的还有一个prev_permutation(),

它们都在#include <algorithm>中包含

时间: 2024-10-16 14:41:22

ztr loves lucky numbers(STL)的相关文章

hdu-5676 ztr loves lucky numbers(乱搞题)

题目链接: ztr loves lucky numbers Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) 问题描述 ztr喜欢幸运数字,他对于幸运数字有两个要求 1:十进制表示法下只包含4.7 2:十进制表示法下4和7的数量相等 比如47,474477就是 而4,744,467则不是 现在ztr想知道最小的但不小于n的幸运数字是多少 输入描述 有TT(1≤T≤10?5??)组数据,

hdu 5676 ztr loves lucky numbers(dfs+离线)

Problem Description ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not. Lucky number is

hdu 5676 ztr loves lucky numbers(BC——暴力打表+二分查找)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5676 ztr loves lucky numbers Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 594    Accepted Submission(s): 257 Problem Description ztr loves luck

hdoj ztr loves lucky numbers 5676 (dfs模拟)

ztr loves lucky numbers Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 918    Accepted Submission(s): 389 Problem Description ztr loves lucky numbers. Everybody knows that positive integers ar

hdu 5676 ztr loves lucky numbers

题目链接:hdu 5676 一开始看题还以为和数位dp相关的,后来才发现是搜索题,我手算了下,所有的super lucky number(也就是只含数字4, 7且4, 7的数量相等的数)加起来也不过几万个,可以采用打表的方法来把所有的super lucky number存储起来.因为4,7数量须相等,所以可以用一个二进制数的0,1来代替,先限定4,7数量分别为 i,之后就是求出包含 i 个0和 i 个1的 2*i 位所有这样的二进制数,然后简单转换一下(1->7, 0->4,这样子能从小到大

hdu5676 ztr loves lucky numbers DFS

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=5676 题意: 定义幸运数为:只存在4和7且4和7数量相等的数,给出n,求比>=n的最小幸运数 思路: 因为n最多18位,幸运数最大是10个4,10个7,这种情况特判掉,爆longlong,其他的暴力搜出所有长度从2-18的幸运数,因为最多9个4,9个7,然后二分找出比这个数大的那个数 代码: 1 #include <bits/stdc++.h> 2 using namespace std;

[HDOJ5676]ztr loves lucky numbers(状压枚举,打表,二分)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5676 题意:输入一个正整数n(n <=10^18),求不小于n的只有4和7组成的数,且4和7数量相同 枚举2~18位偶数位的4.7的组合,01分别代表4或7.存下来后排序,二分查询. trick就是LL存不下20位的数,但是n<=10^18,那么只要特判大于777777777444444444的数都输出44444444447777777777就行了. 1 #include <bits/std

Lucky Numbers (easy) CodeForces - 96B

Petya loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not. Lucky number is super lucky if it

C - Lucky Numbers (easy)

Problem description Petya loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not. Lucky number