【POJ 2983】Is the Information Reliable?(差分约束系统)

【POJ 2983】Is the Information Reliable?(差分约束系统)

Is the Information Reliable?

Time Limit: 3000MS   Memory Limit: 131072K
Total Submissions: 12244   Accepted: 3861

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with
N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task
is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station
A
is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station
B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers
N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next
M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange
N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable

Source

POJ Monthly--2006.08.27, Dagger

建立差分约束系统进行求解

存在两种关系

P a b x 表示a在b北边x光年 等价与Pb - Pa = x

想要表示等于 就要转换成 Pb - Pa >= x Pb - Pa <= x

即为 Pb-Pa >= x Pa - Pb >= -x

V a b 表示a在b北边至少一光年 即为Pb - Pa >= 1

用三个公式建立差分约束系统即可 由于可能是多个不连通图 就需要用一个超级源点把他们都链接起来

如果跑最短的过程中没有负环 即说明是合法的关系图 否则Unreliable

代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const double eps = 1e-8;

int dcmp(double x)
{
	return x < -eps? -1: x > eps;
}

struct Edge
{
	int v,w,next;
};

Edge eg[233333];
int head[1010];
int dis[1010];
int cnt[1010];
bool vis[1010];
int n,m,tp;

void Add(int u,int v,int w)
{
	eg[tp].v = v;
	eg[tp].w = w;
	eg[tp].next = head[u];
	head[u] = tp++;
}

bool SPFA()
{
	memset(dis,-INF,sizeof(dis));
	memset(cnt,0,sizeof(cnt));
	memset(vis,0,sizeof(vis));
	vis[0] = 1;
	dis[0] = 0;
	cnt[0]++;
	queue <int> q;
	q.push(0);
	int u,v,w;

	while(!q.empty())
	{
		u = q.front();
		vis[u] = 0;
		q.pop();
		for(int i = head[u]; i != -1; i = eg[i].next)
		{
			v = eg[i].v;
			w = eg[i].w;
			if(dis[v] < dis[u]+w)
			{
				dis[v] = dis[u]+w;
				cnt[v]++;
				if(cnt[v] > n) return false;
				if(!vis[v])
				{
					q.push(v);
					vis[v] = 1;
				}
			}
		}
	}
	return true;
}

int main()
{
	int u,v,w;
	char opt[3];
	while(~scanf("%d%d",&n,&m))
	{
		memset(head,-1,sizeof(head));
		tp = 0;
		while(m--)
		{
			scanf("%s",opt);

			if(opt[0] == 'P')
			{
				scanf("%d%d%d",&u,&v,&w);
				Add(u,v,w);
				Add(v,u,-w);
			}
			else
			{
				scanf("%d%d",&u,&v);
				Add(u,v,1);
			}

		}
		for(int i = 1; i <= n; ++i)
		{
			Add(0,i,0);
		}

		puts(SPFA()? "Reliable": "Unreliable");
	}

	return 0;
}
时间: 2024-08-03 01:52:03

【POJ 2983】Is the Information Reliable?(差分约束系统)的相关文章

POJ 2983 Is the Information Reliable? 差分约束

裸差分约束. //#pragma comment(linker, "/STACK:1024000000,1024000000") #include<cstdio> #include<cstring> #include<cstdlib> #include<algorithm> #include<iostream> #include<sstream> #include<cmath> #include<

POJ 2983 Is the Information Reliable?

/* *POJ 2983 Is the Information Reliable? *差分约束系统 *(1)对于确定信息 P A B X, 有 A - B >= X && A - B <= X 即 B <= A + (-X) && A <= B + X * 即构成边<A, B, -X> 和 <B, A, X> *(2)对于不确定信息 V A B, 有 A - B >= 1, 即 B <= A + (-1) * 即构

POJ 2983 Is the Information Reliable?(差分约束系统)

题目地址:POJ 2983 这题刚上来完全不知道跟差分约束系统有什么关系.....后来发现只要判个负环就可以.. 因为假如有冲突的话会形成一个负环.之所以建图加上一个正值一个负值,是因为这样的话,像1 2 4和1 2 3这样的数据就会形成一个负环.这个方法还是很巧妙的...然后对于V的那些不清楚的位置,就会跟P的那些等式联立形成一个不等式,然后在用最短路判环的过程中就用松弛来解决. 代码如下: #include <iostream> #include <cstdio> #inclu

POJ 2983-Is the Information Reliable?(差分约束系统)

题目地址:POJ 2983 题意:有N个车站.给出一些点的精确信息和模糊信息.精确信息给出两点的位置和距离.模糊信息给出两点的位置.但距离大于等于一.试确定是否全部的信息满足条件. 思路:事实上就是让你推断是否存在负环.好久才看明确.对于精确消息.能够得出两个差分公式:dis[v] <= dist[u] - w  &&  dist[u] <= dist[v] + w.对于模糊信息.能够得出dis[v] <= dis[u] -1. PS:做差分约束感觉还是Bellman_f

POJ训练计划2983_Is the Information Reliable?(差分约束)

解题报告 思路: 求解: p:a-b=x v:a-b>=1 的方程 #include <iostream> #include <cstring> #include <cstdio> #include <queue> #define inf 0x3f3f3f3f using namespace std; struct node { int v,w,next; } edge[220000]; int head[1111],dis[1111],vis[111

POJ 2983 Is the Information Reliable? 信息可靠吗 (差分约束,spfa)

题意:有n个站排成一列,针对每个站的位置与距离关系,现有多个约束条件,约束条件分两种:(1)确定的.明确说明站a距离站b多少个单位距离.(2)不确定的.只知道a在b的左边至少1个单位距离.  根据已知条件,问有没有冲突?不冲突则输出reliable. 思路: 第2种条件比较好确定,如果知道如何用最短路解差分约束的话. 问题在第1种,明确地说明了距离,怎么办?拆成两条式子,比如 dis(a,b)=c,那么可以写成 b-a>=c ,b-a<=c 这样,只要满足这两个条件,原来明确说明的距离也会成立

【poj 2983】Is the Information Reliable? 差分约束

题目:http://poj.org/problem?id=2983 Is the Information Reliable? Time Limit: 3000MS Memory Limit: 131072K Total Submissions: 12535 Accepted: 3943 Description The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Dr

【POJ 1716】Integer Intervals(差分约束系统)

[POJ 1716]Integer Intervals(差分约束系统) Integer Intervals Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13425   Accepted: 5703 Description An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending w

POJ 题目2983 Is the Information Reliable?(差分约束)

Is the Information Reliable? Time Limit: 3000MS   Memory Limit: 131072K Total Submissions: 11859   Accepted: 3742 Description The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defe

【POJ2983】Is the Information Reliable? ——差分约束

题目大意:一天南北线上有n个防御站,给出他们之间的位置关系,问有没有可能存在这样一种位置布置符合所给的位置关系.关系有两种,一种是 P A B X,表示A在B北边X光年的位置,V A B表示A在B北边至少1光年位置. 分析:仍然考虑差分约束,容易想到,若关系为P,则 s[a]-a[b]=c; 变换一下则变成: s[b]-s[a]<=-c; s[a]-a[b]<=c; 若关系为V,则 s[b]-s[a]<=-1; 这样转换之后就变成了求最短路了,注意这道题可能无解,无解即表现为存在负环,判