HDU 5375 Gray code(模拟)

Gray code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 65    Accepted Submission(s): 35

Problem Description

The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical
switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.

Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code
is 1,you can get the point ai.

Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.

Input

The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)

Output

For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most

Sample Input

2
00?0
1 2 4 8
????
1 2 4 8

Sample Output

Case #1: 12
Case #2: 15

Hint

https://en.wikipedia.org/wiki/Gray_code

http://baike.baidu.com/view/358724.htm

Source

2015 Multi-University Training Contest 7

点击打开链接

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<stack>
#include<queue>
#include<map>

#define eps 1e-6
#define INF 0x3f3f3f3f

using namespace std;

char str[200010];
int a[200100];

int main()
{
    int T;
    scanf("%d",&T);
    int k = 0;
    while(T--)
    {
        scanf("%s",str);
        int n = strlen(str);
        int p = 0;
        int pi = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        int flag = 0;
        int sum = 0;
        int minn = 99999;
        int cnt = 0;
        if(str[0] !='?')
        {
            p = str[0] - '0';
            pi = 0;
            if(str[0] == '1')
            {
                sum += a[0];
            }
        }
        else
        {
            for(int j=0; j<n; j++)
            {
                if(str[j]!='?')
                {
                    p = str[j] - '0';
                    sum += a[j];
                    pi = j;
                    minn = min(minn,a[j]);
                    break;
                }
                else
                {
                    cnt++;
                    sum += a[j];
                    minn = min(minn,a[j]);
                }
            }
            if(cnt == n)
            {
                flag = 1;
                printf("Case #%d: %d\n",++k,sum);
                break;
            }
            if(cnt%2 == 1 && p == 1)
            {
                sum = sum - minn;
            }
            else if(cnt%2 == 0 && p == 0)
            {
                sum = sum - minn;
            }
        }
        int pp,pj;
        if(flag == 0)
        {
            for(int i=pi+1;i<n;)
            {
                if(str[i]!='?')
                {
                    if(str[i-1]!='?' && str[i] != str[i-1])
                    {
                        sum += a[i];
                        p = str[i] - '0';
                        pi = i;
                    }
                    i++;
                    continue;
                }
                minn = 99999;
                cnt = 0;
                while(str[i] == '?')
                {
                    sum += a[i];
                    minn = min(minn,a[i]);
                    i++;
                    cnt++;
                    if(i==n)
                    {
                        break;
                    }
                }
                if(i<n)
                {
                    sum += a[i];
                    minn = min(minn,a[i]);
                    pp = str[i] - '0';
                    pj = i;
                    if(p!=pp && cnt%2 == 1)
                    {
                        sum -= minn;
                    }
                    else if(p == pp && cnt%2 == 0)
                    {
                        sum -= minn;
                    }
                    p = pp;
                    pi = pj;
                }
            }
            printf("Case #%d: %d\n",++k,sum);
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

时间: 2024-08-26 00:43:09

HDU 5375 Gray code(模拟)的相关文章

hdu 5375 Gray code(DP)

hdu 5375 Gray code Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed

HDU 5375 Gray code (简单dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5375 题面: Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 626    Accepted Submission(s): 369 Problem Description The reflected binary cod

HDU HDU 5375 Gray code(二进制和格雷码)

Description: The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious outpu

hdu 5375 - Gray code(dp) 解题报告

Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 684    Accepted Submission(s): 402 Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary

HDU 5375——Gray code——————【dp||讨论】

Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 569    Accepted Submission(s): 337 Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary

HDU 5375 Gray code

题意:给出一个二进制数,其中有些位的数字不确定,对于所有对应的格雷码,与一个序列a对应,第i位数字为1时得分a[i],求最大的得分. 解法:一个二进制数x对应的格雷码为x ^ (x >> 1),题解说是个dp……但其实就四种情况……判一下就好了 代码: #include<stdio.h> #include<iostream> #include<algorithm> #include<string> #include<string.h>

hdu 5375 Gray code dp

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; const int N=200000+5; const int inf=1<<24; int dp[N][2],a[N]; char s[2*N]; int main() { int n,m,i,_; scanf("%d",&_); for(int k=1;k<=_;k+

HDU 5375(Gray code-格雷码dp)

Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 860    Accepted Submission(s): 490 Problem Description The reflected binary code, also known as Gray code after Frank Gray, is a binary

HDOJ 5375 Gray code DP

标准格雷码的性质:二进制a1 a2 ... an,对应的格雷码为a1 (a1 xor a2) ... (an-1 xor an) 题目就可以转为O(n)的dp dp[i][j]表示二进制第i位为j时前i位对应最大分数. Gray code Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 298    Accepted Submissio