Box of Bricks最小移动砖块数目

Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I‘ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of
bricks will be divisible by the number of stacks. Thus, it is always possible to
rearrange the bricks such that all stacks have the same height.

The input is terminated
by a set starting with n = 0. This set should not be processed.

Output

For each set,
print the minimum number of bricks that have to be moved in order to make all
the stacks the same height.
Output a blank line
between each set.

Sample Input

6
5 2 4 1 7 5
0

Sample Output

5
#include<stdio.h>
void sort(int *a,int n);
int a[51];
void main()
{
    int n;
    while(scanf("%d",&n)==1 && n!=0)
    {
        int i,j=0,arev=0;
        for(i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                arev+=a[i];
        }
        arev=arev/n;
        sort(a,n);
        while(a[n-1]>arev)
        {
            if(a[n-1]-arev>arev-a[0])
            {
                j+=(arev-a[0]);
                a[n-1]=a[n-1]-(arev-a[0]);
                a[0]=arev;

            }
            else
                if(a[n-1]-arev==arev-a[0])
                {
                    j+=(arev-a[0]);
                    a[n-1]=arev;
                    a[0]=arev;

                }
                else
                {
                    j+=(a[n-1]-arev);
                    a[0]=+a[0]+a[n-1]-arev;
                    a[n-1]=arev;

                }
                sort(a,n);
        }
        printf("%d\n\n",j);

    }

}
void sort(int *a,int n)
{
    int i,j;
    for(i=0;i<n-1;i++)
        for(j=i+1;j<n;j++)
        {
            if(a[i]>a[j])
            {
                int temp=a[i];
                a[i]=a[j];
                a[j]=temp;
            }

        }

}
时间: 2024-08-26 01:58:39

Box of Bricks最小移动砖块数目的相关文章

Box of Bricks(南阳oj)

Box of Bricks 时间限制:1000 ms  |  内存限制:65535 KB 描述 Bob在垒砖块,但是他垒的有些乱,但是他很懒,所以想花费最少的体力来让他垒好的砖块一样高,所以你需要做的就是算出最少需要移动的砖块 输入 多组测试数据,以EOF结束,第一行是一个n(1<=n<=50)表示有n摞砖 第二行是n个正整数k(1<=k<=100)表示每摞砖的砖块数量 输出 对于每组输入数据有两行输出,第一行是一个Case #x,表示x组测试数据,第二行是一句话The minim

HDOJ 1326. Box of Bricks 纯水题

Box of Bricks Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5994    Accepted Submission(s): 2599 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one up

POJ 1477. Box of Bricks 纯水题

Box of Bricks Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19552   Accepted: 7889 Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've buil

zoj 1251 Box of Bricks

Box of Bricks Time Limit: 2 Seconds      Memory Limit: 65536 KB Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice.

杭电 HDU ACM 1326 Box of Bricks

Box of Bricks Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5457    Accepted Submission(s): 2358 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one up

HDU 1326 Box of Bricks(简单数学题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1326 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older siste

1177: 零起点学算法84——Box of Bricks

1177: 零起点学算法84--Box of Bricks Time Limit: 1 Sec  Memory Limit: 32 MB   64bit IO Format: %lldSubmitted: 769  Accepted: 268[Submit][Status][Web Board] Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and

uva 591 Box of Bricks

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. Look, I've built a wall!'', he tells his older sister Alice.Nah, you should make all stacks the same height. Then you would ha

Box of Bricks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5871    Accepted Submission(s): 2549 Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and