General Problem Solving Techniques [Examples]~A

Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.

The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.

One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom.

The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight’s height.”

Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!

Input

The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.

The last test case is followed by a line containing ‘0 0’.

Output

For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’.

Sample Input

2 3

5

4

7

8

4

2 1

5

5

10

0 0

Sample Output

11

Loowater is doomed!

解题思路:按照所给出的数据求出将所有龙全部杀掉所需付的最小金币数量。首先骑士想将龙的头砍掉的必需条件是他的高度不能小于龙的头部的直径。一个骑士最多只能杀掉一条龙,所以当骑士的数量小于龙的数量时,结局只有一个,就是龙将国王杀掉。运用贪心思想,可以将题目解出来,首先将数组进行排序,需要注意的是每一组数据开始时要将数组清零,并且计算杀掉的龙的数量的这个变两也要进行清零。

程序代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=20010;
int a[N],b[N];
int main()
{
    int n,m,i,j,counta;
    while(scanf("%d%d",&n,&m)==2&&n&&m)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<m;i++)
            scanf("%d",&b[i]);
        sort(a,a+n);
        sort(b,b+m);
        counta=0;
        int cnt=0;
        if(n>m) printf("Loowater is doomed!\n");
        else
            {
                for(i=0,j=0;i<n&&j<m;i++,j++)
                {
                    if(a[i]>b[j]) {i--;continue;}
                    else {counta+=b[j];cnt++;}
                    if(i<n-1&&j==m-1) break;
                }
                if(cnt<n)printf("Loowater is doomed!\n");
                else printf("%d\n",counta);
            }
    }
    return 0;
}
时间: 2024-10-07 05:45:21

General Problem Solving Techniques [Examples]~A的相关文章

General Problem Solving Techniques [Intermediate-1]~A - Children&#39;s Game

There are lots of number games for children. These games are pretty easy to play but not so easy to make. We will discuss about an interesting game here. Each player will be given N positive integer. (S)He can make a big integer by appending those in

General Problem Solving Techniques [Intermediate-1]~F - Tian Ji -- The Horse Racing

Here is a famous story in Chinese history. That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others. Both of Tian and the king have three horses in different classes,

General Problem Solving Techniques [Beginner-1]~B

An architect wants to design a very high building. The building will consist of some floors, and each floor has a certain size. The size of a floor must be greater than the size of the floor immediately above it. In addition, the designer (who is a f

General Problem Solving Techniques [Intermediate-1]~G - The Bus Driver Problem

In a city there are n bus drivers. Also there are n morning bus routes and n afternoon bus routes withvarious lengths. Each driver is assigned one morning route and one evening route. For any driver, ifhis total route length for a day exceeds d, he h

General Problem Solving Techniques [Beginner-1]~E

Mohammad has recently visited Switzerland. As he loves his friends very much, he decided to buy some chocolate for them, but as this fine chocolate is very expensive (You know Mohammad is a little BIT stingy!), he could only afford buying one chocola

General Problem Solving Techniques [Beginner-1]~F

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inser

General Problem Solving Techniques [Intermediate-1]~D - Fabled Rooks

We would like to place n rooks, 1 ≤ n ≤ 5000, on a n × nboard subject to the following restrictions• The i-th rook can only be placed within the rectanglegiven by its left-upper corner (xli, yli) and its rightlowercorner (xri, yri), where 1 ≤ i ≤ n,

AST11103 Problem Solving

AST11103 Problem Solving with Programming SkillsAdditional Individual Assignment: Min-Game Programming (40%)Learning Outcomes1. Use common application software and program development tools;2. Analyze simple problems with basic problem solving skills

【POJ 3265】Problem Solving

Problem Solving Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 1645   Accepted: 675 Description In easier times, Farmer John's cows had no problems. These days, though, they have problems, lots of problems; they have P (1 ≤ P ≤ 300) pro