FZU 2034-Password table(模拟)

Problem 2034 Password table

Accept: 424    Submit: 816

Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Do you know password table? A password table is used to protect the security of the online account. When a user needs to login to his/her online account or pay for money, he/she may need to fill in the password according to his/her own password table. For
example, if one user has the following table and the online system requires him/her to input the password of “A4B7D1”, he/she may input “577000”.

 Input

The first line of the input contains an integer T(T≤100), indicating the number of test cases. The first line of each case contains three numbers n(5≤n≤9), m(5≤m≤9) and q(1≤q≤100) representing the length and width of the password table, and the total number
of queries (Look at the password table above, its length is 8 and its width is 5). Each of the following n lines contains m numbers, representing the given password table.

Then, each of the following q lines represents a query with the format of "L1D1L2D2L3D3" (L1, L2 and L3 are letters. D1, D2 and D3 are digits), just like the example in paragraph one.

 Output

For each test case, print a line containing the test case number (beginning with 1). For each query in one test case, please output its corresponding password in one line.

 Sample Input

18 5 294 62 80 00 2479 11 07 80 0332 66 12 89 4857 82 36 69 3254 66 91 54 9312 14 37 92 8352 70 33 89 9559 91 01 80 69A4B7D1E5C3B2

 Sample Output

Case 1:577000931211

 Source

2011年全国大学生程序设计邀请赛(福州)

题意:题目的意思,给出n*m的数组,然后给出e行cas、行数从1编号到n,列数从A到。。给你字符串,求出对应的表中的数据。

用三维数组水水的模拟一下就好了

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
char a[10][10][1010];
int main()
{
    int T,n,m,q,i,j;
    int icase;
    char str[110];
    scanf("%d",&T);
    for(icase=1;icase<=T;icase++){
        scanf("%d %d %d",&n,&m,&q);
        for(i=1;i<=n;i++)
            for(j=0;j<m;j++)
            scanf("%s",&a[i][j]);
        printf("Case %d:\n", icase);
        while(q--){
            scanf("%s",str);
            int len=strlen(str);
            for(i=0;i<len;i+=2){
                printf("%s",a[str[i+1]-'0'][str[i]-'A']);
            }
            puts("");
        }
        }
    return 0;
}
时间: 2024-10-10 02:45:55

FZU 2034-Password table(模拟)的相关文章

FZU Problem 2034 Password table (简单模拟题)

这种简单题做了好长时间,我是不是有点逗? 地址:http://acm.fzu.edu.cn/problem.php?pid=2034 不解释了,自己看吧,练手的好题 上个代码吧 ? 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 #include <stdio.h> #include <string.h> #include <stdlib.h>

HDU 4772 Zhuge Liang&#39;s Password(模拟水)

HDU 4772 Zhuge Liang's Password 题目链接 题意:给定两张牌,可以旋转后重叠,重合后相同数字最多的是密码,求密码 思路:直接模拟记录最大值即可 代码: #include <stdio.h> #include <string.h> #include <algorithm> using namespace std; const int N = 35; int n; int a[N][N], b[N][N]; int solve() { int

FZU 2152 文件系统 (小模拟)

       Problem 2152 文件系统 Time Limit: 1000 mSec    Memory Limit : 32768 KB Problem Description 每个Linux文件具有四种访问权限:可读(r).可写(w).可执行(x)和无权限(-). 利用ls -l命令可以看到某个文件或目录的权限,它以显示数据的第一个字段为准.第一个字段由10个字符组成,如下: -rwxr-xr-x 第1位表示文件类型,-表示文件,d表示目录 2-4位表示文件所有者的权限,u权限 5-

FZU 1893 内存管理 模拟

比赛的时候队友要做这道题…… 他没做出来自己也被误导了…… 也算是个教训 自己还是要有自己的思路…… 又是模拟题…… 网上都是用vector做的 我最近才会stl 怎么会用那么高大上的的东西…… 强力模拟一波内存…… 反正只有100的大小 随意遍历…… 模拟都做不出来 只能说明真的方了…… 只要心态稳定 模拟都是水题…… 1 #include<stdio.h> 2 #include<string.h> 3 int memory[102]; 4 int room[102]; 5 in

#个人赛第七场解题总结# (FZU 1881三角形问题 找规律 &amp;&amp;FZU 1884 排火车 模拟)

链接:click here~~ ,密码:nyist C - 三角形问题 Description 给你一个由无穷个节点组成的三角形(如下图),你的任务很简单--任意给你两个正整数x和y,判断它们是否相邻(重合不是相邻). Input 第一行T,表示T组测试数据,接下来仅有两个32位正整数x 和y. Output 对于每组测试数据,首先输出"Case k:",其中k表示第几组.然后如果x和y相邻,则输出"Yes",否则输出"No". Sample I

Lua用table模拟数组

1 local array = {}; 2 local row1 = {1, 3, 5, 7, 9} 3 local row2 = {2, 4, 6, 8, 10} 4 local row3 = {"I", "love", "lua"} 5 array[1] = row1; 6 array[2] = row2; 7 array[3] = row3 8 print("length = ", #array); 9 for i =

FZU - 2159 - WuYou (模拟= =!)

Problem 2159 WuYou Accept: 78    Submit: 405 Time Limit: 1000 mSec    Memory Limit : 32768 KB  Problem Description 有两个正整数A和B,这两个数的位数相同且不含前缀0.A的一些位不能够确定,用'?'代替.已知A是满足 A < B 的最大的A.求A .  Input 第一行一个整数T(T<=1000),表示有T组数据. 每组数据两行,第一行为A,第二行为B(0 < A,B &l

两句话动态修改table数据并提交到后台

//为所有的input 添加click事件,我将对象的id放入到name属性中,行数放入到alt属性中 $("input").click(function(obj){ //获得当前事件发生的dom对象 var $obj=$(this); //判断是否为修改操作 if($obj.prop("value")=="修改"){ //获得当前操作的行对象 var $table=$("table").get(0).rows[$obj.pr

模拟上传,可自行定义上传按钮的名称和图片。

<table>    <tr>    <td>上传</td>    <td style="width:300px;">                    <div style="position: absolute; z-index: 3; cursor:hand; float:left; width:227px;">              <input id="File