poj3903 Stock Exchange最大上升子序列

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://poj.org/problem?id=3903

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given
a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).

White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend.

For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1

Sample Output

3
1
1

第一种:http://blog.csdn.net/u012860063/article/details/34086819

代码如下:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[100047],dp[100047],n;

int bin(int size,int k)
{
    int l = 1,r = size;
    while(l<=r)
    {
        int mid = (l+r)/2;
        if(k>dp[mid])
            l = mid+1;
        else
            r = mid-1;
    }
    return l;
}

int LIS(int *a)
{
    int i,j,ans=1;
    dp[1] = a[1];
    for(i = 2; i<=n; i++)
    {
        if(a[i]<=dp[1])
            j = 1;
        else if(a[i]>dp[ans])
            j = ++ans;
        else
            j = bin(ans,a[i]);
        dp[j] = a[i];
    }
    return ans;
}
int main()
{
	int i;
	while(~scanf("%d",&n))
	{
		for(i = 1; i <= n; i++)
		{
			scanf("%d",&a[i]);
		}
		int ans = LIS(a);
		printf("%d\n",ans);
	}
	return 0;
}

第二种使用了:lower_bound

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
#define INF 0x3fffffff

int a[100047],dp[100047];

int main()
{
	int t,i;
	while(scanf("%d",&t)!=EOF)
	{
		for(i = 0; i <= t; i++)
			dp[i]=INF;
		for(i = 0; i < t; i++)
		{
			scanf("%d",&a[i]);
		}
		for(i = 0; i < t; i++)
		{
			*lower_bound(dp,dp+t,a[i])=a[i];
		}
		printf("%d\n",lower_bound(dp,dp+t,INF)-dp);
	}
	return 0;
}

附上解释的图片一张:

poj3903 Stock Exchange最大上升子序列

时间: 2024-10-11 18:59:21

poj3903 Stock Exchange最大上升子序列的相关文章

POJ3903 Stock Exchange LIS最长上升子序列

POJ3903 Stock Exchange 1 #include <iostream> 2 #include <cstdio> 3 #include <vector> 4 #include <algorithm> 5 using namespace std; 6 const int maxn = 1e5+5; 7 int a[maxn]; 8 int main() { 9 int n; 10 while (~scanf("%d",&am

poj3903 Stock Exchange(最长上升子序列)

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:id=3903">http://poj.org/problem?id=3903 Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned

poj3903 Stock Exchange 二分+dp

题目地址:http://poj.org/problem?id=3903 题目: Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He fo

POJ3903 Stock Exchange

题目大意:求最长上升子序列-- 思路:看这数据规模,L<=100000,还一个点多组测试数据,O(n2)的是不用指望了,于是要使用O(nlogn)的算法. 说一下该算法:令序列存于数组a中在O(n2)的算法中,我们对于一个f[i]值的确定,需要扫描j=1->i-1的所有a[j]值,并取a[j]<a[i]时的f[j]的最大值.试想如果存在两个个值x与y,满足x<y<i,x<y,且f[x]=f[y],在构建序列的过程中,我们应该选择x还是y?显然,应该是x,因为在a[x]至

POJ - 3903 Stock Exchange(LIS最长上升子序列问题)

E - LIS Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned abo

{POJ}{3903}{Stock Exchange}{nlogn 最长上升子序列}

题意:求最长上升子序列,n=100000 思路:O(N^2)铁定超时啊....利用贪心的思想去找答案.利用栈,每次输入数据检查栈,二分查找替换掉最小比他大的数据,这样得到的栈就是更优的.这个题目确实不错,思路很好 #include <iostream> #include <string> #include <cstring> #include <cstdio> #include <algorithm> #include <memory>

poj 3903 Stock Exchange(最长上升子序列,模版题)

题目 #include<stdio.h> //最长上升子序列 nlogn //入口参数:数组名+数组长度,类型不限,结构体类型可以通过重载运算符实现 //数组下标从1号开始. int bsearch(int a[],int len,int num) { int left=1,right=len; while(left<=right) { int mid=(left+right)/2; if(num<=a[mid]) //若最长不下降子序列,改<= 为 < right=m

POJ3903:Stock Exchange(LIS)

Description The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for

POJ 3903 Stock Exchange LIS

题目链接:http://poj.org/problem?id=3903 题目大意:LIS的nlog(n)写法. 解题思路:dp[i]:=长度为i的最长递增子序列的末尾元素最小值.那么由于dp[i]形成了一个有序的序列,所以可以采用二分的办法. dp[j] = a[i]  dp[j] <= a[j] < dp[j + 1] 代码: 1 const int inf = 0x3f3f3f3f; 2 const int maxn = 1e5 + 5; 3 int a[maxn], n; 4 int d