POJ 1753 Flip Game(枚举+DFS)

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4题意:    每次取一颗黑白棋子对其进行翻转,那么的它的上下左右四个方向的棋子也会跟着翻转。问至少需要操作多少次,可以使棋盘的棋子全为黑色或者白色。题解:    首先可以得出一个结论,那就是操作过程中对每个棋子最多只翻转一次。那么4*4的棋盘最多只操作16次就能得到结果,棋盘的可能情况有2^16种。我们可以DFS(递归)求解。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
bool maze[5][5];
int st;
int dx[5]={0,0,0,1,-1},dy[5]={0,1,-1,0,0};
bool flag;
bool check()//判断棋盘是否全为同色
{
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
        {
            if(maze[i][j]!=maze[0][0])
                return false;
        }
    return true;
}
void flip(int x,int y)//对棋子进行翻转
{
    for(int i=0;i<5;i++)
    {
        int nx=x+dx[i],ny=y+dy[i];
        if(0<=nx&&nx<4&&0<=ny&&ny<4)
            maze[nx][ny]=!maze[nx][ny];
    }
}
void dfs(int x,int y,int k)
{
    if(k==st&&check())//k为翻转的次数
    {
        flag=true;
        return ;
    }
    if(flag||x==4)
        return ;
    flip(x,y);
    if(y<3)
        dfs(x,y+1,k+1);
    else
        dfs(x+1,0,k+1);
    flip(x,y);//状态回溯
    if(y<3)
        dfs(x,y+1,k);
    else
        dfs(x+1,0,k);
}
int main()
{
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
        {
            char x;
            cin>>x;
            if(x==‘b‘)
                maze[i][j]=true;
            else
                maze[i][j]=false;
        }
    flag=false;
    for(st=0;st<=16;st++)//枚举需要翻转的次数
    {
        dfs(0,0,0);
        if(flag)
            break;
    }
    if(flag)
        cout<<st<<endl;
    else
        cout<<"Impossible"<<endl;
    return 0;
}
 
时间: 2024-08-04 04:50:43

POJ 1753 Flip Game(枚举+DFS)的相关文章

[ACM] POJ 1753 Flip Game (枚举,BFS,位运算)

Flip Game Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 29921   Accepted: 12975 Description Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the

POJ 1753 Flip Game(dfs+枚举)

POJ 1753 题意: 输入一个4*4的图像,由黑白两色组成,定义一种操作为:改变某个格子内小球的颜色(黑变白,白变黑),同时其上下左右的格子内小球也将变色.求最少多少次操作能使之成为纯色图案. 思路: 对一个格子操作偶数次等于没有操作,操作奇数次等于操作一次,所以答案在0~16以及impossible之间. 从n=0开始枚举n次操作可能的组成情况,即操作哪几个格子,若某种组合能变图案为纯色则停止. 由于总组合数达到2^16,故枚举组合情况可以用dfs来进行回溯枚举. //还有一种方法是位运算

POJ 1753 Flip Game (DFS + 枚举)

题目:http://poj.org/problem?id=1753 这个题在开始接触的训练计划的时候做过,当时用的是DFS遍历,其机制就是把每个棋子翻一遍,然后顺利的过了,所以也就没有深究. 省赛前一次做PC2遇到了几乎一模一样的题,只不过是把棋盘的界限由4X4改为了5X5,然后一直跑不出结果来,但是当时崔老湿那个队过了,在最后总结的时候,崔老湿就说和这个题一样,不过要枚举第一行进行优化. 我以为就是恢复第一行然后第二行以此类推,不过手推一下结果是6不是4,就知道这个有问题. 问了崔老湿,问了+

POJ 1753 Flip Game (高斯消元 枚举自由变元求最小步数)

题目链接 题意:4*4的黑白棋,求把棋全变白或者全变黑的最小步数. 分析:以前用状态压缩做过. 和上题差不多,唯一的不同是这个终态是黑棋或者白棋, 但是只需要把给的初态做不同的两次处理就行了. 感觉现在还只是会套模板,不能独立的思考,好伤心.... 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <cstdlib> 5 #include <cmath&g

poj 1753 Flip Game (bfs + 枚举)

链接:poj 1753 题意:这是翻棋游戏,给定4*4棋盘,棋子一面为黑色(用b表示),另一面为白色(用w表示),问至少要几步可以将棋子翻为全黑或者全白,如不能达到目的,输出"Impossible " 翻转规则:可以选定16个棋子中的任意一个,将其本身以及上下左右相邻的翻转过来 分析:其实每格棋子最多只可以翻转一次(实际是奇数次,但与翻转一次状态一样),只要其中一格重复翻了2次(不论是连续翻动还是不连翻动),那么它以及周边的棋子和没翻动时的状态是一致的,与最初状态未翻转一样,由此就可以

POJ 1753 Flip Game (迭代递归)

POJ 1753,题目链接http://poj.org/problem?id=1753. POJ 1753,题目链接http://poj.org/problem?id=1753. 总共有16个点.对某个点选择操作或者不操作.一共有2^16次方种可能. 从前往后枚举,保证不重复. 1 #include<stdio.h> 2 #include<string.h> 3 #include<math.h> 4 #include<algorithm> 5 #includ

poj 1753 Flip Game(bfs状态压缩 或 dfs枚举)

Description Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you f

poj 1753 flip[ 枚举 ]

传送门:http://poj.org/problem?id=1753 思路:16格用16位的int表示,然后用bfs的层次关系枚举: 代码: #include<iostream> #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<queue> #include<stack> #include<map> #de

POJ 1753 Flip Game (DFS)

Flip Game Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 32104   Accepted: 13988 Description Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the