POJ 1469 COURSES //简单二分图

COURSES

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17211   Accepted: 6769

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

...

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each
two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

Southeastern Europe 2000

#include <stdio.h>
#include <string.h>

bool map[105][305];	//图,记录 第i个同学 选修 第j个课程
bool visit[305];	//记录该点是否被访问过
int r_jilu[305];	//记录右边项 对应的 左边点

bool dfs(int n, int r);

int main()
{
	int t;
	int l, r;
	int ans, k, v;
	int i;

	scanf("%d", &t);
	while(t--)
	{
		scanf("%d%d", &l, &r);

		memset(map, false, sizeof(map));
		for(i=1; i<=r; i++)
			r_jilu[i] = -1;		//初始化

		for(i=1; i<=l; i++)
		{
			scanf("%d", &k);
			while(k--)
			{
				scanf("%d", &v);
				map[i][v] = true;
			}
		}

		ans = 0;
		for(i=1; i<=l; i++)
		{
			memset(visit, false, sizeof(visit));
			if( dfs(i, r) )
				ans++;
		}
		if(ans == l)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}
bool dfs(int n, int r)	// 匈牙利算法
{
	int i;
	for(i=1; i<=r; i++)
	{
		if(map[n][i]==true && visit[i]==false)	//当此点为左边对应的点,并且没被访问过时
		{
			visit[i] = true;
			if(r_jilu[i]==-1 || dfs(r_jilu[i], r))//如果i未在前一个匹配M中,或者i在匹配M中,但是从与i相邻的节点出发可以有增广路径
			{
				r_jilu[i] = n;		//更新
				return true;
			}
		}
	}
	return false;
}

POJ 1469 COURSES //简单二分图

时间: 2024-08-05 08:46:30

POJ 1469 COURSES //简单二分图的相关文章

POJ 1469 COURSES【二分图最大匹配】

分析:二分图最大匹配 代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <vector> 5 using namespace std; 6 7 const int maxn = 305; 8 9 int n; 10 11 vector<int> G[maxn]; 12 int vis[maxn]; 13 int Link[maxn]; 14

poj 1469 COURSES (二分图匹配)

Language: Default COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 18290   Accepted: 7204 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine

POJ 1469 COURSES 二分图最大匹配

就是判断一下是不是每一个课程都能找到自己的代表人,做一遍最大匹配看看匹配数是否等于p即可 #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cs

poj 1469 COURSES 解题报告

题目链接:http://poj.org/problem?id=1469 题目意思:略 for 循环中遍历的对象要特别注意,究竟是遍历课程数P 还是 学生数N,不要搞混! 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 6 const int maxn = 300 + 5; 7 int match[maxn], map[maxn][maxn];

poj 1469 COURSES (二分匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 16877   Accepted: 6627 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

poj 1469 COURSES(二分匹配模板)

题目链接:http://poj.org/problem?id=1469 COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17135   Accepted: 6730 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your tas

poj 1469 COURSES(匈牙利算法模板)

http://poj.org/problem?id=1469 COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19419   Accepted: 7642 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is

POJ 1469 COURSES (二分图最大匹配 匈牙利算法)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 18892   Accepted: 7455 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

POJ - 1469 COURSES [二分图匈牙利算法]

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 24919   Accepted: 9679 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss