将两个字符串连接起来

#import <Foundation/Foundation.h>

int main(int argc, const char * argv[]) {

@autoreleasepool {

NSString *[email protected]"pear",*[email protected]"apple";

NSString *newstr=[[NSString alloc]initWithFormat:@"拼接后%@ %@",str1,str2];

NSString *newstr1=[str1 stringByAppendingString:str2];

NSString *newstr2=[str1 stringByAppendingFormat:@"-%@",str2];

NSLog(@"%@",newstr2);

}

return 0;

}

时间: 2024-11-03 21:53:38

将两个字符串连接起来的相关文章

7.13编写一程序将两个字符串连接起来,不使用stracat函数

输入的时候,注意字符串的长度. #include<stdio.h>//7.13 编写一个程序,将两个字符串连接起来,不要用strcat函数.  int main()  {      char c1[20],c2[20];      int i=0,j=0;      printf("Input string1:");      gets(c1);      printf("Input string2:");      gets(c2);      whi

实现两个字符串连接

char *Mystrcat(char*str1, char* str2){ if (str1 == NULL || str2 == NULL)  return NULL; char*temp = str1;    //申请指向字符的指针 while (*str1 != '\0') {  str1++;  //让指针指向字符串的尾部 } while (*str2 != '\0') {  *str1++ = *str2++;    //从尾部开始循环赋值 } *str1 = '\0'; retur

写一函数,将两个字符串连接

题目描述 输入 两行字符串 输出 链接后的字符串 样例输入 123 abc 样例输出 123abc #include <iostream>#include <string.h>using namespace std;int main(){ char a1[1000],a2[1000]; gets(a1); gets(a2); cout<<strcat(a1,a2); return 0;}

两个字符串连接问题

6sgn0m乖滴堑菜膛聊<http://weibo.com/p199p500p/230927983048043194486784> 7u7x2t拇颊煞蚀计节<http://weibo.com/p299p699p/230927982998619974012928> v98rwz谫抡茄眉试妥<http://weibo.com/p188p367p/230927982969078819856384> 1yu479雍涌豪泻阑爸<http://weibo.com/p20180

JavaScript基础 使用+号连接两个字符串

镇场诗: 清心感悟智慧语,不着世间名与利.学水处下纳百川,舍尽贡高我慢意. 学有小成返哺根,愿铸一良心博客.诚心于此写经验,愿见文者得启发.------------------------------------------ code: 1 <!DOCTYPE html> 2 <html> 3 <head> 4 <meta http-equiv="Content-Type" content="text/html; charset=ut

Python 连接MongoDB并比较两个字符串相似度的简单示例

本文介绍一个示例:使用 pymongo 连接 MongoDB,查询MongoDB中的 字符串 记录,并比较字符串之间的相似度. 一,Python连接MongoDB 大致步骤:创建MongoClient---> 获取 DataBase --->获取Collection,代码如下: client = MongoClient(host="127.0.0.1", port=10001) db = client['database_name'] db.authenticate(nam

Python_字符串连接

1 #join() 与split()相反,join()方法用来将列表中多个字符串进行连接,并在相邻两个字符串之间插入指定字符 2 li=['apple','peach','banana','pear'] 3 sep=',' 4 s=sep.join(li) 5 print(s) #使用逗号作为连接符 6 s1=':'.join(li) #使用冒号作为连接符 7 print(s1) 8 s2=''.join(li) 9 print(s2) 10 #使用split()和join()方法可以删除字符串

java中+(加号或字符串连接)运算顺序的问题

由于java中+(加号或字符串连接)的运算顺序是从左向右的,所以一下程序的输出会得到两个不同的结果 1 public class Test { 2 public static void main(String[] args) { 3 System.out.println("ddd"+7+5); 4 System.out.println(7+5+"ddd"); 5 6 } 7 } 结果为ddd75 12ddd

Oracle字符串连接的方法

Oracle数据库中,使用“||”进行字符串连接,下面就让我们一起了解一下Oracle数据库中字符串连接的方法,希望对您能有所帮助. 和其他数据库系统类似,Oracle字符串连接使用“||”进行字符串拼接,其使用方式和MSSQLServer中的加号“+”一样. 比如执行下面的SQL语句:SELECT '工号为'||FNumber||'的员工姓名为'||FName FROM T_EmployeeWHERE FName IS NOT NULL 除了“||”,Oracle还支持使用CONCAT()函数