UVA 409-Excuses, Excuses!(模拟)

Excuses, Excuses!

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld
& %llu

Submit Status

Description

 Excuses, Excuses! 

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has
asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data.

  • Line 1 of each set will contain exactly two integers. The first number (  ) defines the number of keywords to be used in the
    search. The second number (  ) defines the number of excuses in the set to be searched.
  • Lines 2 through K+1 each contain exactly one keyword.
  • Lines K+2 through K+1+E each contain exactly one excuse.
  • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (  ) and
    will occupy columns 1 through L in the input line.
  • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
  • Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list.

  • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
  • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
  • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst
excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!

题意:给两个数m,n。即m个关键字,n句借口,哪个借口包含的的关键字最多,就输出当前的借口

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
using namespace std;
char key[20][20];
char ex[20][110];
int cnt[110];
int n,m;
int find(char *str)
{
    char a[110];
    int i,j=0;
    int count = 0;
    for(i=0;str[i]!='\0';i++)
    {
        if(str[i]>='A'&&str[i]<='Z'||str[i]>='a'&&str[i]<='z')//关键字都是小写,所以把借口里面的大写字母全部转换成小写字母
        {
            if(str[i]>='A'&&str[i]<='Z')
            {
                a[j]=str[i]+32;
            }
            else
                a[j]=str[i];
            j++;
        }
        else//因为语句中包含其他的字符,所以当是其他字符的时候
        {
            a[j] = '\0';//意味着重新换成另一个单词
            for(j = 0; j < m; j++)
            {
                if(strcmp(a,key[j]) == 0)
                {
                    count++;
                }
            }
            j = 0;//拿出下一个单词;
        }
    }
    return count;
}

int main()
{
    int i;
    int t=1;
    int maxx;
    while(~scanf("%d %d",&m,&n))
    {
        getchar();
        maxx=0;
        memset(cnt,0,sizeof(cnt));
        for(i=0; i<m; i++)
            gets(key[i]);
        for(i=0; i<n; i++)
            gets(ex[i]);
        for(i=0; i<n; i++)
            cnt[i]=find(ex[i]);
        for(i=0; i<n; i++)
            maxx=max(maxx,cnt[i]);
        printf("Excuse Set #%d\n",t++);
        for(i=0; i<n; i++)
        {
            if(maxx==cnt[i])
            {
                puts(ex[i]);
            }
        }
        printf("\n");
    }
    return 0;
}
时间: 2024-08-05 12:05:32

UVA 409-Excuses, Excuses!(模拟)的相关文章

UVA之409 - Excuses, Excuses!

 Excuses, Excuses!  Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write

Excuses, Excuses! UVA 409

#include <stdio.h> #include <string.h> #include <ctype.h> int get_word(int); void convert_word(); int str_cmp(); char key[100][100];//保存关键词 char word[100];//保存从excuse中提取出来的词 char exc[100][100];//保存excuses int cnt[100];//记录每个excuse中keywor

UVA (POJ 1598)Excuses, Excuses!

Excuses, Excuses! Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Description  Excuses, Excuses!  Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid ser

【HDOJ】1606 Excuses, Excuses!

简单字符串. 1 #include <cstdio> 2 #include <cstring> 3 4 #define MAXLEN 105 5 #define MAXN 25 6 7 char keys[MAXN][MAXN]; 8 char lines[MAXN][MAXLEN]; 9 int nums[MAXN]; 10 11 int main() { 12 int case_n = 0; 13 int n, m, max; 14 int i, j, k, v; 15 cha

Excuses, Excuses! (map , string )

Excuses, Excuses! Problem Description Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has as

Uva - 1513 Moive collection ( 模拟栈 + 树状数组基本操作 )

Uva - 1513 Moive collection ( 模拟栈 + 树状数组基本操作 ) 题意: 一个书架,原来所有的书都是按顺序摆好的,书的编号从1开始到n 操作: 取出一本书,统计在这本书之前有多少本书,统计完之后,将这本书放在书架的第一位. 如:  1 2 3 4 5取4   4 1 2 3 5 (取之前,有3本书在4前面,取完后,将4放在栈顶)取4   4 1 2 3 5 (取之前,有0本书在4前面,取完后,将4放在栈顶)取2   2 4 1 3 5 (取之前,有2本书在2前面,取完

uva 1156 - Pixel Shuffle(模拟+置换)

题目链接:uva 1156 - Pixel Shuffle 题目大意:给定一个N*N的黑白位图,有7种操作,并且对应在指令后加上'-'即为操作的逆,给定N和一系列操作,(从最后一个开始执行),问说这一套指令需要执行多少次才能形成循环. 解题思路:模拟指令执行后获得一个置换,分解成若干的循环,各个循环长度的最小公倍数即使答案. #include <cstdio> #include <cstring> #include <algorithm> using namespace

POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!【文本】

Excuses, Excuses! Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 4701 Accepted: 1602 Description Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce t

UVA 409 Excuses, Excuses! (字符处理)

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will

UVA 409 Excuses, Excuses!

题目大意:给定几个keywords,再给几个excuses,要求从中找出keywords最多的excuse.如果有几个excuse一样多,就都输出来.其中要求出现的keyword是有条件的: If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword ``occurs" in an excuse if and only if it ex