FJNU-1159 Fat Brother’s new way

Description

I bet, except Fat Brothers, all of you don’t like strange way to show integers , he is really like this way to showing integers:

1 -> ‘A’

2 -> ‘B’

…….

26 -> ‘Z’

27 -> ‘AA’

28 -> ‘AB’

…….

Unfortunately, Fat Brother’s mathematics is poor, so he needs your help, he will give you some integers, and you must transform it with Fat Brother’s way.

Input

Input starts with an integer T(T <= 10000), denoting the number of test case.

For each test case, an integers n(1 <= n <= 2147483647) is given.

Output

For each case, output the corresponding string with upper-case letters.

Sample Input 

3

17311

2068

37

Sample Output

YOU

CAN

AK


#include <iostream>
using namespace std;

int main(void)
{
    char opt[20];
    int t, a, i;

    cin >> t;
    while (t--)
    {
        cin >> a;
        for (i = -1; a--; a /= 26)
        {
            opt[++i] = ‘A‘ + a % 26;
        }
        while (~i)
        {
            putchar(opt[i--]);
        }
        cout << endl;
    }
    return 0;
}
时间: 2024-12-06 10:01:01

FJNU-1159 Fat Brother’s new way的相关文章

FJNU 1154 Fat Brother And His Love(胖哥与女神)

FJNU 1154 Fat Brother And His Love(胖哥与女神) Time Limit: 2000MS   Memory Limit: 257792K [Description] [题目描述] As we know, fat Brother and his goddess is in a same city. The city is consist of N locations and the N locations is connected by M roads. Fat B

FJNU 1155 Fat Brother’s prediction(胖哥的预言)

FJNU 1155 Fat Brother’s prediction(胖哥的预言) Time Limit: 1000MS   Memory Limit: 257792K [Description] [题目描述] Fat Brother is a famous prophet, One day he get a prediction that disaster will come after X days. He is too nervous that sudden die. Fortunatel

FJNU 1157 Fat Brother’s ruozhi magic(胖哥的弱智术)

FJNU 1157 Fat Brother’s ruozhi magic(胖哥的弱智术) Time Limit: 1000MS   Memory Limit: 257792K [Description] [题目描述] Fat Brother is a powerful magician. Both he and his enemy has N soldiers and each soldier has IQ. When two soldier is in PK, the one whose IQ

FJNU 1156 Fat Brother’s Gorehowl(胖哥的血吼)

FJNU 1156 Fat Brother’s Gorehowl(胖哥的血吼) Time Limit: 1000MS   Memory Limit: 257792K [Description] [题目描述] Fat Brother is a Great warrior(战士) and he has a powerful weapons named “Gorehowl”. Firstly it can cause 7 damage points to the other side, but it

FJNU 1153 Fat Brother And XOR(胖哥与异或)

Time Limit: 1000MS   Memory Limit: 257792K [Description] [题目描述] Fat brother had master ACM, recently he began to study the operation of XOR (the operation “^”). He thought of a very interesting question: select arbitrary k positive integers from the

FJNU 1152 Fat Brother And Integer(胖哥与整数)

Time Limit: 1000MS   Memory Limit: 257792K [Description] [题目描述] Fat brother recently studied number theory, him came across a very big problem — minimum does not appear positive integer. Fat brother get n positive integers, he needs to find out the l

FJNU-1152 Fat Brother And Integer

Description Fat brother recently studied number theory, him came across a very big problem - minimum does not appear positive integer. Fat brother get n positive integers, he needs to find out the least a positive integer and the positive integer is

FZU 2150 Fire Game(点火游戏)

p.MsoNormal { margin: 0pt; margin-bottom: .0001pt; text-align: justify; font-family: Calibri; font-size: 10.5000pt } h2 { margin-top: 5.0000pt; margin-bottom: 5.0000pt; text-align: left; font-family: 宋体; font-weight: bold; font-size: 18.0000pt } h3 {

FZU 2148 Moon Game 判断凸边形

点击打开链接 Problem 2148 Moon Game Accept: 512    Submit: 1419 Time Limit: 1000 mSec    Memory Limit : 32768 KB  Problem Description Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a k