Anniversary party
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5917 Accepted Submission(s): 2692
Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests’ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
题意:有一个宴会要邀请一个公司的人来,这个公司有严格的等级制度,就是一颗树,现在树的每个节点都有一个(rating)权值,要求一个职员不能和他的直属boss(父节点)同时出现,求能够出现的最大的权值和。
思路:因为考虑到前面节点的最大值就要考虑到后面字节点的最大值,用dp。
状态方程:dp[i]【0】(代表第i个节点的不出现), dp[i][1]表示出现.
那么dp[i][0] += max(dp[j][0], dp[j][1]);
dp[i][1] += dp[j][0]; 其中j是i的子节点。
代码(HDoj的数据不是特别水不用vector会TL):
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int M = 6e3+5;
int dp[M][2], fat[M], n;
bool vis[M];
vector<int > map[M];
void dfs(int u){
vis[u] = 1;
for(int i = 0; i < map[u].size(); ++ i){
int v = map[u][i];
if(!vis[v]){
dfs(v);
dp[u][0] += max(dp[v][0], dp[v][1]);
dp[u][1] += dp[v][0];
}
}
}
int main(){
while(scanf("%d", &n) == 1){
for(int i = 1; i <= n; ++i){
dp[i][0] = dp[i][1] = 0;
fat[i] = i;
vis[i] = 0;map[i].clear();
}
for(int i = 1; i <= n; ++i){
scanf("%d", &dp[i][1]);
}
int l, k;
while(scanf("%d%d", &l, &k), l||k){
if(fat[l] == l){
fat[l] = k;
map[k].push_back(l);
}
}
int root = 1;
while(root != fat[root]) root = fat[root];
//memset(vis, 0, sizeof(vis));
dfs(root);
printf("%d\n", max(dp[root][0], dp[root][1]));
}
return 0;
}