POJ 3273 Monthly Expense 二分答案

Monthly Expense

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13281   Accepted: 5362

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over
the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题解

又是一个二分题。题目的意思是说,在接下来的n天里,Farmer John每天需要花money[i]钱,把这些天分成k份(每份都是连续的天),要求每份的和尽量少,输出这个最小的和。

依旧是二分答案二分答案。。。但是特别奇怪,如果用一个res维护当前可行值就会WA,而且R也得用r = mid 而不是r = mid - 1。。。

这个二分真是难

代码示例

/****
	*@author    Shen
	*@title     poj 3273
	*/

#include <cstdio>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

int n, k;
int r, v[100005];
int maxa = 0, mina = 0;

bool test(int x)
{
    int sum = 0, cnt = 1;
    for (int i = 0; i < n; i++)
    {
        if (sum + v[i] <= x)
            sum += v[i];
        else
            cnt++, sum = v[i];
    }
    //printf("\t%s with x = %d, result is that sum = %d.\n", __func__, x, sum);
    return cnt <= k;
}

int Bsearch(int l, int r)
{
    while (l < r)
    {
        int mid = (r + l) / 2;
        //printf("l = %d, r = %d, mid = %d.\n", l, r, mid);
        if (test(mid))
            r = mid;
        else
            l = mid + 1;
    }
    return l;
}

void solve()
{
    maxa = mina = 0;
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &v[i]);
        maxa += v[i];
        mina = max(mina, v[i]);
    }
    int ans = Bsearch(mina, maxa);
    printf("%d\n", ans);
}

int main()
{
    while (~scanf("%d%d", &n, &k))
        solve();
    return 0;
}

POJ 3273 Monthly Expense 二分答案

时间: 2024-10-25 05:44:30

POJ 3273 Monthly Expense 二分答案的相关文章

POJ 3273 Monthly Expense (二分枚举)

Monthly Expense Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 15822   Accepted: 6321 Description Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and r

poj 3273 Monthly Expense 二分

题目链接:http://poj.org/problem?id=3273 因为规定天数连续 所以从前到后贪心即可 裸二分 二分专题的特点: 1.很容易写 2.很容易写错 所以要注意: 上下界的取值是否太大太小 加起来会不会爆 最后能不能跳出循环 当对中值进行判定以后 应该如何调整lb和ub 注意lb那个地方应该赋值为mid+1 否则会T到死 #include <cstdio> #include <cstdlib> #include <ctime> #include <

[ACM] POJ 3273 Monthly Expense (二分解决最小化最大值)

Monthly Expense Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14158   Accepted: 5697 Description Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and r

二分搜索 POJ 3273 Monthly Expense

题目传送门 1 /* 2 题意:分成m个集合,使最大的集合值(求和)最小 3 二分搜索:二分集合大小,判断能否有m个集合. 4 */ 5 #include <cstdio> 6 #include <algorithm> 7 #include <cstring> 8 #include <cmath> 9 using namespace std; 10 11 const int MAXN = 1e5 + 10; 12 const int INF = 0x3f3f

POJ 3273 Monthly Expense 【二分答案】

题意:给出n天的花费,需要将这n天的花费分成m组,使得每份的和尽量小,求出这个最小的和 看题目看了好久不懂题意,最后还是看了题解 二分答案,上界为这n天花费的总和,下界为这n天里面花费最多的那一天 如果mid>=m,说明mid偏小,l=mid+1, 如果mid<m,说明mid偏大,r=mid, 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include <cmath>

POJ 3273 Monthly Expense(二分)

Monthly Expense Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 17465   Accepted: 6961 Description Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and r

poj 3273 Monthly Expense

题目链接:http://poj.org/problem?id=3273 题目大意:给你n个数把他们连续的分成m组,问最小的那一组的最大值. 思路:用最小的那一个元素和总和进行二分...然后判断最小那组为mid时,分组的个数. #include <cstdio> #include <iostream> #include <algorithm> #include <cstring> #include <cmath> using namespace s

poj 3273 Monthly Expense(二分搜索之最大化最小值)

Description Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the

poj 3273 Monthly Expence 简单二分

1 /** 2 大意: 有连续的n天,每一天有一定的花费,将其分成m份,每一份占一天或者连续的几天,求这m份中的最大值 3 思路: 二分其最大上限,看在此最大上线,能分成多少份,若大于m份,说明上限过小,需要扩大上限 4 若小于m份,则说明,下限过大,需要缩小上限. 5 **/ 6 #include <iostream> 7 8 using namespace std; 9 int c[100010]; // 记录,每天的花费 10 int main() 11 { 12 int n,m; 13